summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-02-25 17:01:49 +0000
committerJeroen Roovers <jer@gentoo.org>2009-02-25 17:01:49 +0000
commit05eefc398d243570dd6435a08ba0f3eff258e6ff (patch)
tree5747e710bc5979bc07593f92245bb0d91169133c /x11-terms/yeahconsole
parentppc stable, bug #252830 (diff)
downloadgentoo-2-05eefc398d243570dd6435a08ba0f3eff258e6ff.tar.gz
gentoo-2-05eefc398d243570dd6435a08ba0f3eff258e6ff.tar.bz2
gentoo-2-05eefc398d243570dd6435a08ba0f3eff258e6ff.zip
Initial commit, thanks to Martín R. Dapás (bug #120112, partly based on the ebuilds attached there).
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'x11-terms/yeahconsole')
-rw-r--r--x11-terms/yeahconsole/ChangeLog12
-rw-r--r--x11-terms/yeahconsole/files/yeahconsole-0.3.4-make.patch28
-rw-r--r--x11-terms/yeahconsole/metadata.xml9
-rw-r--r--x11-terms/yeahconsole/yeahconsole-0.3.4.ebuild39
4 files changed, 88 insertions, 0 deletions
diff --git a/x11-terms/yeahconsole/ChangeLog b/x11-terms/yeahconsole/ChangeLog
new file mode 100644
index 000000000000..03cff292271c
--- /dev/null
+++ b/x11-terms/yeahconsole/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for x11-terms/yeahconsole
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/yeahconsole/ChangeLog,v 1.1 2009/02/25 17:01:49 jer Exp $
+
+*yeahconsole-0.3.4 (25 Feb 2009)
+
+ 25 Feb 2009; Jeroen Roovers <jer@gentoo.org>
+ +files/yeahconsole-0.3.4-make.patch, +metadata.xml,
+ +yeahconsole-0.3.4.ebuild:
+ Initial commit, thanks to Martín R. Dapás (bug #120112, partly based on
+ the ebuilds attached there).
+
diff --git a/x11-terms/yeahconsole/files/yeahconsole-0.3.4-make.patch b/x11-terms/yeahconsole/files/yeahconsole-0.3.4-make.patch
new file mode 100644
index 000000000000..6697e71e96ec
--- /dev/null
+++ b/x11-terms/yeahconsole/files/yeahconsole-0.3.4-make.patch
@@ -0,0 +1,28 @@
+--- yeahconsole-0.3.4/Makefile.orig 2006-01-14 16:54:05.000000000 +0100
++++ yeahconsole-0.3.4/Makefile 2009-02-25 17:12:05.000000000 +0100
+@@ -1,6 +1,4 @@
+ TARGET = yeahconsole
+-CC = gcc
+-#CC = cc
+ INSTALL = install
+
+ PREFIX = /usr/local
+@@ -8,17 +6,15 @@
+ LIBS = -lX11
+ INCLUDES = -I/usr/X11R6/include
+ LIB_DIRS = -L/usr/X11R6/lib
+-FLAGS = -Os -Wall
+
+ OBJECTS := yeahconsole.o
+ SOURCES := yeahconsole.c
+
+ $(TARGET): $(OBJECTS)
+ $(CC) $(DEFINES) $(INCLUDES) $(LIB_DIRS) $(LIBS) -o $@ $<
+- strip $@
+
+ $(OBJECTS): $(SOURCES)
+- $(CC) $(FLAGS) $(DEFINES) $(INCLUDES) $(LIB_DIRS) -c -o $@ $<
++ $(CC) $(CFLAGS) $(DEFINES) $(INCLUDES) $(LIB_DIRS) -c -o $@ $<
+
+ clean:
+ rm -rf $(TARGET) $(OBJECTS)
diff --git a/x11-terms/yeahconsole/metadata.xml b/x11-terms/yeahconsole/metadata.xml
new file mode 100644
index 000000000000..9134efa10c60
--- /dev/null
+++ b/x11-terms/yeahconsole/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>jer@gentoo.org</email>
+ <name>Jeroen Roovers</name>
+</maintainer>
+</pkgmetadata>
diff --git a/x11-terms/yeahconsole/yeahconsole-0.3.4.ebuild b/x11-terms/yeahconsole/yeahconsole-0.3.4.ebuild
new file mode 100644
index 000000000000..62944ddfcad2
--- /dev/null
+++ b/x11-terms/yeahconsole/yeahconsole-0.3.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/yeahconsole/yeahconsole-0.3.4.ebuild,v 1.1 2009/02/25 17:01:49 jer Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="yeahconsole turns an xterm or rxvt-unicode into a game-like console"
+HOMEPAGE="http://phrat.de/yeahtools.html"
+SRC_URI="http://phrat.de/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}-make.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "make failed"
+}
+
+src_install() {
+ dodir /usr/bin
+ emake PREFIX="${D}"/usr install || die "emake install failed"
+ dodoc README
+}
+
+pkg_postinst() {
+ elog "Do not forget to emerge a terminal emulator (perhaps x11-terms/xterm"
+ elog "or x11-terms/rxvt-unicode) or ${PN} will not work ;-)."
+}