summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2011-05-19 20:35:55 +0000
committerAlex Alexander <wired@gentoo.org>2011-05-19 20:35:55 +0000
commit9ed69ef253a0757f3241d926b3fbdab7053fe53e (patch)
tree6520898f114fb5c7072136a76e84d20453a0b26f /x11-terms/rxvt-unicode
parentEAPI4 (diff)
downloadgentoo-2-9ed69ef253a0757f3241d926b3fbdab7053fe53e.tar.gz
gentoo-2-9ed69ef253a0757f3241d926b3fbdab7053fe53e.tar.bz2
gentoo-2-9ed69ef253a0757f3241d926b3fbdab7053fe53e.zip
EAPI 4, added REQUIRED_USE and a few new USE flags, fixed bug #365813
(Portage version: 2.2.0_alpha33/cvs/Linux x86_64)
Diffstat (limited to 'x11-terms/rxvt-unicode')
-rw-r--r--x11-terms/rxvt-unicode/ChangeLog6
-rw-r--r--x11-terms/rxvt-unicode/metadata.xml2
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-9.11.ebuild27
3 files changed, 18 insertions, 17 deletions
diff --git a/x11-terms/rxvt-unicode/ChangeLog b/x11-terms/rxvt-unicode/ChangeLog
index 8d0fedcd97a5..142d7385e4a3 100644
--- a/x11-terms/rxvt-unicode/ChangeLog
+++ b/x11-terms/rxvt-unicode/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-terms/rxvt-unicode
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.184 2011/05/19 17:41:37 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.185 2011/05/19 20:35:55 wired Exp $
+
+ 19 May 2011; Alex Alexander <wired@gentoo.org> rxvt-unicode-9.11.ebuild,
+ metadata.xml:
+ EAPI 4, added REQUIRED_USE and a few new USE flags, fixed bug #365813
19 May 2011; Jeroen Roovers <jer@gentoo.org> rxvt-unicode-9.11.ebuild,
metadata.xml:
diff --git a/x11-terms/rxvt-unicode/metadata.xml b/x11-terms/rxvt-unicode/metadata.xml
index 1c9458c9ce78..c5ffed97df78 100644
--- a/x11-terms/rxvt-unicode/metadata.xml
+++ b/x11-terms/rxvt-unicode/metadata.xml
@@ -14,8 +14,10 @@
<flag name='256-color'>Enable 256 color support</flag>
<flag name='afterimage'>Enable transparency support using
<pkg>media-libs/libafterimage</pkg></flag>
+<flag name='alt-font-width'>Calculate the font width using a different method</flag>
<flag name='blink'>Enable blinking text</flag>
<flag name='fading-colors'>Enable colors fading when off focus</flag>
+<flag name='focused-urgency'>Enable the urgent flag when a terminal window is focused</flag>
<flag name='font-styles'>Enable support for bold and italic fonts</flag>
<flag name='force-hints'>Force WM hints on rxvt-unicode's geometry. Read
http://bugs.gentoo.org/show_bug.cgi?id=346553</flag>
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-9.11.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-9.11.ebuild
index 5c5c3f7bf453..1f621a778e1e 100644
--- a/x11-terms/rxvt-unicode/rxvt-unicode-9.11.ebuild
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-9.11.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/rxvt-unicode-9.11.ebuild,v 1.2 2011/05/19 17:41:37 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/rxvt-unicode-9.11.ebuild,v 1.3 2011/05/19 20:35:55 wired Exp $
-EAPI="3"
+EAPI="4"
inherit autotools
@@ -14,8 +14,9 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="
- 256-color afterimage blink fading-colors +font-styles force-hints iso14755
- +mousewheel perl pixbuf truetype unicode3 +vanilla wcwidth
+ 256-color alt-font-width afterimage blink +focused-urgency fading-colors
+ +font-styles force-hints iso14755 +mousewheel perl pixbuf truetype unicode3
+ +vanilla wcwidth
"
RDEPEND="x11-libs/libX11
@@ -29,6 +30,8 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig
x11-proto/xproto"
+REQUIRED_USE="vanilla? ( !alt-font-width focused-urgency !force-hints !wcwidth )"
+
src_prepare() {
if ! use afterimage && ! use pixbuf; then
einfo " + If you want transparency support, please enable either the *pixbuf*"
@@ -39,18 +42,12 @@ src_prepare() {
ewarn " + You have enabled the vanilla USE flag."
ewarn " This means no USE flag controlled patches will be applied."
else
- if use wcwidth || use force-hints; then
- ewarn " + You enabled wcwidth or force-hints or both."
- ewarn " Please note that these are not supported by upstream."
- ewarn " You are at your own if you run into problems."
- fi
-
- local tdir=/usr/share/terminfo
+ ewarn " + You are going to include unsupported third-party bug fixes/features."
use wcwidth && epatch doc/wcwidth.patch
# bug #240165
- epatch "${FILESDIR}"/${PN}-9.06-no-urgency-if-focused.diff
+ use focused-urgency || epatch "${FILESDIR}"/${PN}-9.06-no-urgency-if-focused.diff
# bug #263638
epatch "${FILESDIR}"/${PN}-9.06-popups-hangs.patch
@@ -59,11 +56,9 @@ src_prepare() {
use force-hints && epatch "${FILESDIR}"/${PN}-9.10-force-hints.patch
# bug #237271
- ewarn " + You are going to include third-party bug fixes/features."
- ewarn " They came without any warranty and are not supported by the"
- ewarn " Gentoo community."
epatch "${FILESDIR}"/${PN}-9.05_no-MOTIF-WM-INFO.patch
- epatch "${FILESDIR}"/${PN}-9.06-font-width.patch
+
+ use alt-font-width && epatch "${FILESDIR}"/${PN}-9.06-font-width.patch
fi
# kill the rxvt-unicode terminfo file - #192083