summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRené Nussbaumer <killerfox@gentoo.org>2008-12-21 20:44:23 +0000
committerRené Nussbaumer <killerfox@gentoo.org>2008-12-21 20:44:23 +0000
commit23c7e2c0b59f7d69d88761be040bd5f29a28f108 (patch)
treee8e2ebd7858ab66e5b633eec37ecebf177aa8e42 /x11-terms/rxvt-unicode/rxvt-unicode-9.06.ebuild
parent- fix pie support and use local installer (diff)
downloadgentoo-2-23c7e2c0b59f7d69d88761be040bd5f29a28f108.tar.gz
gentoo-2-23c7e2c0b59f7d69d88761be040bd5f29a28f108.tar.bz2
gentoo-2-23c7e2c0b59f7d69d88761be040bd5f29a28f108.zip
Version bump. Prepared for ncurses-5.7 support where rxvt-unicode ships with it
(Portage version: 2.1.4.5)
Diffstat (limited to 'x11-terms/rxvt-unicode/rxvt-unicode-9.06.ebuild')
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-9.06.ebuild100
1 files changed, 100 insertions, 0 deletions
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-9.06.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-9.06.ebuild
new file mode 100644
index 000000000000..56f92cf71b57
--- /dev/null
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-9.06.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/rxvt-unicode-9.06.ebuild,v 1.1 2008/12/21 20:44:23 killerfox Exp $
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="rxvt clone with xft and unicode support"
+HOMEPAGE="http://software.schmorp.de/"
+SRC_URI="http://dist.schmorp.de/rxvt-unicode/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="truetype perl iso14755 afterimage xterm-color wcwidth vanilla"
+
+# see bug #115992 for modular x deps
+RDEPEND="x11-libs/libX11
+ x11-libs/libXft
+ afterimage? ( media-libs/libafterimage )
+ x11-libs/libXrender
+ perl? ( dev-lang/perl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ x11-proto/xproto"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if (use xterm-color || use wcwidth); then
+ ewarn "You enabled xterm-color or wcwidth or both."
+ ewarn "Please note that neither of them are supported by upstream."
+ ewarn "You are at your own if you run into problems."
+ ebeep 5
+ fi
+
+ local tdir=/usr/share/terminfo
+ if use xterm-color; then
+ epatch doc/urxvt-8.2-256color.patch
+ sed -e \
+ 's/^\(rxvt-unicode\)/\1256/;s/colors#88/colors#256/;s/pairs#256/pairs#32767/' \
+ doc/etc/rxvt-unicode.terminfo > doc/etc/rxvt-unicode256.terminfo
+ sed -i -e \
+ "s~^\(\s\+@TIC@.*\)~\1\n\t@TIC@ -o ${D}/${tdir} \$(srcdir)/etc/rxvt-unicode256.terminfo~" \
+ doc/Makefile.in
+ fi
+
+ use wcwidth && epatch doc/wcwidth.patch
+
+ # ncurses will provide rxvt-unicode terminfo, so we don't install them again
+ # see bug #192083
+ #
+ # According to my tests this is not (yet?) true, so keep it prepared and
+ # disabled until it's needed again.
+ #if has_version '<sys-libs/ncurses-5.7'; then
+ sed -i -e \
+ "s~@TIC@ \(\$(srcdir)/etc/rxvt\)~@TIC@ -o ${D}/${tdir} \1~" \
+ doc/Makefile.in
+ #else
+ # # Remove everything except if we have rxvt-unicode256
+ # sed -i -e \
+ # '/rxvt-unicode256/p;/@TIC@/d' \
+ # doc/Makefile.in
+ #fi
+
+ eautoreconf
+}
+
+src_compile() {
+ local myconf=''
+
+ use iso14755 || myconf='--disable-iso14755'
+ use xterm-color && myconf="$myconf --enable-xterm-colors=256"
+
+ econf --enable-everything \
+ $(use_enable truetype xft) \
+ $(use_enable afterimage) \
+ $(use_enable perl) \
+ --disable-text-blink \
+ ${myconf}
+
+ emake || die
+
+ sed -i \
+ -e 's/RXVT_BASENAME = "rxvt"/RXVT_BASENAME = "urxvt"/' \
+ "${S}"/doc/rxvt-tabbed || die "tabs sed failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ dodoc README.FAQ Changes
+ cd "${S}"/doc
+ dodoc README* changes.txt etc/* rxvt-tabbed
+}
+
+pkg_postinst() {
+ einfo "urxvt now always uses TERM=rxvt-unicode so that the"
+ einfo "upstream-supplied terminfo files can be used."
+}