summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2011-11-10 16:39:13 +0000
committerNaohiro Aota <naota@gentoo.org>2011-11-10 16:39:13 +0000
commit76e0b27dc98090f226ce44077674b0e4a926e4a5 (patch)
treef10c5a9a11da13e9c8875da2286c9382d6db066c /x11-terms/mlterm/files
parentbuild with newer zlib (bug #390093) (diff)
downloadgentoo-2-76e0b27dc98090f226ce44077674b0e4a926e4a5.tar.gz
gentoo-2-76e0b27dc98090f226ce44077674b0e4a926e4a5.tar.bz2
gentoo-2-76e0b27dc98090f226ce44077674b0e4a926e4a5.zip
Version bump. Bug #389237
(Portage version: 2.2.0_alpha71/cvs/Linux x86_64)
Diffstat (limited to 'x11-terms/mlterm/files')
-rw-r--r--x11-terms/mlterm/files/mlterm-3.0.8-ldflags.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/x11-terms/mlterm/files/mlterm-3.0.8-ldflags.patch b/x11-terms/mlterm/files/mlterm-3.0.8-ldflags.patch
new file mode 100644
index 000000000000..8e6092d292af
--- /dev/null
+++ b/x11-terms/mlterm/files/mlterm-3.0.8-ldflags.patch
@@ -0,0 +1,24 @@
+diff -Naur mlterm-3.0.5.orig/contrib/tool/mlcc/Makefile.in mlterm-3.0.5/contrib/tool/mlcc/Makefile.in
+--- mlterm-3.0.5.orig/contrib/tool/mlcc/Makefile.in 2011-06-04 01:26:17.000000000 +0900
++++ mlterm-3.0.5/contrib/tool/mlcc/Makefile.in 2011-06-09 23:29:02.851741057 +0900
+@@ -20,7 +20,7 @@
+ all: $(PROG)
+
+ $(PROG): $(OBJECTS)
+- $(CC) -g -o $(PROG) $(OBJECTS)
++ $(CC) -g -o $(PROG) $(OBJECTS) $(LDFLAGS)
+
+ .SUFFIXES: .c.o
+
+diff -Naur mlterm-3.0.5.orig/tool/mlclient/Makefile.in mlterm-3.0.5/tool/mlclient/Makefile.in
+--- mlterm-3.0.5.orig/tool/mlclient/Makefile.in 2011-06-04 01:26:11.000000000 +0900
++++ mlterm-3.0.5/tool/mlclient/Makefile.in 2011-06-09 23:27:57.251467757 +0900
+@@ -20,7 +20,7 @@
+ all: $(PROG)
+
+ $(PROG): $(OBJ)
+- $(CC) -o $(PROG) $(OBJ) $(LIBS)
++ $(CC) -o $(PROG) $(OBJ) $(LIBS) $(LDFLAGS)
+ cp $(PROG) $(PROG)x
+
+ .SUFFIXES: .c.o