summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2008-10-02 02:38:10 +0000
committerJeremy Olexa <darkside@gentoo.org>2008-10-02 02:38:10 +0000
commit4edbfc61b325081eaacd2d1d864f0c10c9597aa2 (patch)
tree3a30dc981ee54c3b27128aea801886beeec3146a /x11-terms/aterm/aterm-1.0.1-r2.ebuild
parentmanual ChangeLog entry, oops (diff)
downloadgentoo-2-4edbfc61b325081eaacd2d1d864f0c10c9597aa2.tar.gz
gentoo-2-4edbfc61b325081eaacd2d1d864f0c10c9597aa2.tar.bz2
gentoo-2-4edbfc61b325081eaacd2d1d864f0c10c9597aa2.zip
(non-maintainer commit) add deadkeys patch submitted by Yarda in bug #211576
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'x11-terms/aterm/aterm-1.0.1-r2.ebuild')
-rw-r--r--x11-terms/aterm/aterm-1.0.1-r2.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/x11-terms/aterm/aterm-1.0.1-r2.ebuild b/x11-terms/aterm/aterm-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..0edf30dcb727
--- /dev/null
+++ b/x11-terms/aterm/aterm-1.0.1-r2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/aterm/aterm-1.0.1-r2.ebuild,v 1.1 2008/10/02 02:37:46 darkside Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="A terminal emulator with transparency support as well as rxvt backwards compatibility"
+HOMEPAGE="http://aterm.sourceforge.net"
+SRC_URI="ftp://ftp.afterstep.org/apps/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="background cjk xgetdefault"
+
+RDEPEND="media-libs/jpeg
+ media-libs/libpng
+ background? ( x11-wm/afterstep )
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libICE"
+
+DEPEND="${RDEPEND}
+ x11-libs/libXt
+ x11-proto/xproto"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Security bug #219746
+ epatch "${FILESDIR}/${P}-display-security-issue.patch"
+ epatch "${FILESDIR}"/${P}-deadkeys.patch
+}
+
+src_compile() {
+ local myconf
+
+ use cjk && myconf="$myconf
+ --enable-kanji
+ --enable-thai
+ --enable-big5"
+
+ econf \
+ $(use_enable xgetdefault) \
+ $(use_enable background background-image) \
+ --with-terminfo=/usr/share/terminfo \
+ --enable-transparency \
+ --enable-fading \
+ --enable-background-image \
+ --enable-menubar \
+ --enable-graphics \
+ --enable-utmp \
+ --enable-wtmp \
+ --with-x \
+ ${myconf} || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ fowners root:utmp /usr/bin/aterm
+ fperms g+s /usr/bin/aterm
+
+ doman doc/aterm.1
+ dodoc ChangeLog doc/FAQ doc/README.*
+ docinto menu
+ dodoc doc/menu/*
+ dohtml -r .
+}
+
+pkg_postinst() {
+ echo
+ ewarn "The transparent background will only work if you have the 'real'"
+ ewarn "root wallpaper set. Some tools that might help include: Esetroot"
+ ewarn "(x11-terms/eterm), wmsetbg (x11-wm/windowmaker), and/or"
+ ewarn "media-gfx/feh."
+ echo
+}