summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2012-01-11 20:34:51 +0000
committerMatt Turner <mattst88@gentoo.org>2012-01-11 20:34:51 +0000
commita80ecb56a51feaf9b8996a39de630017289dcb51 (patch)
tree8d9b9f869e23dd0c872201b0d203ec014e7fea88 /x11-proto
parentMarking xdg-user-dirs-0.14 ppc for bug 388011 (diff)
downloadgentoo-2-a80ecb56a51feaf9b8996a39de630017289dcb51.tar.gz
gentoo-2-a80ecb56a51feaf9b8996a39de630017289dcb51.tar.bz2
gentoo-2-a80ecb56a51feaf9b8996a39de630017289dcb51.zip
Version bump.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'x11-proto')
-rw-r--r--x11-proto/xcb-proto/ChangeLog9
-rw-r--r--x11-proto/xcb-proto/xcb-proto-1.7.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/x11-proto/xcb-proto/ChangeLog b/x11-proto/xcb-proto/ChangeLog
index d5dafca196c9..c11f0ecaf4bc 100644
--- a/x11-proto/xcb-proto/ChangeLog
+++ b/x11-proto/xcb-proto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-proto/xcb-proto
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-proto/xcb-proto/ChangeLog,v 1.67 2011/12/27 21:13:20 maekke Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/xcb-proto/ChangeLog,v 1.68 2012/01/11 20:34:51 mattst88 Exp $
+
+*xcb-proto-1.7 (11 Jan 2012)
+
+ 11 Jan 2012; Matt Turner <mattst88@gentoo.org> +xcb-proto-1.7.ebuild:
+ Version bump.
27 Dec 2011; Markus Meier <maekke@gentoo.org> xcb-proto-1.6-r2.ebuild:
x86 stable, bug #394393
diff --git a/x11-proto/xcb-proto/xcb-proto-1.7.ebuild b/x11-proto/xcb-proto/xcb-proto-1.7.ebuild
new file mode 100644
index 000000000000..f7d5fa6dcb7e
--- /dev/null
+++ b/x11-proto/xcb-proto/xcb-proto-1.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/xcb-proto/xcb-proto-1.7.ebuild,v 1.1 2012/01/11 20:34:51 mattst88 Exp $
+
+EAPI=3
+PYTHON_DEPEND="2:2.5"
+
+inherit python xorg-2
+
+DESCRIPTION="X C-language Bindings protocol headers"
+HOMEPAGE="http://xcb.freedesktop.org/"
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/proto"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-libs/libxml2"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_install() {
+ xorg-2_src_install
+ python_clean_installation_image
+}
+
+pkg_postinst() {
+ python_mod_optimize xcbgen
+ ewarn "Please rebuild both libxcb and xcb-util if you are upgrading from version 1.6"
+}
+
+pkg_postrm() {
+ python_mod_cleanup xcbgen
+}