summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-03-10 00:08:40 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-03-10 00:08:40 +0000
commit71ba1f4e9c78d91e6a53ea9785e551a4231b6b58 (patch)
tree84ee58893dd609327e0fedece392812c9b336b7b /x11-proto
parentAdd support for colorhug device (diff)
downloadgentoo-2-71ba1f4e9c78d91e6a53ea9785e551a4231b6b58.tar.gz
gentoo-2-71ba1f4e9c78d91e6a53ea9785e551a4231b6b58.tar.bz2
gentoo-2-71ba1f4e9c78d91e6a53ea9785e551a4231b6b58.zip
Works with python 3 now.
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'x11-proto')
-rw-r--r--x11-proto/xcb-proto/ChangeLog8
-rw-r--r--x11-proto/xcb-proto/xcb-proto-1.7-r1.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/x11-proto/xcb-proto/ChangeLog b/x11-proto/xcb-proto/ChangeLog
index 6d40ea1456bb..c02cf8203fdc 100644
--- a/x11-proto/xcb-proto/ChangeLog
+++ b/x11-proto/xcb-proto/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-proto/xcb-proto
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-proto/xcb-proto/ChangeLog,v 1.71 2012/03/03 16:33:44 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/xcb-proto/ChangeLog,v 1.72 2012/03/10 00:08:40 chithanh Exp $
+
+*xcb-proto-1.7-r1 (10 Mar 2012)
+
+ 10 Mar 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +xcb-proto-1.7-r1.ebuild:
+ Works with python 3 now.
03 Mar 2012; Brent Baude <ranger@gentoo.org> xcb-proto-1.6-r2.ebuild:
Marking xcb-proto-1.6-r2 ppc64 stable for bug 394393
diff --git a/x11-proto/xcb-proto/xcb-proto-1.7-r1.ebuild b/x11-proto/xcb-proto/xcb-proto-1.7-r1.ebuild
new file mode 100644
index 000000000000..616bd1ec806d
--- /dev/null
+++ b/x11-proto/xcb-proto/xcb-proto-1.7-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/xcb-proto/xcb-proto-1.7-r1.ebuild,v 1.1 2012/03/10 00:08:40 chithanh Exp $
+
+EAPI=4
+
+inherit python xorg-2
+
+DESCRIPTION="X C-language Bindings protocol headers"
+HOMEPAGE="http://xcb.freedesktop.org/"
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/proto"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-libs/libxml2"
+
+src_install() {
+ xorg-2_src_install
+ python_clean_installation_image
+}
+
+pkg_postinst() {
+ python_mod_optimize xcbgen
+ ewarn "Please rebuild both libxcb and xcb-util if you are upgrading from version 1.6"
+}
+
+pkg_postrm() {
+ python_mod_cleanup xcbgen
+}