summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-08-10 21:37:59 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-08-10 21:37:59 +0000
commit0176fa9a282b897430427e15243391ad4342aac8 (patch)
treee1bc0eb801bbe37b64eca303dd0a3a8a8f80377c /x11-proto
parentAdd dep on >=x11-proto/glproto-1.4-r1. (diff)
downloadgentoo-2-0176fa9a282b897430427e15243391ad4342aac8.tar.gz
gentoo-2-0176fa9a282b897430427e15243391ad4342aac8.tar.bz2
gentoo-2-0176fa9a282b897430427e15243391ad4342aac8.zip
Rev bump to make sure people get working GL setup.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'x11-proto')
-rw-r--r--x11-proto/glproto/ChangeLog8
-rw-r--r--x11-proto/glproto/files/digest-glproto-1.4-r11
-rw-r--r--x11-proto/glproto/glproto-1.4-r1.ebuild55
3 files changed, 63 insertions, 1 deletions
diff --git a/x11-proto/glproto/ChangeLog b/x11-proto/glproto/ChangeLog
index d47d78fb26b0..edd5edfc8e18 100644
--- a/x11-proto/glproto/ChangeLog
+++ b/x11-proto/glproto/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-proto/glproto
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/ChangeLog,v 1.6 2005/08/10 06:50:08 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/ChangeLog,v 1.7 2005/08/10 21:35:22 spyderous Exp $
+
+*glproto-1.4-r1 (10 Aug 2005)
+
+ 10 Aug 2005; Donnie Berkholz <spyderous@gentoo.org>;
+ +glproto-1.4-r1.ebuild:
+ Rev bump to make sure people get working GL setup.
10 Aug 2005; Donnie Berkholz <spyderous@gentoo.org>; glproto-1.4.ebuild:
(fd.o #4036) Stop installing glu.h. This and glx.h are already installed by
diff --git a/x11-proto/glproto/files/digest-glproto-1.4-r1 b/x11-proto/glproto/files/digest-glproto-1.4-r1
new file mode 100644
index 000000000000..68d1445c4364
--- /dev/null
+++ b/x11-proto/glproto/files/digest-glproto-1.4-r1
@@ -0,0 +1 @@
+MD5 9cda6fbdcc75f6d7d9cd1d3839264609 glproto-1.4.tar.bz2 57058
diff --git a/x11-proto/glproto/glproto-1.4-r1.ebuild b/x11-proto/glproto/glproto-1.4-r1.ebuild
new file mode 100644
index 000000000000..79e4cd198105
--- /dev/null
+++ b/x11-proto/glproto/glproto-1.4-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/glproto-1.4-r1.ebuild,v 1.1 2005/08/10 21:35:22 spyderous Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+OPENGL_DIR="xorg-x11"
+
+DESCRIPTION="X.Org GL protocol headers"
+#HOMEPAGE="http://foo.bar.com/"
+#SRC_URI="ftp://foo.bar.com/${P}.tar.bz2"
+#LICENSE=""
+#SLOT="0"
+KEYWORDS="~sparc ~x86"
+#IUSE="X gnome"
+DEPEND=">=x11-base/opengl-update-2.2.2"
+#RDEPEND=""
+
+src_install() {
+ x-modular_src_install
+
+ dynamic_libgl_install
+}
+
+pkg_postinst() {
+ switch_opengl_implem
+}
+
+dynamic_libgl_install() {
+ # next section is to setup the dynamic libGL stuff
+ ebegin "Moving GL files for dynamic switching"
+ dodir /usr/$(get_libdir)/opengl/${OPENGL_DIR}/include
+ local x=""
+ # glext.h added for #54984
+ # glx.h also provided by mesa, so we don't add it
+ rm ${D}/usr/include/GL/{glx,glu}.h
+ for x in ${D}/usr/include/GL/{glxtokens.h,glxmd.h,glxproto.h}; do
+ if [ -f ${x} -o -L ${x} ]; then
+ mv -f ${x} ${D}/usr/$(get_libdir)/opengl/${OPENGL_DIR}/include
+ fi
+ done
+ eend 0
+}
+
+switch_opengl_implem() {
+ # Switch to the xorg implementation.
+ # Use new opengl-update that will not reset user selected
+ # OpenGL interface ...
+ echo
+ local opengl_implem="$(${ROOT}/usr/sbin/opengl-update --get-implementation)"
+ ${ROOT}/usr/sbin/opengl-update --use-old ${OPENGL_DIR}
+}