summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2009-05-23 17:29:58 +0000
committerRémi Cardona <remi@gentoo.org>2009-05-23 17:29:58 +0000
commit6a0fa583fbc39246d1c6468b71c018f5b6beb4cb (patch)
tree528e6bea499344d252a6573a5ea0eeb9e4343f11 /x11-proto/xextproto
parentNew prerelease version. (diff)
downloadgentoo-2-6a0fa583fbc39246d1c6468b71c018f5b6beb4cb.tar.gz
gentoo-2-6a0fa583fbc39246d1c6468b71c018f5b6beb4cb.tar.bz2
gentoo-2-6a0fa583fbc39246d1c6468b71c018f5b6beb4cb.zip
x11-proto/xextproto: bump to 7.0.5 with patch from git
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'x11-proto/xextproto')
-rw-r--r--x11-proto/xextproto/ChangeLog8
-rw-r--r--x11-proto/xextproto/files/7.0.5-dont-pull-in-Xmd-h-in-Xge-h.patch46
-rw-r--r--x11-proto/xextproto/xextproto-7.0.5.ebuild20
3 files changed, 73 insertions, 1 deletions
diff --git a/x11-proto/xextproto/ChangeLog b/x11-proto/xextproto/ChangeLog
index 8d0c263562d0..35cc8e984e53 100644
--- a/x11-proto/xextproto/ChangeLog
+++ b/x11-proto/xextproto/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-proto/xextproto
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-proto/xextproto/ChangeLog,v 1.37 2009/05/15 14:44:40 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/xextproto/ChangeLog,v 1.38 2009/05/23 17:29:57 remi Exp $
+
+*xextproto-7.0.5 (23 May 2009)
+
+ 23 May 2009; Rémi Cardona <remi@gentoo.org>
+ +files/7.0.5-dont-pull-in-Xmd-h-in-Xge-h.patch, +xextproto-7.0.5.ebuild:
+ bump to 7.0.5 with patch from git
15 May 2009; Raúl Porcel <armin76@gentoo.org> xextproto-7.0.4.ebuild:
arm/m68k/s390 stable
diff --git a/x11-proto/xextproto/files/7.0.5-dont-pull-in-Xmd-h-in-Xge-h.patch b/x11-proto/xextproto/files/7.0.5-dont-pull-in-Xmd-h-in-Xge-h.patch
new file mode 100644
index 000000000000..98a9e976cca3
--- /dev/null
+++ b/x11-proto/xextproto/files/7.0.5-dont-pull-in-Xmd-h-in-Xge-h.patch
@@ -0,0 +1,46 @@
+From 7629def0733b82687f2879095451d72e42e13db7 Mon Sep 17 00:00:00 2001
+From: James Cloos <cloos@jhcloos.com>
+Date: Sat, 28 Mar 2009 18:20:38 +0000
+Subject: C sucks: define XEventClass in terms of unsigned int, not CARD32.
+
+Apparently pulling in Xmd.h here breaks qt, since they both define an
+INT32 type (and incompatible ones even, since Xmd's is unsigned long on
+ILP32 because whoever wrote Xmd.h is a C novice).
+
+(Based on inputproto commit b5cbe2d93f6c0129b8f29da97778f6d1b15c38f9.
+Patch submitted to xorg@ in <20090117121713.46bf3332@family.dyweni.com>.)
+---
+diff --git a/Xge.h b/Xge.h
+index cc03ece..51382ff 100644
+--- a/Xge.h
++++ b/Xge.h
+@@ -30,7 +30,6 @@
+ #ifndef _XGE_H_
+ #define _XGE_H_
+
+-#include <X11/Xmd.h>
+ #include <X11/Xlib.h>
+ #include <X11/Xfuncproto.h>
+
+@@ -39,12 +38,15 @@ _XFUNCPROTOBEGIN
+ /**
+ * Generic Event mask.
+ * To be used whenever a list of masks per extension has to be provided.
++ *
++ * But, don't actually use the CARD{8,16,32} types. We can't get them them
++ * defined here without polluting the namespace.
+ */
+ typedef struct {
+- CARD8 extension;
+- CARD8 pad0;
+- CARD16 pad1;
+- CARD32 evmask;
++ unsigned char extension;
++ unsigned char pad0;
++ unsigned short pad1;
++ unsigned int evmask;
+ } XGenericEventMask;
+
+ Bool XGEQueryExtension(Display* dpy, int *event_basep, int *err_basep);
+--
+cgit v0.8.2
diff --git a/x11-proto/xextproto/xextproto-7.0.5.ebuild b/x11-proto/xextproto/xextproto-7.0.5.ebuild
new file mode 100644
index 000000000000..baf705d8a54a
--- /dev/null
+++ b/x11-proto/xextproto/xextproto-7.0.5.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/xextproto/xextproto-7.0.5.ebuild,v 1.1 2009/05/23 17:29:57 remi Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org XExt protocol headers"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+IUSE=""
+DEPEND="x11-proto/inputproto"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+"${FILESDIR}/${PV}-dont-pull-in-Xmd-h-in-Xge-h.patch"
+)