summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-12-04 12:48:49 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-12-04 12:48:49 +0000
commita7fb4ec6fb30691cc92560a12cdf820d8f006cf9 (patch)
tree9cf9c7ad23c0cfe9e8fa207d8c99a9af153012e1 /x11-proto/xcb-proto
parentx86 stable wrt bug #347131 (diff)
downloadgentoo-2-a7fb4ec6fb30691cc92560a12cdf820d8f006cf9.tar.gz
gentoo-2-a7fb4ec6fb30691cc92560a12cdf820d8f006cf9.tar.bz2
gentoo-2-a7fb4ec6fb30691cc92560a12cdf820d8f006cf9.zip
Revision bump to fix bug #341999.
(Portage version: 2.2.0_alpha6/cvs/Linux x86_64)
Diffstat (limited to 'x11-proto/xcb-proto')
-rw-r--r--x11-proto/xcb-proto/ChangeLog12
-rw-r--r--x11-proto/xcb-proto/files/1.6-fix_negative.patch14
-rw-r--r--x11-proto/xcb-proto/xcb-proto-1.6-r1.ebuild41
3 files changed, 66 insertions, 1 deletions
diff --git a/x11-proto/xcb-proto/ChangeLog b/x11-proto/xcb-proto/ChangeLog
index 41ce94d51d38..9d8b1ad5820b 100644
--- a/x11-proto/xcb-proto/ChangeLog
+++ b/x11-proto/xcb-proto/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for x11-proto/xcb-proto
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-proto/xcb-proto/ChangeLog,v 1.53 2010/11/06 14:42:30 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/xcb-proto/ChangeLog,v 1.54 2010/12/04 12:48:49 scarabeus Exp $
+
+ 04 Dec 2010; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/1.6-fix_negative.patch, +xcb-proto-1.6-r1.ebuild:
+ Revision bump to fix bug #341999.
+
+*xcb-proto-1.6-r1 (04 Dec 2010)
+
+ 04 Dec 2010; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/1.6-fix_negative.patch, +xcb-proto-1.6-r1.ebuild:
+ Revision bump to fix bug #341999.
06 Nov 2010; Tomáš Chvátal <scarabeus@gentoo.org> xcb-proto-1.6.ebuild:
Make the python generating work again
diff --git a/x11-proto/xcb-proto/files/1.6-fix_negative.patch b/x11-proto/xcb-proto/files/1.6-fix_negative.patch
new file mode 100644
index 000000000000..a2f149eac562
--- /dev/null
+++ b/x11-proto/xcb-proto/files/1.6-fix_negative.patch
@@ -0,0 +1,14 @@
+diff -Naur src/xproto.xml src/xproto.xml
+--- src/xproto.xml 2009-12-02 10:06:59.000000000 +0100
++++ src/xproto.xml 2010-10-21 19:35:57.938000001 +0200
+@@ -1296,8 +1296,8 @@
+ <reply>
+ <field type="BOOL" name="same_screen" />
+ <field type="WINDOW" name="child" altenum="Window" />
+- <field type="CARD16" name="dst_x" />
+- <field type="CARD16" name="dst_y" />
++ <field type="INT16" name="dst_x" />
++ <field type="INT16" name="dst_y" />
+ </reply>
+ </request>
+
diff --git a/x11-proto/xcb-proto/xcb-proto-1.6-r1.ebuild b/x11-proto/xcb-proto/xcb-proto-1.6-r1.ebuild
new file mode 100644
index 000000000000..0d4855d5c772
--- /dev/null
+++ b/x11-proto/xcb-proto/xcb-proto-1.6-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/xcb-proto/xcb-proto-1.6-r1.ebuild,v 1.1 2010/12/04 12:48:49 scarabeus Exp $
+
+EAPI=3
+PYTHON_DEPEND="2:2.5"
+
+inherit python xorg-2
+
+DESCRIPTION="X C-language Bindings protocol headers"
+HOMEPAGE="http://xcb.freedesktop.org/"
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/proto"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+PATCHES=( "${FILESDIR}/1.6-fix_negative.patch" )
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-libs/libxml2"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_install() {
+ xorg-2_src_install
+ python_clean_installation_image
+}
+
+pkg_postinst() {
+ python_mod_optimize xcbgen
+ ewarn "Please rebuild both libxcb and xcb-util if you are upgrading from version 1.6"
+}
+
+pkg_postrm() {
+ python_mod_cleanup xcbgen
+}