summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-10-15 17:16:55 +0000
committerRomain Perier <mrpouet@gentoo.org>2009-10-15 17:16:55 +0000
commitf3f1d2d58ea845506b369b7f37264acb9ab07b0b (patch)
tree2961f1e184a55d7be451fa999283051e2a0015bf /x11-plugins
parentVersion bump (diff)
downloadgentoo-2-f3f1d2d58ea845506b369b7f37264acb9ab07b0b.tar.gz
gentoo-2-f3f1d2d58ea845506b369b7f37264acb9ab07b0b.tar.bz2
gentoo-2-f3f1d2d58ea845506b369b7f37264acb9ab07b0b.zip
Version bump
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/compiz-plugins-extra/ChangeLog8
-rw-r--r--x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.4.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/x11-plugins/compiz-plugins-extra/ChangeLog b/x11-plugins/compiz-plugins-extra/ChangeLog
index 2fd197192388..47db547afca1 100644
--- a/x11-plugins/compiz-plugins-extra/ChangeLog
+++ b/x11-plugins/compiz-plugins-extra/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/compiz-plugins-extra
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/compiz-plugins-extra/ChangeLog,v 1.6 2009/08/27 11:00:42 ikelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/compiz-plugins-extra/ChangeLog,v 1.7 2009/10/15 17:16:55 mrpouet Exp $
+
+*compiz-plugins-extra-0.8.4 (15 Oct 2009)
+
+ 15 Oct 2009; Romain Perier <mrpouet@gentoo.org>
+ +compiz-plugins-extra-0.8.4.ebuild:
+ Version bump.
27 Aug 2009; Mike Auty <ikelos@gentoo.org>
compiz-plugins-extra-0.8.2.ebuild:
diff --git a/x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.4.ebuild b/x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.4.ebuild
new file mode 100644
index 000000000000..2573f3bfa8e2
--- /dev/null
+++ b/x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.4.ebuild,v 1.1 2009/10/15 17:16:55 mrpouet Exp $
+
+EAPI="2"
+
+inherit autotools eutils
+
+DESCRIPTION="Compiz Fusion Window Decorator Extra Plugins"
+HOMEPAGE="http://www.compiz.org/"
+SRC_URI="http://releases.compiz.org/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="gnome"
+
+RDEPEND="
+ !x11-plugins/compiz-fusion-plugins-extra
+ >=gnome-base/librsvg-2.14.0
+ media-libs/jpeg
+ ~x11-libs/compiz-bcop-${PV}
+ ~x11-plugins/compiz-plugins-main-${PV}
+ ~x11-wm/compiz-${PV}
+"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.19
+ >=sys-devel/gettext-0.15
+ x11-libs/cairo
+ gnome? ( gnome-base/gconf )
+"
+
+src_prepare() {
+ use gnome || {
+ epatch "${FILESDIR}"/${PN}-no-gconf.patch
+
+ # required to apply the above patch
+ intltoolize --copy --force || die "intltoolize failed"
+ eautoreconf || die "eautoreconf failed"
+ }
+}
+
+src_configure() {
+ econf $(use_enable gnome gconf) || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}