summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2006-10-10 18:55:33 +0000
committerBryan Østergaard <kloeri@gentoo.org>2006-10-10 18:55:33 +0000
commitde7131c803fd001a7834dd66ea54fc301beec29a (patch)
tree819e68245e2a9dd6e2e4859c365150241f83528e /x11-plugins
parentStable on sparc wrt #146939 (diff)
downloadgentoo-2-de7131c803fd001a7834dd66ea54fc301beec29a.tar.gz
gentoo-2-de7131c803fd001a7834dd66ea54fc301beec29a.tar.bz2
gentoo-2-de7131c803fd001a7834dd66ea54fc301beec29a.zip
Modular X fixes, bug 147232.
(Portage version: 2.1.2_pre2-r6)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/ascpu/ChangeLog10
-rw-r--r--x11-plugins/ascpu/ascpu-1.11.ebuild40
-rw-r--r--x11-plugins/ascpu/files/ascpu-1.11-gentoo.patch36
-rw-r--r--x11-plugins/ascpu/files/digest-ascpu-1.113
4 files changed, 87 insertions, 2 deletions
diff --git a/x11-plugins/ascpu/ChangeLog b/x11-plugins/ascpu/ChangeLog
index 2a0332d7a5e6..db151081da4e 100644
--- a/x11-plugins/ascpu/ChangeLog
+++ b/x11-plugins/ascpu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/ascpu
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/ascpu/ChangeLog,v 1.15 2006/01/02 10:51:17 s4t4n Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/ascpu/ChangeLog,v 1.16 2006/10/10 18:55:33 kloeri Exp $
+
+*ascpu-1.11 (10 Oct 2006)
+
+ 10 Oct 2006; Bryan Østergaard <kloeri@gentoo.org>
+ +files/ascpu-1.11-gentoo.patch, +ascpu-1.11.ebuild:
+ Modular X fixes, bug 147232.
02 Jan 2006; Michele Noberasco <s4t4n@gentoo.org> ascpu-1.10.ebuild, ascpu-1.9.ebuild:
removed LICENSE and INSTALL from dodoc.
diff --git a/x11-plugins/ascpu/ascpu-1.11.ebuild b/x11-plugins/ascpu/ascpu-1.11.ebuild
new file mode 100644
index 000000000000..7ac1d767c872
--- /dev/null
+++ b/x11-plugins/ascpu/ascpu-1.11.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/ascpu/ascpu-1.11.ebuild,v 1.1 2006/10/10 18:55:33 kloeri Exp $
+
+inherit eutils toolchain-funcs
+
+IUSE="jpeg"
+DESCRIPTION="CPU statistics monitor utility for X Windows"
+SRC_URI="http://www.tigr.net/afterstep/download/ascpu/${P}.tar.gz"
+HOMEPAGE="http://www.tigr.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~ppc ~mips ~ppc64 ~amd64"
+
+RDEPEND="x11-libs/libXpm
+ x11-libs/libSM
+ jpeg? ( media-libs/jpeg )"
+
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ econf $(use_enable jpeg) || die "econf failed"
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/man/man1
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README
+}
diff --git a/x11-plugins/ascpu/files/ascpu-1.11-gentoo.patch b/x11-plugins/ascpu/files/ascpu-1.11-gentoo.patch
new file mode 100644
index 000000000000..b26374a4ac03
--- /dev/null
+++ b/x11-plugins/ascpu/files/ascpu-1.11-gentoo.patch
@@ -0,0 +1,36 @@
+--- autoconf/Makefile.common.in.orig 1999-05-06 23:35:32.000000000 +0200
++++ autoconf/Makefile.common.in 2006-09-11 23:07:41.000000000 +0200
+@@ -9,11 +9,10 @@
+ install: install.bin install.man
+
+ install.bin: $(PROG)
+- $(STRIP) $(PROG)
+- $(INSTALL_PROGRAM) $(PROG) $(AFTER_BIN_DIR)
++ $(INSTALL_PROGRAM) $(PROG) $(DESTDIR)$(AFTER_BIN_DIR)
+
+ install.man:
+- $(INSTALL_DATA) $(PROG).man $(AFTER_MAN_DIR)/$(PROG).1x
++ $(INSTALL_DATA) $(PROG).man $(DESTDIR)$(AFTER_MAN_DIR)/$(PROG).1x
+
+ uninstall:
+ $(RMF) $(AFTER_BIN_DIR)/$(PROG)
+--- autoconf/Makefile.defines.in.orig 1999-05-06 23:35:32.000000000 +0200
++++ autoconf/Makefile.defines.in 2006-09-11 23:17:40.000000000 +0200
+@@ -2,6 +2,7 @@
+ # Copyright (c) 1998, Guylhem AZNAR <guylhem@oeil.qc.ca>
+ #
+
++DESTDIR =
+ CC = @CC@
+ CCFLAGS = @CFLAGS@
+ # -march=pentiumpro -mcpu=pentiumpro
+@@ -21,7 +22,7 @@
+ LEXFLAGS =
+
+ INSTALL = @INSTALL@
+-INSTALL_PROGRAM = @INSTALL@ -s -m 755
++INSTALL_PROGRAM = @INSTALL@ -m 755
+ INSTALL_DATA = @INSTALL@ -m 644
+
+ INCS_X = @X_CFLAGS@
+
diff --git a/x11-plugins/ascpu/files/digest-ascpu-1.11 b/x11-plugins/ascpu/files/digest-ascpu-1.11
new file mode 100644
index 000000000000..cd80598921e0
--- /dev/null
+++ b/x11-plugins/ascpu/files/digest-ascpu-1.11
@@ -0,0 +1,3 @@
+MD5 4629775ce07d2ef2f9fe827e6452b25a ascpu-1.11.tar.gz 43867
+RMD160 d196e73f8e97822b43ab58affbb648c73b8ebfd6 ascpu-1.11.tar.gz 43867
+SHA256 fdd2ee8a6cd006bbb2d6d1871b92c33b18f7bd5e1ab8a367572e4b4f1f53c0a2 ascpu-1.11.tar.gz 43867