summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2010-11-01 13:10:36 +0000
committerJim Ramsay <lack@gentoo.org>2010-11-01 13:10:36 +0000
commitc280f68a93d1b79760c4a8deb3c750944af72fa9 (patch)
tree1be2e715237fb12411b8fd7b5c38c4c1ee6fd733 /x11-plugins
parentVersion bump (diff)
downloadgentoo-2-c280f68a93d1b79760c4a8deb3c750944af72fa9.tar.gz
gentoo-2-c280f68a93d1b79760c4a8deb3c750944af72fa9.tar.bz2
gentoo-2-c280f68a93d1b79760c4a8deb3c750944af72fa9.zip
Patches to fix bug #341483 and #335085
(Portage version: 2.1.9.14/cvs/Linux i686)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/gkrellm-mailwatch/ChangeLog11
-rw-r--r--x11-plugins/gkrellm-mailwatch/files/2.4.3-0001-Respect-LDFLAGS.patch36
-rw-r--r--x11-plugins/gkrellm-mailwatch/files/2.4.3-0002-Use-gkrellm_gkd_string_width.patch29
-rw-r--r--x11-plugins/gkrellm-mailwatch/files/2.4.3-0003-Remove-a-few-more-GCC-warnings.patch41
-rw-r--r--x11-plugins/gkrellm-mailwatch/gkrellm-mailwatch-2.4.3-r1.ebuild22
5 files changed, 138 insertions, 1 deletions
diff --git a/x11-plugins/gkrellm-mailwatch/ChangeLog b/x11-plugins/gkrellm-mailwatch/ChangeLog
index 194d1cc0de40..7156d5231bc8 100644
--- a/x11-plugins/gkrellm-mailwatch/ChangeLog
+++ b/x11-plugins/gkrellm-mailwatch/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-plugins/gkrellm-mailwatch
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-mailwatch/ChangeLog,v 1.28 2010/03/12 00:43:24 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-mailwatch/ChangeLog,v 1.29 2010/11/01 13:10:36 lack Exp $
+
+*gkrellm-mailwatch-2.4.3-r1 (01 Nov 2010)
+
+ 01 Nov 2010; Jim Ramsay <lack@gentoo.org>
+ +files/2.4.3-0001-Respect-LDFLAGS.patch,
+ +gkrellm-mailwatch-2.4.3-r1.ebuild,
+ +files/2.4.3-0002-Use-gkrellm_gkd_string_width.patch,
+ +files/2.4.3-0003-Remove-a-few-more-GCC-warnings.patch:
+ Patches to fix bug #341483 and #335085
12 Mar 2010; Sebastian Pipping <sping@gentoo.org>
gkrellm-mailwatch-2.4.3.ebuild:
diff --git a/x11-plugins/gkrellm-mailwatch/files/2.4.3-0001-Respect-LDFLAGS.patch b/x11-plugins/gkrellm-mailwatch/files/2.4.3-0001-Respect-LDFLAGS.patch
new file mode 100644
index 000000000000..158357dc4855
--- /dev/null
+++ b/x11-plugins/gkrellm-mailwatch/files/2.4.3-0001-Respect-LDFLAGS.patch
@@ -0,0 +1,36 @@
+From 139912e0cf5d9714e5e1fe4576d01251491701f5 Mon Sep 17 00:00:00 2001
+From: Jim Ramsay <jim_ramsay@dell.com>
+Date: Mon, 1 Nov 2010 08:36:17 -0400
+Subject: [PATCH 1/3] Respect LDFLAGS
+
+Instead of using a non-standard varible name like LFLAGS, using LDFLAGS
+lets this play nice with Gentoo's build system.
+---
+ Makefile | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index b8cf927..02ca376 100644
+--- a/Makefile
++++ b/Makefile
+@@ -12,7 +12,7 @@ INSTALL=install -c -m 755
+
+ CFLAGS += -O2 -Wall -fPIC $(GTK_INCLUDE) $(IMLIB_INCLUDE) $(GKRELLM_INCLUDE)
+ LIBS = $(GTK_LIB) $(IMLIB_LIB)
+-LFLAGS += -shared
++LDFLAGS += -shared
+
+ LOCALEDIR := $(DESTDIR)/usr/share/locale
+ PACKAGE ?= gkrellm-mailwatch
+@@ -30,7 +30,7 @@ all: mailwatch.so
+
+ mailwatch.so: $(OBJS)
+ (cd po && ${MAKE})
+- $(CC) $(CFLAGS) $(OBJS) -o mailwatch.so $(LFLAGS) $(LIBS)
++ $(CC) $(CFLAGS) $(OBJS) -o mailwatch.so $(LDFLAGS) $(LIBS)
+
+ clean:
+ (cd po && ${MAKE} clean )
+--
+1.7.3.1
+
diff --git a/x11-plugins/gkrellm-mailwatch/files/2.4.3-0002-Use-gkrellm_gkd_string_width.patch b/x11-plugins/gkrellm-mailwatch/files/2.4.3-0002-Use-gkrellm_gkd_string_width.patch
new file mode 100644
index 000000000000..7edff1c74990
--- /dev/null
+++ b/x11-plugins/gkrellm-mailwatch/files/2.4.3-0002-Use-gkrellm_gkd_string_width.patch
@@ -0,0 +1,29 @@
+From c9db9953296709ba3c86a7b0471fcd60469225ed Mon Sep 17 00:00:00 2001
+From: Jim Ramsay <jim_ramsay@dell.com>
+Date: Mon, 1 Nov 2010 08:43:17 -0400
+Subject: [PATCH 2/3] Use gkrellm_gkd_string_width
+
+This wrapper is designed to transition from GdkFont to
+PangoFontDescription. Without it, there is a warning and a probable
+runtime crash, as we are feeding the wrong structure into
+'gdk_string_width'.
+---
+ mailwatch.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/mailwatch.c b/mailwatch.c
+index 3f0f0a2..5cca01e 100644
+--- a/mailwatch.c
++++ b/mailwatch.c
+@@ -608,7 +608,7 @@ update_plugin(void) {
+
+ p->statstext->x_off =
+ gkrellm_chart_width() -
+- gdk_string_width(p->panel->textstyle->font,
++ gkrellm_gdk_string_width(p->panel->textstyle->font,
+ buf) -
+ 2 * gkrellm_get_style_margins(p->panel->style)->left;
+
+--
+1.7.3.1
+
diff --git a/x11-plugins/gkrellm-mailwatch/files/2.4.3-0003-Remove-a-few-more-GCC-warnings.patch b/x11-plugins/gkrellm-mailwatch/files/2.4.3-0003-Remove-a-few-more-GCC-warnings.patch
new file mode 100644
index 000000000000..5cc76c6fc828
--- /dev/null
+++ b/x11-plugins/gkrellm-mailwatch/files/2.4.3-0003-Remove-a-few-more-GCC-warnings.patch
@@ -0,0 +1,41 @@
+From 873186988c7b7cbde50d1f44ad0e745ddadf0e18 Mon Sep 17 00:00:00 2001
+From: Jim Ramsay <jim_ramsay@dell.com>
+Date: Mon, 1 Nov 2010 08:44:17 -0400
+Subject: [PATCH 3/3] Remove a few more GCC warnings
+
+These are mostly harmless, but no harm in cleaning them up.
+---
+ mailwatch.c | 5 +++--
+ 1 files changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/mailwatch.c b/mailwatch.c
+index 5cca01e..fcb77a8 100644
+--- a/mailwatch.c
++++ b/mailwatch.c
+@@ -198,7 +198,7 @@ check_mh(Mailbox * mbox) {
+ return TRUE;
+
+ /* Check the unseen mail */
+- while (fgets(buf, sizeof(buf), f), !feof(f))
++ while (fgets(buf, sizeof(buf), f) && !feof(f))
+ if (!strncmp(buf, "unseen", sizeof("unseen") - 1)) {
+ found = 1;
+ break;
+@@ -444,12 +444,13 @@ plug_expose_event(GtkWidget * widget, GdkEventExpose * event) {
+ static gint
+ button_release(GtkWidget * widget, GdkEventButton * ev, Mailpanel * panel) {
+ gchar *command;
++ int retcode;
+
+ if (panel->command == NULL)
+ return FALSE;
+ command = malloc((strlen(panel->command) + 4) * sizeof(char));
+ strcpy(command, panel->command);
+- system(strcat(command, " &"));
++ retcode = system(strcat(command, " &"));
+ free(command);
+ return FALSE;
+ }
+--
+1.7.3.1
+
diff --git a/x11-plugins/gkrellm-mailwatch/gkrellm-mailwatch-2.4.3-r1.ebuild b/x11-plugins/gkrellm-mailwatch/gkrellm-mailwatch-2.4.3-r1.ebuild
new file mode 100644
index 000000000000..8212d6e4d350
--- /dev/null
+++ b/x11-plugins/gkrellm-mailwatch/gkrellm-mailwatch-2.4.3-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-mailwatch/gkrellm-mailwatch-2.4.3-r1.ebuild,v 1.1 2010/11/01 13:10:36 lack Exp $
+
+EAPI="3"
+inherit gkrellm-plugin eutils
+
+IUSE=""
+S=${WORKDIR}/${PN}
+DESCRIPTION="A GKrellM2 plugin that shows the status of additional mail boxes"
+SRC_URI="http://gkrellm.luon.net/files/${P}.tar.gz"
+HOMEPAGE="http://gkrellm.luon.net/mailwatch.php"
+
+SLOT="2"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+PLUGIN_SO=mailwatch.so
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-*
+}