summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2011-01-24 16:48:28 +0000
committerJim Ramsay <lack@gentoo.org>2011-01-24 16:48:28 +0000
commitc14f37f98ca62a04f5fd91d2709a3ca0ea989e9a (patch)
tree8fcb2f3444bd4acfc315931dfb36cbadfac74be0 /x11-plugins
parentPin to webkit slot 2. (diff)
downloadgentoo-2-c14f37f98ca62a04f5fd91d2709a3ca0ea989e9a.tar.gz
gentoo-2-c14f37f98ca62a04f5fd91d2709a3ca0ea989e9a.tar.bz2
gentoo-2-c14f37f98ca62a04f5fd91d2709a3ca0ea989e9a.zip
Applied user patch to fix CFLAGS and LDFLAGS (Bug #333989)
(Portage version: 2.1.9.34/cvs/Linux i686)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/gkrelltop/ChangeLog9
-rw-r--r--x11-plugins/gkrelltop/gkrelltop-2.2.11-r1.ebuild43
2 files changed, 50 insertions, 2 deletions
diff --git a/x11-plugins/gkrelltop/ChangeLog b/x11-plugins/gkrelltop/ChangeLog
index 960b5ba9538d..5cf2d491cdf7 100644
--- a/x11-plugins/gkrelltop/ChangeLog
+++ b/x11-plugins/gkrelltop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/gkrelltop
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrelltop/ChangeLog,v 1.32 2009/09/05 22:35:12 maekke Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrelltop/ChangeLog,v 1.33 2011/01/24 16:48:28 lack Exp $
+
+*gkrelltop-2.2.11-r1 (24 Jan 2011)
+
+ 24 Jan 2011; Jim Ramsay <lack@gentoo.org> +gkrelltop-2.2.11-r1.ebuild:
+ Applied user patch to fix CFLAGS and LDFLAGS (Bug #333989)
05 Sep 2009; Markus Meier <maekke@gentoo.org> gkrelltop-2.2.11.ebuild:
amd64 stable, bug #271463
diff --git a/x11-plugins/gkrelltop/gkrelltop-2.2.11-r1.ebuild b/x11-plugins/gkrelltop/gkrelltop-2.2.11-r1.ebuild
new file mode 100644
index 000000000000..cef9fef9cb02
--- /dev/null
+++ b/x11-plugins/gkrelltop/gkrelltop-2.2.11-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrelltop/gkrelltop-2.2.11-r1.ebuild,v 1.1 2011/01/24 16:48:28 lack Exp $
+
+EAPI=2
+inherit gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="a GKrellM2 plugin which displays the top three processes"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}.orig.tar.gz"
+HOMEPAGE="http://sourceforge.net/projects/gkrelltop"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="X"
+
+PLUGIN_SERVER_SO=gkrelltopd.so
+PLUGIN_SO=gkrelltop.so
+
+S="${WORKDIR}/${P}.orig"
+
+RDEPEND="=app-admin/gkrellm-2*[X=]"
+DEPEND="${RDEPEND}
+ =dev-libs/glib-2*
+ X? ( =x11-libs/gtk+-2* )"
+
+src_prepare() {
+ sed -i \
+ -e "s:/usr/bin/gcc:$(tc-getCC) \$(CFLAGS):" \
+ -e 's/-shared/$(LDFLAGS) &/' \
+ Makefile || die
+}
+
+src_compile() {
+ use X || TARGET="server"
+ emake ${TARGET}
+}
+
+pkg_postinst() {
+ einfo "To enable the gkrelltopd server plugin, you must add the following"
+ einfo "line to /etc/gkrellmd.conf:"
+ einfo "\tplugin-enable gkrelltopd"
+}