summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2010-06-28 09:09:44 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2010-06-28 09:09:44 +0000
commita302a5749d28e6cb3e52be19cbd21b63bedec813 (patch)
treef9fbf9f7b928365428368eb5d27f3cdf7b03659e /x11-plugins
parentVersion bump. No noteworthy changes. (diff)
downloadgentoo-2-a302a5749d28e6cb3e52be19cbd21b63bedec813.tar.gz
gentoo-2-a302a5749d28e6cb3e52be19cbd21b63bedec813.tar.bz2
gentoo-2-a302a5749d28e6cb3e52be19cbd21b63bedec813.zip
Fix support with gtk+ >= 2.18, bug #310779
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmfishtime/ChangeLog10
-rw-r--r--x11-plugins/wmfishtime/files/wmfishtime-1.24-no_display.patch19
-rw-r--r--x11-plugins/wmfishtime/wmfishtime-1.24-r2.ebuild35
3 files changed, 62 insertions, 2 deletions
diff --git a/x11-plugins/wmfishtime/ChangeLog b/x11-plugins/wmfishtime/ChangeLog
index be429ef58c6a..ee2386206667 100644
--- a/x11-plugins/wmfishtime/ChangeLog
+++ b/x11-plugins/wmfishtime/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/wmfishtime
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmfishtime/ChangeLog,v 1.21 2008/01/15 12:50:06 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmfishtime/ChangeLog,v 1.22 2010/06/28 09:09:44 voyageur Exp $
+
+*wmfishtime-1.24-r2 (28 Jun 2010)
+
+ 28 Jun 2010; Bernard Cafarelli <voyageur@gentoo.org>
+ +wmfishtime-1.24-r2.ebuild, +files/wmfishtime-1.24-no_display.patch:
+ Fix support with gtk+ >= 2.18, bug #310779
15 Jan 2008; Raúl Porcel <armin76@gentoo.org> wmfishtime-1.24-r1.ebuild:
sparc stable wrt #205466, thanks to Tiago Cunha for testing
diff --git a/x11-plugins/wmfishtime/files/wmfishtime-1.24-no_display.patch b/x11-plugins/wmfishtime/files/wmfishtime-1.24-no_display.patch
new file mode 100644
index 000000000000..a991cdab934b
--- /dev/null
+++ b/x11-plugins/wmfishtime/files/wmfishtime-1.24-no_display.patch
@@ -0,0 +1,19 @@
+--- fishmon.c.orig 2010-06-27 18:38:42.000000000 +0200
++++ fishmon.c 2010-06-27 18:40:56.000000000 +0200
+@@ -152,6 +152,8 @@
+
+ int main(int argc, char **argv)
+ {
++ /* This is needed to proper dockapp work on >=GTK+-2.18 */
++ setenv("GDK_NATIVE_WINDOWS", "1", 0);
+ int ch;
+ GdkEvent *event;
+ #ifdef PRO
+@@ -694,6 +696,7 @@
+ gdk_window_show(bm.win);
+
+ XSetWMHints(GDK_WINDOW_XDISPLAY(bm.win), win, &wmhints);
++ gdk_window_show(bm.iconwin);
+
+ #undef MASK
+ } /* make_new_fishmon_dockapp */
diff --git a/x11-plugins/wmfishtime/wmfishtime-1.24-r2.ebuild b/x11-plugins/wmfishtime/wmfishtime-1.24-r2.ebuild
new file mode 100644
index 000000000000..6c2845c01dad
--- /dev/null
+++ b/x11-plugins/wmfishtime/wmfishtime-1.24-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmfishtime/wmfishtime-1.24-r2.ebuild,v 1.1 2010/06/28 09:09:44 voyageur Exp $
+
+EAPI=3
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A fun clock applet for your desktop featuring swimming fish"
+HOMEPAGE="http://www.ne.jp/asahi/linux/timecop"
+SRC_URI="http://www.ne.jp/asahi/linux/timecop/software/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gtk.patch
+ epatch "${FILESDIR}"/${P}-no_display.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed."
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc ALL_I_GET_IS_A_GRAY_BOX AUTHORS ChangeLog CODING README
+}