summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2010-07-28 14:41:55 +0000
committerJim Ramsay <lack@gentoo.org>2010-07-28 14:41:55 +0000
commita061c88f0cf9572cc8e21822eed0085428bb7684 (patch)
tree1de9a64b19f923ece0b41b6cb4c331adba01b565 /x11-plugins
parentSet dev-lang/python-2* dependency. (diff)
downloadgentoo-2-a061c88f0cf9572cc8e21822eed0085428bb7684.tar.gz
gentoo-2-a061c88f0cf9572cc8e21822eed0085428bb7684.tar.bz2
gentoo-2-a061c88f0cf9572cc8e21822eed0085428bb7684.zip
Patch double-free of PangoFontDescription (Bug #284504)
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/gkrellsun/ChangeLog10
-rw-r--r--x11-plugins/gkrellsun/files/gkrellsun-1.0.0-reenable.patch16
-rw-r--r--x11-plugins/gkrellsun/gkrellsun-1.0.0-r2.ebuild28
3 files changed, 52 insertions, 2 deletions
diff --git a/x11-plugins/gkrellsun/ChangeLog b/x11-plugins/gkrellsun/ChangeLog
index 8a188e670978..719e63727658 100644
--- a/x11-plugins/gkrellsun/ChangeLog
+++ b/x11-plugins/gkrellsun/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/gkrellsun
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellsun/ChangeLog,v 1.27 2007/03/12 17:52:07 lack Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellsun/ChangeLog,v 1.28 2010/07/28 14:41:54 lack Exp $
+
+*gkrellsun-1.0.0-r2 (28 Jul 2010)
+
+ 28 Jul 2010; Jim Ramsay <lack@gentoo.org> +gkrellsun-1.0.0-r2.ebuild,
+ +files/gkrellsun-1.0.0-reenable.patch:
+ Patch double-free of PangoFontDescription (Bug #284504)
12 Mar 2007; Jim Ramsay <lack@gentoo.org> gkrellsun-1.0.0-r1.ebuild:
Updated to use new gkrellm-plugin eclass
diff --git a/x11-plugins/gkrellsun/files/gkrellsun-1.0.0-reenable.patch b/x11-plugins/gkrellsun/files/gkrellsun-1.0.0-reenable.patch
new file mode 100644
index 000000000000..f47b96e88905
--- /dev/null
+++ b/x11-plugins/gkrellsun/files/gkrellsun-1.0.0-reenable.patch
@@ -0,0 +1,16 @@
+diff --git a/src20/gkrellsun.c b/src20/gkrellsun.c
+index f3adff5..0738bfc 100644
+--- a/src20/gkrellsun.c
++++ b/src20/gkrellsun.c
+@@ -1140,7 +1140,10 @@ cb_plugin_disabled()
+
+ save_sun_data();
+
+- if (textOptions.fontDesc) pango_font_description_free (textOptions.fontDesc);
++ if (textOptions.fontDesc) {
++ pango_font_description_free (textOptions.fontDesc);
++ textOptions.fontDesc = NULL;
++ }
+
+ /* This happens when user quits X Windows and gkrellm2 is still running */
+ if (colormap == NULL)
diff --git a/x11-plugins/gkrellsun/gkrellsun-1.0.0-r2.ebuild b/x11-plugins/gkrellsun/gkrellsun-1.0.0-r2.ebuild
new file mode 100644
index 000000000000..c8b870f2c55e
--- /dev/null
+++ b/x11-plugins/gkrellsun/gkrellsun-1.0.0-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellsun/gkrellsun-1.0.0-r2.ebuild,v 1.1 2010/07/28 14:41:54 lack Exp $
+
+EAPI="3"
+inherit gkrellm-plugin eutils
+
+IUSE="nls"
+DESCRIPTION="A GKrellM plugin that shows sunrise and sunset times."
+HOMEPAGE="http://gkrellsun.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gkrellsun/${P}.tar.gz"
+
+SLOT="1"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND="nls? ( sys-devel/gettext )"
+
+PLUGIN_SO=src20/gkrellsun.so
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-reenable.patch"
+}
+
+src_compile() {
+ use nls && myconf="$myconf enable_nls=1"
+ emake ${myconf}
+}