summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2012-10-24 11:25:47 +0000
committerAgostino Sarubbo <ago@gentoo.org>2012-10-24 11:25:47 +0000
commit9cb1a8dc5cf6cacedf075061c4f42ee8487a993a (patch)
tree8e408854700c2873358ea939de8f5bb57cf9ecc2 /x11-plugins
parentTemp mask of new razorqt-0.5.1 release (diff)
downloadgentoo-2-9cb1a8dc5cf6cacedf075061c4f42ee8487a993a.tar.gz
gentoo-2-9cb1a8dc5cf6cacedf075061c4f42ee8487a993a.tar.bz2
gentoo-2-9cb1a8dc5cf6cacedf075061c4f42ee8487a993a.zip
New revision, eapi4 bump, respect CC, LDFLAGS, add ~amd64
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/allin1/ChangeLog11
-rw-r--r--x11-plugins/allin1/allin1-0.5.0-r1.ebuild39
-rw-r--r--x11-plugins/allin1/files/makefile.patch23
3 files changed, 70 insertions, 3 deletions
diff --git a/x11-plugins/allin1/ChangeLog b/x11-plugins/allin1/ChangeLog
index 170957ed425a..b319273e390f 100644
--- a/x11-plugins/allin1/ChangeLog
+++ b/x11-plugins/allin1/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/allin1
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/allin1/ChangeLog,v 1.12 2007/07/22 02:24:05 coldwind Exp $
+# Copyright 2000-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/allin1/ChangeLog,v 1.13 2012/10/24 11:25:47 ago Exp $
+
+*allin1-0.5.0-r1 (24 Oct 2012)
+
+ 24 Oct 2012; Agostino Sarubbo <ago@gentoo.org> +allin1-0.5.0-r1.ebuild,
+ +files/makefile.patch:
+ New revision, eapi4 bump, respect CC, LDFLAGS, add ~amd64
22 Jul 2007; Santiago M. Mola <coldwind@gentoo.org> allin1-0.5.0.ebuild:
virtual/x11 removed.
@@ -52,4 +58,3 @@
Please type the log entry, finish with ctrl-d
Initial version ebuild submitted by <kevin@desertsol.com>.
Closes bug #23009.
-
diff --git a/x11-plugins/allin1/allin1-0.5.0-r1.ebuild b/x11-plugins/allin1/allin1-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..409524f2ae61
--- /dev/null
+++ b/x11-plugins/allin1/allin1-0.5.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/allin1/allin1-0.5.0-r1.ebuild,v 1.1 2012/10/24 11:25:47 ago Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="All in one monitoring dockapp: RAM, CPU, Net, Power, df, seti"
+HOMEPAGE="http://ilpettegolo.altervista.org/linux_allin1.en.shtml"
+SRC_URI="mirror://sourceforge/allinone/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_prepare() {
+ epatch "${FILESDIR}/makefile.patch"
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin src/allin1
+ doman docs/allin1.1
+ dodoc README README.it TODO ChangeLog BUGS src/allin1.conf.example
+}
diff --git a/x11-plugins/allin1/files/makefile.patch b/x11-plugins/allin1/files/makefile.patch
new file mode 100644
index 000000000000..20837b4488c4
--- /dev/null
+++ b/x11-plugins/allin1/files/makefile.patch
@@ -0,0 +1,23 @@
+--- src/Makefile.old 2012-10-24 13:12:48.128285694 +0200
++++ src/Makefile 2012-10-24 13:19:56.135247071 +0200
+@@ -11,8 +11,9 @@
+
+ CC = gcc
+ FLEX = flex
+-LIBFLAGS = -ggdb -Wall -O2 -fPIC
+-CFLAGS = -ggdb -Wall -O2
++LIBFLAGS = -fPIC
++CFLAGS =
++LDFLAGS =
+ GENERATED = allin1 confparse.c
+ LIBRARIES = -L/usr/X11R6/lib -lXext -lX11 -lXpm -lm
+ MODULES = allin1.o dockhelper.o memory.o battery.o cpu.o \
+@@ -58,7 +59,7 @@
+
+
+ allin1: $(MODULES)
+- $(CC) $(CFLAGS) -o $@ $(MODULES) -DDEBUG $(LIBRARIES)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(MODULES) -DDEBUG $(LIBRARIES)
+
+
+ install: allin1