summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-20 15:57:58 +0000
committerJustin Lecher <jlec@gentoo.org>2015-03-20 15:57:58 +0000
commit94044307c6be58d9e6bc2c9edb3e0c764c019a95 (patch)
tree7951d72f7787915b7ff8198d9229dfe668b649f0 /x11-plugins
parentModernize ebuild (diff)
downloadgentoo-2-94044307c6be58d9e6bc2c9edb3e0c764c019a95.tar.gz
gentoo-2-94044307c6be58d9e6bc2c9edb3e0c764c019a95.tar.bz2
gentoo-2-94044307c6be58d9e6bc2c9edb3e0c764c019a95.zip
Modernize ebuild
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmmldonkey/ChangeLog11
-rw-r--r--x11-plugins/wmmldonkey/metadata.xml2
-rw-r--r--x11-plugins/wmmldonkey/wmmldonkey-0.003-r1.ebuild46
3 files changed, 55 insertions, 4 deletions
diff --git a/x11-plugins/wmmldonkey/ChangeLog b/x11-plugins/wmmldonkey/ChangeLog
index 984350a1814d..1c165939a0d2 100644
--- a/x11-plugins/wmmldonkey/ChangeLog
+++ b/x11-plugins/wmmldonkey/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/wmmldonkey
-# Copyright 2000-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmldonkey/ChangeLog,v 1.8 2012/02/15 09:51:41 voyageur Exp $
+# Copyright 2000-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmldonkey/ChangeLog,v 1.9 2015/03/20 15:57:58 jlec Exp $
+
+*wmmldonkey-0.003-r1 (20 Mar 2015)
+
+ 20 Mar 2015; Justin Lecher <jlec@gentoo.org> +wmmldonkey-0.003-r1.ebuild,
+ metadata.xml:
+ Modernize ebuild
15 Feb 2012; Bernard Cafarelli <voyageur@gentoo.org> wmmldonkey-0.003.ebuild:
Update HOMEPAGE and SRC_URI, thanks Lorenz in bug #394607
@@ -29,4 +35,3 @@
26 Dec 2003; Markus Nigbur <pyrania@gentoo.org> metadata.xml,
wmmldonkey-0.003.ebuild:
Initial import. Thanks to Marco Lui for the ebuild.
-
diff --git a/x11-plugins/wmmldonkey/metadata.xml b/x11-plugins/wmmldonkey/metadata.xml
index b1a9efc4f2f0..ca551894a934 100644
--- a/x11-plugins/wmmldonkey/metadata.xml
+++ b/x11-plugins/wmmldonkey/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>desktop-dock</herd>
+ <herd>desktop-dock</herd>
</pkgmetadata>
diff --git a/x11-plugins/wmmldonkey/wmmldonkey-0.003-r1.ebuild b/x11-plugins/wmmldonkey/wmmldonkey-0.003-r1.ebuild
new file mode 100644
index 000000000000..c6c4fef8aae0
--- /dev/null
+++ b/x11-plugins/wmmldonkey/wmmldonkey-0.003-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmldonkey/wmmldonkey-0.003-r1.ebuild,v 1.1 2015/03/20 15:57:58 jlec Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="wmmsg is a dockapp to show the up and downloadrate from your mldonkey"
+HOMEPAGE="http://dockapps.windowmaker.org/file.php/id/174"
+SRC_URI="http://dockapps.windowmaker.org/download.php/id/298/wmmldonkey3.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ net-p2p/mldonkey"
+
+S=${WORKDIR}/wmmldonkey3
+
+src_prepare() {
+ sed \
+ -e 's:gcc:${CC} ${CFLAGS}:' \
+ -e 's:gui_protocol.o endianess.o::' \
+ -e 's:main.c -o wmmldonkey:main.c gui_protocol.o endianess.o -o wmmldonkey:' \
+ -e 's:-lXpm -lXext:-lX11 -lXpm -lXext:' \
+ -i "${S}/Makefile" || die
+
+ tc-export CC
+}
+
+src_install() {
+ dodoc CHANGELOG README
+ dobin wmmldonkey
+}
+
+pkg_postinst() {
+ elog "Make sure the mldonkey daemon is running before you"
+ elog "attempt to run emmldonkey..."
+}