summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2004-07-08 12:33:43 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2004-07-08 12:33:43 +0000
commit8e956de1907429a2f5a543facae01a9a80f458b8 (patch)
tree6cc36bca4db1df2dcc6be802a498cf42f7f15d84 /x11-plugins
parentVersion bump; submitted by Josh Glover in bug #54196 (Manifest recommit) (diff)
downloadgentoo-2-8e956de1907429a2f5a543facae01a9a80f458b8.tar.gz
gentoo-2-8e956de1907429a2f5a543facae01a9a80f458b8.tar.bz2
gentoo-2-8e956de1907429a2f5a543facae01a9a80f458b8.zip
Initial import of x11-plugins/wmacpimon, version 0.2.1
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmacpimon/ChangeLog8
-rw-r--r--x11-plugins/wmacpimon/Manifest6
-rw-r--r--x11-plugins/wmacpimon/files/digest-wmacpimon-0.2.11
-rw-r--r--x11-plugins/wmacpimon/files/wmacpimon.c.patch20
-rw-r--r--x11-plugins/wmacpimon/files/wmacpimon.initscript15
-rw-r--r--x11-plugins/wmacpimon/metadata.xml11
-rw-r--r--x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild50
7 files changed, 111 insertions, 0 deletions
diff --git a/x11-plugins/wmacpimon/ChangeLog b/x11-plugins/wmacpimon/ChangeLog
new file mode 100644
index 000000000000..ec7cc6b41c8c
--- /dev/null
+++ b/x11-plugins/wmacpimon/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for x11-plugins/wmacpimon
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmacpimon/ChangeLog,v 1.1 2004/07/08 12:33:43 s4t4n Exp $
+
+*wmacpimon-0.2.1 (08 Jul 2004)
+
+ 08 Jul 2004; Michele Noberasco <s4t4n@gentoo.org> wmacpimon-0.2.1.ebuild:
+ Initial import.
diff --git a/x11-plugins/wmacpimon/Manifest b/x11-plugins/wmacpimon/Manifest
new file mode 100644
index 000000000000..b19b4da59f01
--- /dev/null
+++ b/x11-plugins/wmacpimon/Manifest
@@ -0,0 +1,6 @@
+MD5 204751753c7c54a5af4def4291ad80b8 wmacpimon-0.2.1.ebuild 1173
+MD5 7076aac96a81fc7175e6d1e225577357 ChangeLog 248
+MD5 e0610fd0e64292e0ea4a9c297dc47d65 metadata.xml 404
+MD5 b6e42cf0c97a55a676c4b711c24f3779 files/wmacpimon.initscript 406
+MD5 ea6be2a74e2041eff879cc7239852aa3 files/digest-wmacpimon-0.2.1 66
+MD5 b73395cd8e29d43ae9a72cd04c69f17f files/wmacpimon.c.patch 968
diff --git a/x11-plugins/wmacpimon/files/digest-wmacpimon-0.2.1 b/x11-plugins/wmacpimon/files/digest-wmacpimon-0.2.1
new file mode 100644
index 000000000000..a916582606d4
--- /dev/null
+++ b/x11-plugins/wmacpimon/files/digest-wmacpimon-0.2.1
@@ -0,0 +1 @@
+MD5 50efb23d6c6e2e692bee4407d52756ca wmacpimon-0.2.1.tar.gz 26498
diff --git a/x11-plugins/wmacpimon/files/wmacpimon.c.patch b/x11-plugins/wmacpimon/files/wmacpimon.c.patch
new file mode 100644
index 000000000000..001c1d8c96be
--- /dev/null
+++ b/x11-plugins/wmacpimon/files/wmacpimon.c.patch
@@ -0,0 +1,20 @@
+--- wmacpimon.c 2004-07-08 14:16:22.184359328 +0200
++++ wmacpimon.c 2004-07-08 14:15:59.677780848 +0200
+@@ -314,7 +314,7 @@
+ acpinfo = calloc(1, sizeof(ACPInfo));
+ dockapp->blink = OFF;
+ init_acpinfo();
+- strcpy(prcfile, ".wmacpimon.prc");
++ strcpy(prcfile, "/var/tmp/wmacpimon.prc");
+
+ /* parse command-line options */
+ while ((ch = getopt(argc, argv, "pd:b:c:s:h")) != EOF) {
+@@ -345,7 +345,7 @@
+ printf("wmacpimon v%s (c) 2002 Costantino Pistagna (valvoline@vrlteam.org)\n"
+ "usage: wmacpimon [-d] [-b] [-p] [-c] [-s]\n\n"
+ "-d display\tdisplay on remote display <display>\n"
+- "-b value\tprcfile for wmacpimond comunication (default: ~/.wmacpimon.prc)\n"
++ "-b value\tprcfile for wmacpimond comunication (default: /var/tmp/wmacpimon.prc)\n"
+ "-p\t\tset powersave mode\n"
+ "-c value\tset critical level (default to 10)\n"
+ "-s value\tshutdown pc when battery value (percent) has reached\n"
diff --git a/x11-plugins/wmacpimon/files/wmacpimon.initscript b/x11-plugins/wmacpimon/files/wmacpimon.initscript
new file mode 100644
index 000000000000..049cac53fb34
--- /dev/null
+++ b/x11-plugins/wmacpimon/files/wmacpimon.initscript
@@ -0,0 +1,15 @@
+#!/sbin/runscript
+
+start() {
+ ebegin "Starting up wmacpimond daemon"
+ touch /var/tmp/wmacpimon.prc
+ start-stop-daemon --start --quiet --exec /usr/bin/wmacpimond -- /var/tmp/wmacpimon.prc >/dev/null
+ eend $? "Failed to start wmacpimond"
+}
+
+stop() {
+ ebegin "Shutting down wmacpimond daemon"
+ killall wmacpimonmd &>/dev/null
+ rm /var/tmp/wmacpimon.prc &>/dev/null
+ eend $? "Failed to stop wmacpimond"
+}
diff --git a/x11-plugins/wmacpimon/metadata.xml b/x11-plugins/wmacpimon/metadata.xml
new file mode 100644
index 000000000000..63abaff70235
--- /dev/null
+++ b/x11-plugins/wmacpimon/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+<longdescription>
+wmacpimon is a Windowmaker dockapp that monitors
+the temperature and Speedstep features in new ACPI-based systems.
+It supports batteries, automatic shutdown when the power is low,
+and multiple screens.
+</longdescription>
+</pkgmetadata>
diff --git a/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild b/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild
new file mode 100644
index 000000000000..b1806e751955
--- /dev/null
+++ b/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild,v 1.1 2004/07/08 12:33:43 s4t4n Exp $
+
+inherit eutils
+
+IUSE=""
+
+DESCRIPTION="WMaker DockApp that monitors the temperature and Speedstep features in new ACPI-based systems."
+HOMEPAGE="http://www.vrlteam.org/wmacpimon/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/x11"
+
+src_unpack()
+{
+ unpack ${A}
+
+ # patch wmacpimon.c file to set default path for
+ # wmacpimon.prc to /var/tmp/
+ cd ${S}
+ epatch ${FILESDIR}/wmacpimon.c.patch
+}
+
+src_compile()
+{
+ make \
+ CFLAGS="${CFLAGS} -DACPI -Wall -I/usr/X11R6/include" \
+ LDFLAGS="${CFLAGS} -DACPI -L/usr/X11R6/lib -lX11 -lXpm -lXext" \
+ || die "Compilation failed"
+}
+
+src_install()
+{
+ dobin wmacpimond wmacpimon
+ dodoc AUTHORS ChangeLog README INSTALL
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/wmacpimon.initscript wmacpimon
+}
+
+pkg_postinst()
+{
+ einfo "Remember to start the wmacpimond daemon"
+ einfo "(by issuing the \"/etc/init.d/wmacpimon start\" command)"
+ einfo "before you attempt to run wmacpimon..."
+}