summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2006-09-26 05:23:35 +0000
committerDoug Goldstein <cardoe@gentoo.org>2006-09-26 05:23:35 +0000
commit835311f6dd706f8bf859ea1de7dff075b87edcbb (patch)
treecddabdaec41c0a672579f52e7a07c42c703d9920 /x11-plugins
parentFiltering fforce-addr on x86, as its the fix I'm going to do for the package.... (diff)
downloadgentoo-2-835311f6dd706f8bf859ea1de7dff075b87edcbb.tar.gz
gentoo-2-835311f6dd706f8bf859ea1de7dff075b87edcbb.tar.bz2
gentoo-2-835311f6dd706f8bf859ea1de7dff075b87edcbb.zip
rev bump for Thunderbird 1.5.0.7. Based of ebuild by Walter Meinl <wuno@lsvw.de> from bug #144628. Untested on amd64 until the morning, since they have so many problems marking -amd64 for now.
(Portage version: 2.1.2_pre1-r2)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/enigmail/ChangeLog9
-rw-r--r--x11-plugins/enigmail/enigmail-0.94.1.ebuild191
-rw-r--r--x11-plugins/enigmail/files/digest-enigmail-0.94.130
3 files changed, 229 insertions, 1 deletions
diff --git a/x11-plugins/enigmail/ChangeLog b/x11-plugins/enigmail/ChangeLog
index 4bfc3c528903..7cb41885d572 100644
--- a/x11-plugins/enigmail/ChangeLog
+++ b/x11-plugins/enigmail/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-plugins/enigmail
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/enigmail/ChangeLog,v 1.30 2006/09/21 14:47:54 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/enigmail/ChangeLog,v 1.31 2006/09/26 05:23:35 cardoe Exp $
+
+*enigmail-0.94.1 (26 Sep 2006)
+
+ 26 Sep 2006; Doug Goldstein <cardoe@gentoo.org> +enigmail-0.94.1.ebuild:
+ rev bump for Thunderbird 1.5.0.7. Based of ebuild by Walter Meinl
+ <wuno@lsvw.de> from bug #144628. Untested on amd64 until the morning, since
+ they have so many problems marking -amd64 for now.
21 Sep 2006; Gustavo Zacarias <gustavoz@gentoo.org>
enigmail-0.94.0-r5.ebuild:
diff --git a/x11-plugins/enigmail/enigmail-0.94.1.ebuild b/x11-plugins/enigmail/enigmail-0.94.1.ebuild
new file mode 100644
index 000000000000..ea3a2f79790f
--- /dev/null
+++ b/x11-plugins/enigmail/enigmail-0.94.1.ebuild
@@ -0,0 +1,191 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/enigmail/enigmail-0.94.1.ebuild,v 1.1 2006/09/26 05:23:35 cardoe Exp $
+
+unset ALLOWED_FLAGS # stupid extra-functions.sh ... bug 49179
+WANT_AUTOCONF=2.1
+inherit flag-o-matic toolchain-funcs eutils nsplugins mozcoreconf mozextension makeedit multilib autotools
+
+LANGS="de el es-AR es-ES nb-NO sv-SE zh-CN"
+SHORTLANGS="es-ES nb-NO sv-SE"
+
+EMVER=${PV}
+TBVER="1.5.0.7"
+TBPVER="0.1"
+
+DESCRIPTION="Gnupg encryption plugin for thunderbird."
+HOMEPAGE="http://www.enigmail.mozdev.org"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/${TBVER}/source/thunderbird-${TBVER}-source.tar.bz2
+ mirror://gentoo/mozilla-thunderbird-${TBVER}-patches-${TBPVER}.tar.bz2
+ http://www.mozilla-enigmail.org/downloads/src/enigmail-${EMVER}.tar.gz"
+
+KEYWORDS="-amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+SLOT="0"
+LICENSE="MPL-1.1 NPL-1.1"
+IUSE=""
+
+for X in ${LANGS} ; do
+ SRC_URI="${SRC_URI} linguas_${X/-/_}? ( http://www.mozilla-enigmail.org/downloads/lang/0.9x/${PN}-${X}-0.9x.xpi )"
+ IUSE="${IUSE} linguas_${X/-/_}"
+done
+# ( mirror://gentoo/${PN}-${X}-0.9x.xpi )"
+
+for X in ${SHORTLANGS} ; do
+ SRC_URI="${SRC_URI} linguas_${X%%-*}? ( http://www.mozilla-enigmail.org/downloads/lang/0.9x/${PN}-${X}-0.9x.xpi )"
+ IUSE="${IUSE} linguas_${X%%-*}"
+done
+#( mirror://gentoo/${PN}-${X}-0.9x.xpi )"
+
+DEPEND=">=mail-client/mozilla-thunderbird-${TBVER}"
+RDEPEND="${DEPEND}
+ >=app-crypt/gnupg-1.4.5
+ >=www-client/mozilla-launcher-1.37"
+
+S=${WORKDIR}/mozilla
+
+# Needed by src_compile() and src_install().
+# Would do in pkg_setup but that loses the export attribute, they
+# become pure shell variables.
+export BUILD_OFFICIAL=1
+export MOZILLA_OFFICIAL=1
+export MOZ_CO_PROJECT=mail
+
+linguas() {
+ linguas=
+ local LANG
+ for LANG in ${LINGUAS}; do
+ if hasq ${LANG} en en_US; then
+ hasq en ${linguas} || \
+ linguas="${linguas:+"${linguas} "}en"
+ continue
+ elif hasq ${LANG} ${LANGS//-/_}; then
+ hasq ${LANG//_/-} ${linguas} || \
+ linguas="${linguas:+"${linguas} "}${LANG//_/-}"
+ continue
+ else
+ local SLANG
+ for SLANG in ${SHORTLANGS}; do
+ if [[ ${LANG} == ${SLANG%%-*} ]]; then
+ hasq ${SLANG} ${linguas} || \
+ linguas="${linguas:+"${linguas} "}${SLANG}"
+ continue 2
+ fi
+ done
+ fi
+ ewarn "Sorry, but ${PN} does not support the ${LANG} LINGUA"
+ done
+}
+
+src_unpack() {
+ unpack thunderbird-${TBVER}-source.tar.bz2 mozilla-thunderbird-${TBVER}-patches-${TBPVER}.tar.bz2 || die "unpack failed"
+
+ linguas
+ for X in ${linguas}; do
+ [[ ${X} != en ]] && xpi_unpack ${PN}-${X}-0.9x.xpi
+ done
+
+ cd ${S} || die "cd failed"
+
+ # Apply our patches
+ EPATCH_SUFFIX="patch" \
+ EPATCH_FORCE="yes" \
+ epatch ${WORKDIR}/patch
+
+ # Unpack the enigmail plugin
+ cd ${S}/mailnews/extensions || die
+ unpack enigmail-${EMVER}.tar.gz
+ cd ${S}/mailnews/extensions/enigmail || die "cd failed"
+ makemake2
+
+ cd ${S}
+
+ # Use the right theme for thunderbird #45609
+ sed -i -ne '/^enigmail-skin.jar:$/ { :x; n; /^\t/bx; }; p' mailnews/extensions/enigmail/ui/jar.mn
+
+ # Don't allow upgrades via the browser
+ epatch ${FILESDIR}/50_enigmail_no_upgrade-1.patch
+
+ # Fix installation of enigmail.js
+ epatch ${FILESDIR}/70_enigmail-fix.patch
+
+ WANT_AUTOCONF="2.1" \
+ eautoreconf || die "failed running autoreconf"
+}
+
+src_compile() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/mozilla-thunderbird
+
+ ####################################
+ #
+ # mozconfig, CFLAGS and CXXFLAGS setup
+ #
+ ####################################
+
+ mozconfig_init
+
+ # tb-specific settings
+ mozconfig_annotate '' \
+ --with-system-nspr \
+ --with-system-nss \
+ --with-default-mozilla-five-home=${MOZILLA_FIVE_HOME} \
+ --with-user-appdir=.thunderbird
+
+ # Finalize and report settings
+ mozconfig_final
+
+ # hardened GCC uses -fstack-protector-all by default, and this breaks
+ # thunderbird
+ gcc-specs-ssp && append-flags -fno-stack-protector-all
+ replace-flags -fstack-protector-all -fstack-protector
+
+ ####################################
+ #
+ # Configure and build Thunderbird
+ #
+ ####################################
+
+ econf || die "econf failed"
+
+ # This removes extraneous CFLAGS from the Makefiles to reduce RAM
+ # requirements while compiling
+ edit_makefiles
+
+ # Only build the parts necessary to support building enigmail
+ emake -j1 export || die "make export failed"
+ emake -C modules/libreg || die "make modules/libreg failed"
+ emake -C xpcom/string || die "make xpcom/string failed"
+ emake -C xpcom || die "make xpcom failed"
+ emake -C xpcom/obsolete || die "make xpcom/obsolete failed"
+
+ # Build the enigmail plugin
+ einfo "Building Enigmail plugin..."
+ emake -C ${S}/mailnews/extensions/enigmail || die "make enigmail failed"
+
+ # Package the enigmail plugin; this may be the easiest way to collect the
+ # necessary files
+ emake -j1 -C ${S}/mailnews/extensions/enigmail xpi || die "make xpi failed"
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/mozilla-thunderbird
+ declare emid
+
+ cd ${T}
+ unzip ${S}/dist/bin/*.xpi install.rdf
+ emid=$(sed -n '/<em:id>/!d; s/.*\({.*}\).*/\1/; p; q' install.rdf)
+
+ dodir ${MOZILLA_FIVE_HOME}/extensions/${emid}
+ cd ${D}${MOZILLA_FIVE_HOME}/extensions/${emid}
+ unzip ${S}/dist/bin/*.xpi
+
+ # these files will be picked up by mozilla-launcher -register
+ dodir ${MOZILLA_FIVE_HOME}/{chrome,extensions}.d
+ insinto ${MOZILLA_FIVE_HOME}/chrome.d
+ newins ${S}/dist/bin/chrome/installed-chrome.txt ${PN}
+ echo "extension,${emid}" > ${D}${MOZILLA_FIVE_HOME}/extensions.d/${PN}
+
+ linguas
+ for X in ${linguas}; do
+ [[ ${X} != en ]] && xpi_install ${WORKDIR}/${PN}-${X}-0.9x
+ done
+}
diff --git a/x11-plugins/enigmail/files/digest-enigmail-0.94.1 b/x11-plugins/enigmail/files/digest-enigmail-0.94.1
new file mode 100644
index 000000000000..c049cfa7fce3
--- /dev/null
+++ b/x11-plugins/enigmail/files/digest-enigmail-0.94.1
@@ -0,0 +1,30 @@
+MD5 b255e7a77ecea435934bfa1872e99f6a enigmail-0.94.1.tar.gz 513084
+RMD160 1b8719c7669449f706bd3ff6964565e6ba9f8902 enigmail-0.94.1.tar.gz 513084
+SHA256 3584329e4f51e43fbb9028cf47101de8c74651e7607de80cb1f61349424133c1 enigmail-0.94.1.tar.gz 513084
+MD5 3af52a4c8277e825451474115379e33d enigmail-de-0.9x.xpi 2385
+RMD160 c4a2c02bee819639938cef3fc49b0a168bef6a99 enigmail-de-0.9x.xpi 2385
+SHA256 bd7ce56444955e532266a28e1f17d86ca2ae649d441b24b1d79915355de43f27 enigmail-de-0.9x.xpi 2385
+MD5 1ea24fe218e37a12c307c542ae5909f5 enigmail-el-0.9x.xpi 37047
+RMD160 b655be606c1f84a626969b29d34ea4b139aaebf5 enigmail-el-0.9x.xpi 37047
+SHA256 1bda2a0f2f081c5b5a9e612890dff16469f2b794ce21e10fca249f758ea3eebe enigmail-el-0.9x.xpi 37047
+MD5 ba2c0188476992ecfcd389ea1b9e150b enigmail-es-AR-0.9x.xpi 28723
+RMD160 56a8c4ee531adf40dedcfb0a6d4930cddfb73c9a enigmail-es-AR-0.9x.xpi 28723
+SHA256 8e58e443d89cfc8ae574a8ba6a27f0b3143306673e79f1a65300a2a2e13a6405 enigmail-es-AR-0.9x.xpi 28723
+MD5 4e147df61d36030bb2754ab702da8491 enigmail-es-ES-0.9x.xpi 30493
+RMD160 57feebbf302d16eff8ff0003d98fcaf3c5a2c992 enigmail-es-ES-0.9x.xpi 30493
+SHA256 a4ae0282c991cd66f75a980d840cdb39cd357d4257338015ddcd84ee239665b4 enigmail-es-ES-0.9x.xpi 30493
+MD5 2aa5734f939734bdc05a29e0f2cf1c3e enigmail-nb-NO-0.9x.xpi 28466
+RMD160 756a7e63d557d1eff49232d1eaec322cfc01f2f0 enigmail-nb-NO-0.9x.xpi 28466
+SHA256 09f61fb75f0df03a8779a89b9b39cba2aafdaab257909537c6d9c89eb7f57270 enigmail-nb-NO-0.9x.xpi 28466
+MD5 8850c1eab91e441d30a2e536b3b31a3b enigmail-sv-SE-0.9x.xpi 30803
+RMD160 5f4259a55e6753a6ec61a7a5eac64b365d3a1973 enigmail-sv-SE-0.9x.xpi 30803
+SHA256 afa3b754d9372cc531752e83909c6147cdc10d7a5ef42f364dc8cbbc686af93c enigmail-sv-SE-0.9x.xpi 30803
+MD5 ea388891cc3e67a5c69345608e2ca127 enigmail-zh-CN-0.9x.xpi 31747
+RMD160 a65e2a014777d1d13c9d45e14b6f9abec03b75f2 enigmail-zh-CN-0.9x.xpi 31747
+SHA256 628141041a7b316ede43cb0fda01d834dc02b344f6ad6b491d4329d2eead7512 enigmail-zh-CN-0.9x.xpi 31747
+MD5 02c06f7c12807daf4d990db5519696e6 mozilla-thunderbird-1.5.0.7-patches-0.1.tar.bz2 30715
+RMD160 a86a745963ad911da7c4e30eb9a673f1b657c5af mozilla-thunderbird-1.5.0.7-patches-0.1.tar.bz2 30715
+SHA256 1f7af196a2342a27ebd37c1deed0ec6fb2e028d4b55faa9e3c5e761716b3352d mozilla-thunderbird-1.5.0.7-patches-0.1.tar.bz2 30715
+MD5 c3933149147567471000e53dbeac7429 thunderbird-1.5.0.7-source.tar.bz2 35994957
+RMD160 b8948723e4a96e22409e6a2cb3cd1b6512bef189 thunderbird-1.5.0.7-source.tar.bz2 35994957
+SHA256 99f67c50a94af48bc738c19cda390561ec518b5fec4bc4f1f43e65337b645fc9 thunderbird-1.5.0.7-source.tar.bz2 35994957