summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-01-29 01:49:06 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-01-29 01:49:06 +0000
commit7f0f6834b4a939b4a10ff89b40aaf4e26dd3b59e (patch)
treefd2e1422471742a8dd2917acd9878f19c40773f6 /x11-plugins
parentMask prime and its related packages. #464286 (diff)
downloadgentoo-2-7f0f6834b4a939b4a10ff89b40aaf4e26dd3b59e.tar.gz
gentoo-2-7f0f6834b4a939b4a10ff89b40aaf4e26dd3b59e.tar.bz2
gentoo-2-7f0f6834b4a939b4a10ff89b40aaf4e26dd3b59e.zip
Initial ebuild. Thanks to Gerion Entrup. See bug #490954.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/pidgin-xmpp-receipts/ChangeLog9
-rw-r--r--x11-plugins/pidgin-xmpp-receipts/metadata.xml8
-rw-r--r--x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.6.ebuild32
3 files changed, 49 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-xmpp-receipts/ChangeLog b/x11-plugins/pidgin-xmpp-receipts/ChangeLog
new file mode 100644
index 000000000000..ec9b2b827575
--- /dev/null
+++ b/x11-plugins/pidgin-xmpp-receipts/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for x11-plugins/pidgin-xmpp-receipts
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-xmpp-receipts/ChangeLog,v 1.1 2014/01/29 01:49:06 mrueg Exp $
+
+*pidgin-xmpp-receipts-0.6 (29 Jan 2014)
+
+ 29 Jan 2014; Manuel Rüger <mrueg@gentoo.org> +metadata.xml,
+ +pidgin-xmpp-receipts-0.6.ebuild:
+ Initial ebuild. Thanks to Gerion Entrup. See bug #490954.
diff --git a/x11-plugins/pidgin-xmpp-receipts/metadata.xml b/x11-plugins/pidgin-xmpp-receipts/metadata.xml
new file mode 100644
index 000000000000..bfcb6974f1c4
--- /dev/null
+++ b/x11-plugins/pidgin-xmpp-receipts/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.6.ebuild b/x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.6.ebuild
new file mode 100644
index 000000000000..3770f3a2233c
--- /dev/null
+++ b/x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.6.ebuild,v 1.1 2014/01/29 01:49:06 mrueg Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Implementation of xmpp message delivery receipts (XEP-0184) for Pidgin"
+HOMEPAGE="https://www.assembla.com/spaces/pidgin-xmpp-receipts/documents"
+SRC_URI="https://www.assembla.com/spaces/pidgin-xmpp-receipts/documents/ckA6jCV5Kr4OkjacwqjQXA/download/ckA6jCV5Kr4OkjacwqjQXA -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="net-im/pidgin[gtk]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_compile() {
+ GTK_PIDGIN_INCLUDES=$(pkg-config --cflags gtk+-2.0 pidgin)
+ $(tc-getCC) ${LDFLAGS} -shared ${CFLAGS} -fpic ${GTK_PIDGIN_INCLUDES} -o ${PN/pidgin-/}.so ${PN/pidgin-/}.c || die
+}
+
+src_install() {
+ PLUGIN_DIR_PIDGIN=$(pkg-config --variable=plugindir pidgin)
+ dodir "${PLUGIN_DIR_PIDGIN}"
+ insinto "${PLUGIN_DIR_PIDGIN}"
+ doins ${PN/pidgin-/}.so
+}