summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2011-05-26 14:52:47 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2011-05-26 14:52:47 +0000
commit7967dad85cd7ed24e9dc98a3314b81456ca4661a (patch)
tree648933f4478e1a709463b53a9a0937ae44846ce1 /x11-plugins
parentversion bump (diff)
downloadgentoo-2-7967dad85cd7ed24e9dc98a3314b81456ca4661a.tar.gz
gentoo-2-7967dad85cd7ed24e9dc98a3314b81456ca4661a.tar.bz2
gentoo-2-7967dad85cd7ed24e9dc98a3314b81456ca4661a.zip
Version bump. Added patch to check for /proc/acpi instead of /proc/acpi/info. Partially fixes bug #348124.
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmlaptop/ChangeLog13
-rw-r--r--x11-plugins/wmlaptop/files/wmlaptop-ACPI-detection.patch24
-rw-r--r--x11-plugins/wmlaptop/files/wmlaptop-Makefile.patch (renamed from x11-plugins/wmlaptop/files/wmlaptop-1.3-Makefile.patch)0
-rw-r--r--x11-plugins/wmlaptop/wmlaptop-1.3.ebuild7
-rw-r--r--x11-plugins/wmlaptop/wmlaptop-1.4.ebuild47
5 files changed, 86 insertions, 5 deletions
diff --git a/x11-plugins/wmlaptop/ChangeLog b/x11-plugins/wmlaptop/ChangeLog
index 2f2cae7e7502..0f41c1413651 100644
--- a/x11-plugins/wmlaptop/ChangeLog
+++ b/x11-plugins/wmlaptop/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-plugins/wmlaptop
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlaptop/ChangeLog,v 1.9 2010/09/09 09:54:32 s4t4n Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlaptop/ChangeLog,v 1.10 2011/05/26 14:52:47 s4t4n Exp $
+
+ 26 May 2011; Michele Noberasco <s4t4n@gentoo.org> wmlaptop-1.4.ebuild,
+ wmlaptop-1.3.ebuild:
+ Added patch to check for /proc/acpi instead of /proc/acpi/info. Partially fixes bug #348124.
+
+*wmlaptop-1.4 (26 May 2011)
+
+ 26 May 2011; Michele Noberasco <s4t4n@gentoo.org> wmlaptop-1.4.ebuild:
+ Version bump.
09 Sep 2010; Michele Noberasco <s4t4n@gentoo.org>; wmlaptop-1.3.ebuild,
+files/wmlaptop-1.3-Makefile.patch:
diff --git a/x11-plugins/wmlaptop/files/wmlaptop-ACPI-detection.patch b/x11-plugins/wmlaptop/files/wmlaptop-ACPI-detection.patch
new file mode 100644
index 000000000000..802e6f09a755
--- /dev/null
+++ b/x11-plugins/wmlaptop/files/wmlaptop-ACPI-detection.patch
@@ -0,0 +1,24 @@
+diff -ru wmlaptop-1.4.orig/src/battery.c wmlaptop-1.4/src/battery.c
+--- wmlaptop-1.4.orig/src/battery.c 2010-11-26 14:26:27.594108155 -0600
++++ wmlaptop-1.4/src/battery.c 2010-11-26 14:26:51.324108155 -0600
+@@ -74,7 +74,7 @@
+
+ bool ACPI_canSupport( )
+ {
+- if( access( ACPI_ACCESS_TEST, R_OK ) == SUCCESS )
++ if( access( ACPI_ACCESS_TEST, R_OK | X_OK ) == SUCCESS )
+ return true;
+ return false;
+ }
+diff -ru wmlaptop-1.4.orig/src/battery.h wmlaptop-1.4/src/battery.h
+--- wmlaptop-1.4.orig/src/battery.h 2010-11-26 14:26:27.594108155 -0600
++++ wmlaptop-1.4/src/battery.h 2010-11-26 14:26:56.100774821 -0600
+@@ -24,7 +24,7 @@
+ /*******************
+ * ACPI FEATURES *
+ *********************************************************************************/
+-#define ACPI_ACCESS_TEST "/proc/acpi/info"
++#define ACPI_ACCESS_TEST "/proc/acpi"
+ #define ACPI_BATTERY_DIR "/proc/acpi/battery"
+ //TODO #define ACPI_BATTERY_DIR "/home/mtc/hisBattery/battery"
+
diff --git a/x11-plugins/wmlaptop/files/wmlaptop-1.3-Makefile.patch b/x11-plugins/wmlaptop/files/wmlaptop-Makefile.patch
index ab1148ce117e..ab1148ce117e 100644
--- a/x11-plugins/wmlaptop/files/wmlaptop-1.3-Makefile.patch
+++ b/x11-plugins/wmlaptop/files/wmlaptop-Makefile.patch
diff --git a/x11-plugins/wmlaptop/wmlaptop-1.3.ebuild b/x11-plugins/wmlaptop/wmlaptop-1.3.ebuild
index 977590a065e7..e17e9cfab70f 100644
--- a/x11-plugins/wmlaptop/wmlaptop-1.3.ebuild
+++ b/x11-plugins/wmlaptop/wmlaptop-1.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlaptop/wmlaptop-1.3.ebuild,v 1.8 2010/09/09 09:54:32 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlaptop/wmlaptop-1.3.ebuild,v 1.9 2011/05/26 14:52:47 s4t4n Exp $
inherit eutils
@@ -28,7 +28,8 @@ src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${P}-Makefile.patch
+ epatch "${FILESDIR}"/${PN}-Makefile.patch
+ epatch "${FILESDIR}"/${PN}-ACPI-detection.patch
}
src_compile() {
diff --git a/x11-plugins/wmlaptop/wmlaptop-1.4.ebuild b/x11-plugins/wmlaptop/wmlaptop-1.4.ebuild
new file mode 100644
index 000000000000..5e080ee8525c
--- /dev/null
+++ b/x11-plugins/wmlaptop/wmlaptop-1.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlaptop/wmlaptop-1.4.ebuild,v 1.1 2011/05/26 14:52:47 s4t4n Exp $
+
+inherit eutils
+
+IUSE=""
+
+MY_P="${P}"
+S="${WORKDIR}/${MY_P}/src"
+
+DESCRIPTION="Dockapp for laptop users"
+SRC_URI="http://www.dockapps.org/download.php/id/509/${P}.tar.gz"
+HOMEPAGE="http://www.dockapps.org/file.php/id/227"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ >=sys-apps/sed-4.1.5-r1"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-Makefile.patch
+ epatch "${FILESDIR}"/${PN}-ACPI-detection.patch
+}
+
+src_compile() {
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ dodir /usr/bin
+ einstall INSTALLDIR="${D}/usr/bin" || die "Installation failed"
+
+ dodoc ../AUTHORS ../README ../README.IT ../THANKS
+
+ insinto /usr/share/applications
+ doins "${FILESDIR}/${PN}.desktop"
+}