summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-08-31 14:41:51 +0000
committerPacho Ramos <pacho@gentoo.org>2013-08-31 14:41:51 +0000
commit58b22a6ea72d2130cb10aa2fea5ea7f648aa1a8d (patch)
treefac3a8fdf27c510ab861e9073d6224b91f26db62 /x11-plugins
parentmask custom-cflags for media-libs/libsdl2 since it's unsupported (diff)
downloadgentoo-2-58b22a6ea72d2130cb10aa2fea5ea7f648aa1a8d.tar.gz
gentoo-2-58b22a6ea72d2130cb10aa2fea5ea7f648aa1a8d.tar.bz2
gentoo-2-58b22a6ea72d2130cb10aa2fea5ea7f648aa1a8d.zip
Fix LDFLAGS/gcc usage (#338903), deps (#421703) and gcc-4.7 building (#426454). By Michael Mair-Keimberger (iamnr3).
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/gkrellkam/ChangeLog7
-rw-r--r--x11-plugins/gkrellkam/files/gkrellkam-2.0.0-makefile.patch25
-rw-r--r--x11-plugins/gkrellkam/gkrellkam-2.0.0.ebuild22
3 files changed, 48 insertions, 6 deletions
diff --git a/x11-plugins/gkrellkam/ChangeLog b/x11-plugins/gkrellkam/ChangeLog
index f9a1d5516f44..5972271e53df 100644
--- a/x11-plugins/gkrellkam/ChangeLog
+++ b/x11-plugins/gkrellkam/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/gkrellkam
# Copyright 2002-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellkam/ChangeLog,v 1.16 2013/06/01 11:30:48 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellkam/ChangeLog,v 1.17 2013/08/31 14:41:51 pacho Exp $
+
+ 31 Aug 2013; Pacho Ramos <pacho@gentoo.org>
+ +files/gkrellkam-2.0.0-makefile.patch, gkrellkam-2.0.0.ebuild:
+ Fix LDFLAGS/gcc usage (#338903), deps (#421703) and gcc-4.7 building
+ (#426454). By Michael Mair-Keimberger (iamnr3).
01 Jun 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due bug #144305
diff --git a/x11-plugins/gkrellkam/files/gkrellkam-2.0.0-makefile.patch b/x11-plugins/gkrellkam/files/gkrellkam-2.0.0-makefile.patch
new file mode 100644
index 000000000000..83178b4b0ff8
--- /dev/null
+++ b/x11-plugins/gkrellkam/files/gkrellkam-2.0.0-makefile.patch
@@ -0,0 +1,25 @@
+--- Makefile 2002-10-23 18:36:20.000000000 +0200
++++ Makefile_new 2013-03-16 14:02:42.979029588 +0100
+@@ -12,10 +12,10 @@
+ # This should point to the GKrellM headers
+ GKRELLM_HDRS = /usr/include
+
+-CC := gcc
++CC = $(CC)
+ GTKFLAGS := $(shell pkg-config gtk+-2.0 --cflags)
+-CFLAGS := $(CFLAGS) -fPIC -Wall $(GTKFLAGS) -I$(GKRELLM_HDRS)
+-LDFLAGS := -shared -Wl
++CFLAGS := $(CFLAGS) -fPIC $(GTKFLAGS) -I$(GKRELLM_HDRS)
++LFLAGS = -shared
+ INST_DIR := $(DESTDIR)/usr/lib/gkrellm2/plugins
+ USER_INST_DIR := $(DESTDIR)$(HOME)/.gkrellm2/plugins
+ MANPAGES := gkrellkam-list.5
+@@ -26,7 +26,7 @@
+ all: $(TARGET).so
+
+ %.so: %.o
+- $(CC) $(LDFLAGS) -o $@ $<
++ $(CC) $(CFLAGS) $(LDFLAGS) $(LFLAGS) -o $@ $<
+
+ clean:
+ -rm -f $(TARGET).so $(TARGET).o
diff --git a/x11-plugins/gkrellkam/gkrellkam-2.0.0.ebuild b/x11-plugins/gkrellkam/gkrellkam-2.0.0.ebuild
index 4207cf571196..62ae5cbb6cc2 100644
--- a/x11-plugins/gkrellkam/gkrellkam-2.0.0.ebuild
+++ b/x11-plugins/gkrellkam/gkrellkam-2.0.0.ebuild
@@ -1,23 +1,35 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellkam/gkrellkam-2.0.0.ebuild,v 1.13 2007/03/09 16:01:53 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellkam/gkrellkam-2.0.0.ebuild,v 1.14 2013/08/31 14:41:51 pacho Exp $
-inherit gkrellm-plugin
+EAPI="5"
+inherit eutils gkrellm-plugin toolchain-funcs
MY_P=${P/-/_}
-IUSE=""
+
DESCRIPTION="an Image-Watcher-Plugin for GKrellM2."
SRC_URI="mirror://sourceforge/gkrellkam/${MY_P}.tar.gz"
HOMEPAGE="http://gkrellkam.sourceforge.net"
LICENSE="GPL-2"
SLOT="0"
+IUSE=""
KEYWORDS="x86 ppc sparc alpha amd64"
-RDEPEND="net-misc/wget"
+RDEPEND="net-misc/wget
+ app-admin/gkrellm[X]"
+DEPEND="${RDEPEND}"
PLUGIN_SO=gkrellkam2.so
PLUGIN_DOCS="example.list"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
+}
+
src_install () {
gkrellm-plugin_src_install
doman gkrellkam-list.5