summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-07-25 19:47:19 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-07-25 19:47:19 +0000
commit40933e50a2cd2462f324fa1caad5fc903eebdfe6 (patch)
tree72d5d922a865425ff2021b486f655f39fde1251c /x11-plugins
parentAdd patch to fix compilation with gcc-4.4; bug #276510 (diff)
downloadgentoo-2-40933e50a2cd2462f324fa1caad5fc903eebdfe6.tar.gz
gentoo-2-40933e50a2cd2462f324fa1caad5fc903eebdfe6.tar.bz2
gentoo-2-40933e50a2cd2462f324fa1caad5fc903eebdfe6.zip
Fix building with GCC 4.4 wrt #274000.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmmsens/ChangeLog8
-rw-r--r--x11-plugins/wmmsens/files/wmmsens-0.29.8-gcc44.patch11
-rw-r--r--x11-plugins/wmmsens/wmmsens-0.29.8.ebuild9
3 files changed, 22 insertions, 6 deletions
diff --git a/x11-plugins/wmmsens/ChangeLog b/x11-plugins/wmmsens/ChangeLog
index 0481f8d18476..fb6d62c2dab1 100644
--- a/x11-plugins/wmmsens/ChangeLog
+++ b/x11-plugins/wmmsens/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/wmmsens
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmsens/ChangeLog,v 1.12 2008/06/28 07:11:39 maekke Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmsens/ChangeLog,v 1.13 2009/07/25 19:47:15 ssuominen Exp $
+
+ 25 Jul 2009; Samuli Suominen <ssuominen@gentoo.org> wmmsens-0.29.8.ebuild,
+ +files/wmmsens-0.29.8-gcc44.patch:
+ Fix building with GCC 4.4 wrt #274000.
28 Jun 2008; Markus Meier <maekke@gentoo.org> wmmsens-0.29.8.ebuild:
x86 stable, bug #229587
diff --git a/x11-plugins/wmmsens/files/wmmsens-0.29.8-gcc44.patch b/x11-plugins/wmmsens/files/wmmsens-0.29.8-gcc44.patch
new file mode 100644
index 000000000000..90fc4b18690d
--- /dev/null
+++ b/x11-plugins/wmmsens/files/wmmsens-0.29.8-gcc44.patch
@@ -0,0 +1,11 @@
+diff -ur wmmsens-0.29.8.orig/src/main.c wmmsens-0.29.8/src/main.c
+--- wmmsens-0.29.8.orig/src/main.c 2005-07-05 01:18:21.000000000 +0300
++++ wmmsens-0.29.8/src/main.c 2009-07-25 22:45:56.000000000 +0300
+@@ -119,6 +119,7 @@
+ //
+ //
+
++#include <cstdlib>
+ #include <iostream>
+ #include <iomanip>
+ #include <fstream>
diff --git a/x11-plugins/wmmsens/wmmsens-0.29.8.ebuild b/x11-plugins/wmmsens/wmmsens-0.29.8.ebuild
index 59c0ac50c451..87d3c5d1bbe6 100644
--- a/x11-plugins/wmmsens/wmmsens-0.29.8.ebuild
+++ b/x11-plugins/wmmsens/wmmsens-0.29.8.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmsens/wmmsens-0.29.8.ebuild,v 1.2 2008/06/28 07:11:39 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmsens/wmmsens-0.29.8.ebuild,v 1.3 2009/07/25 19:47:15 ssuominen Exp $
-inherit toolchain-funcs
+inherit eutils toolchain-funcs
DESCRIPTION="a dockapp for monitoring hardware sensors (sys-apps/lm_sensors)"
HOMEPAGE="http://www.digressed.net/wmmsens"
@@ -10,7 +10,7 @@ SRC_URI="http://www.digressed.net/${PN}/src/${P}.tar.gz"
LICENSE="Artistic"
SLOT="0"
-KEYWORDS="~amd64 x86"
+KEYWORDS="amd64 x86"
IUSE=""
RDEPEND="sys-apps/lm_sensors
@@ -24,6 +24,7 @@ S=${WORKDIR}/${P}/src
src_unpack() {
unpack ${A}
+ epatch "${FILESDIR}"/${P}-gcc44.patch
sed -e 's:$(OBJS) $(LDFLAGS):$(LDFLAGS) $(OBJS) $(LIBS):g' \
-e 's:LDFLAGS = -L/usr/X11R6/lib:LIBS =:' -e '/DELETE/q' \
-i "${S}"/Makefile