summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2009-01-16 16:21:11 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2009-01-16 16:21:11 +0000
commit3b5f176444bd70615e2878c457f8fc764957382c (patch)
treec1e3200cf12acd8c88193bee57689fa26c499d32 /x11-plugins
parentStable for HPPA (bug #252991). (diff)
downloadgentoo-2-3b5f176444bd70615e2878c457f8fc764957382c.tar.gz
gentoo-2-3b5f176444bd70615e2878c457f8fc764957382c.tar.bz2
gentoo-2-3b5f176444bd70615e2878c457f8fc764957382c.zip
Fixed compilation with --as-needed. Closes bug #248642.
Prevent automatic stripping of binaries. Some ebuild QA fixing. (Portage version: 2.1.6.4/cvs/Linux 2.6.24-tuxonice-r9 i686)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmlpq/ChangeLog8
-rw-r--r--x11-plugins/wmlpq/files/wmlpq-makefile.patch12
-rw-r--r--x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild12
3 files changed, 21 insertions, 11 deletions
diff --git a/x11-plugins/wmlpq/ChangeLog b/x11-plugins/wmlpq/ChangeLog
index f234a1156fb3..f17d64e5e22c 100644
--- a/x11-plugins/wmlpq/ChangeLog
+++ b/x11-plugins/wmlpq/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/wmlpq
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlpq/ChangeLog,v 1.7 2007/02/06 02:02:54 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlpq/ChangeLog,v 1.8 2009/01/16 16:21:10 s4t4n Exp $
+
+ 16 Jan 2009; Michele Noberasco <s4t4n@gentoo.org> wmlpq-0.2.1-r1.ebuild,
+ files/wmlpq-makefile.patch:
+ Fixed compilation with --as-needed. Closes bug #248642.
+ Prevent automatic stripping of binaries.
+ Some ebuild QA fixing.
06 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/x11-plugins/wmlpq/files/wmlpq-makefile.patch b/x11-plugins/wmlpq/files/wmlpq-makefile.patch
index 953d18ff4798..4dc00bd97cdb 100644
--- a/x11-plugins/wmlpq/files/wmlpq-makefile.patch
+++ b/x11-plugins/wmlpq/files/wmlpq-makefile.patch
@@ -1,6 +1,6 @@
---- Makefile.orig 2001-03-27 22:19:12.000000000 +0000
-+++ Makefile 2004-06-20 18:52:17.513090584 +0000
-@@ -2,8 +2,9 @@
+--- /Makefile.orig 2009-01-16 17:01:47.000000000 +0100
++++ /Makefile 2009-01-16 17:04:18.000000000 +0100
+@@ -2,11 +2,11 @@
CPPFLAGS = -I/usr/X11R6/include -I/usr/local/include
LIBS = -lXpm -lX11 -ldockapp
LDFLAGS = -L/usr/X11R6/lib -L/usr/local/lib
@@ -10,7 +10,11 @@
+DESTDIR = /usr/bin/
wmlpq: wmlpq.c wmlpq-master.xpm
- cc $(CFLAGS) $(LDFLAGS) $(CPPFLAGS) -o wmlpq $(LIBS) wmlpq.c
+- cc $(CFLAGS) $(LDFLAGS) $(CPPFLAGS) -o wmlpq $(LIBS) wmlpq.c
++ cc $(CFLAGS) $(LDFLAGS) $(CPPFLAGS) wmlpq.c -o wmlpq $(LIBS)
+- strip wmlpq
+
+ debug: wmlpq.c wmlpq-master.xpm
@@ -18,10 +19,8 @@
rm -f wmlpq
diff --git a/x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild b/x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild
index bf04a0dea76b..55a676b8c5a1 100644
--- a/x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild
+++ b/x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild,v 1.2 2006/01/15 17:47:42 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild,v 1.3 2009/01/16 16:21:10 s4t4n Exp $
inherit eutils
@@ -21,18 +21,18 @@ KEYWORDS="x86 ppc"
src_unpack()
{
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PN}-makefile.patch
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-makefile.patch"
}
src_install()
{
dodir /usr/bin/
- einstall DESTDIR=${D}/usr/bin/ CFLAGS="${CFLAGS} -Wall" || die "Installation failed"
+ einstall DESTDIR="${D}/usr/bin/" CFLAGS="${CFLAGS} -Wall" || die "Installation failed"
dodoc README sample.wmlpqrc
newman wmlpq.1x wmlpq.1
insinto /usr/share/applications
- doins ${FILESDIR}/${PN}.desktop
+ doins "${FILESDIR}/${PN}.desktop"
}