summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2008-12-02 10:42:35 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2008-12-02 10:42:35 +0000
commit3819fe75e0b2f9f6710fdca88c99e284117e2385 (patch)
treee86adc11a6b2f9912481caf658b7066f4924f2c9 /x11-plugins
parent Version bump, closing bug #249351. (diff)
downloadgentoo-2-3819fe75e0b2f9f6710fdca88c99e284117e2385.tar.gz
gentoo-2-3819fe75e0b2f9f6710fdca88c99e284117e2385.tar.bz2
gentoo-2-3819fe75e0b2f9f6710fdca88c99e284117e2385.zip
Fix LDFLAGS ordering. Fixes bug #248641.
(Portage version: 2.1.4.5)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmget/ChangeLog5
-rw-r--r--x11-plugins/wmget/wmget-0.6.0.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/x11-plugins/wmget/ChangeLog b/x11-plugins/wmget/ChangeLog
index a079c138930a..40256cea115c 100644
--- a/x11-plugins/wmget/ChangeLog
+++ b/x11-plugins/wmget/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-plugins/wmget
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmget/ChangeLog,v 1.15 2008/01/16 01:17:43 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmget/ChangeLog,v 1.16 2008/12/02 10:42:35 s4t4n Exp $
+
+ 02 Dec 2008; Michele Noberasco <s4t4n@gentoo.org> wmget-0.6.0.ebuild:
+ Fix LDFLAGS ordering. Fixes bug #248641.
16 Jan 2008; Samuli Suominen <drac@gentoo.org> wmget-0.6.0.ebuild:
Use correct AR and CC targets and remove X11R6 references from ebuild.
diff --git a/x11-plugins/wmget/wmget-0.6.0.ebuild b/x11-plugins/wmget/wmget-0.6.0.ebuild
index f1ec9e9fb328..53fc3d6c5d64 100644
--- a/x11-plugins/wmget/wmget-0.6.0.ebuild
+++ b/x11-plugins/wmget/wmget-0.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmget/wmget-0.6.0.ebuild,v 1.8 2008/01/16 01:17:43 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmget/wmget-0.6.0.ebuild,v 1.9 2008/12/02 10:42:35 s4t4n Exp $
inherit toolchain-funcs
@@ -26,6 +26,9 @@ S=${WORKDIR}/${PN}
src_unpack() {
unpack ${A}
sed -i -e "s:ar rc:$(tc-getAR) rc:" "${S}"/dockapp/Makefile
+
+ #Fix LDFLAGS ordering for bug #248641
+ sed -i 's/$(CC) $(CFLAGS) $(LDFLAGS) $(OBJS) $(DALIB) -o $@/$(CC) $(CFLAGS) $(OBJS) $(DALIB) -o $@ $(LDFLAGS)/' "${S}"/Makefile
}
src_compile() {