summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2012-06-26 21:47:46 +0000
committerIan Whyman <thev00d00@gentoo.org>2012-06-26 21:47:46 +0000
commit28ffdc72cdc53e50c195f49b2137742b292f733f (patch)
treeb05eb44acd2a194903279a0eeec014e67434b160 /x11-plugins
parentVersion bump, bug 422671 (diff)
downloadgentoo-2-28ffdc72cdc53e50c195f49b2137742b292f733f.tar.gz
gentoo-2-28ffdc72cdc53e50c195f49b2137742b292f733f.tar.bz2
gentoo-2-28ffdc72cdc53e50c195f49b2137742b292f733f.zip
Version bump, patch to remove possible sandbox violation
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/pidgin-sipe/ChangeLog8
-rw-r--r--x11-plugins/pidgin-sipe/files/pidgin-sipe-1.13.2-fix-sandbox.patch40
-rw-r--r--x11-plugins/pidgin-sipe/metadata.xml1
-rw-r--r--x11-plugins/pidgin-sipe/pidgin-sipe-1.13.2.ebuild58
4 files changed, 106 insertions, 1 deletions
diff --git a/x11-plugins/pidgin-sipe/ChangeLog b/x11-plugins/pidgin-sipe/ChangeLog
index e5ec18197d47..1630c3a41dc5 100644
--- a/x11-plugins/pidgin-sipe/ChangeLog
+++ b/x11-plugins/pidgin-sipe/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/pidgin-sipe
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-sipe/ChangeLog,v 1.13 2012/06/26 19:53:26 thev00d00 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-sipe/ChangeLog,v 1.14 2012/06/26 21:47:46 thev00d00 Exp $
+
+*pidgin-sipe-1.13.2 (26 Jun 2012)
+
+ 26 Jun 2012; Ian Whyman <thev00d00@gentoo.org> +pidgin-sipe-1.13.2.ebuild,
+ +files/pidgin-sipe-1.13.2-fix-sandbox.patch, metadata.xml:
+ Version bump, patch to remove possible sandbox violation
26 Jun 2012; Ian Whyman <thev00d00@gentoo.org> -pidgin-sipe-1.12.0.ebuild,
-pidgin-sipe-1.13.0.ebuild, pidgin-sipe-1.13.1.ebuild:
diff --git a/x11-plugins/pidgin-sipe/files/pidgin-sipe-1.13.2-fix-sandbox.patch b/x11-plugins/pidgin-sipe/files/pidgin-sipe-1.13.2-fix-sandbox.patch
new file mode 100644
index 000000000000..cb30c63c375b
--- /dev/null
+++ b/x11-plugins/pidgin-sipe/files/pidgin-sipe-1.13.2-fix-sandbox.patch
@@ -0,0 +1,40 @@
+# Fix possible sandbox violation when snippet tries to probe for plugins
+# Gentoo Bug 409559
+
+--- pidgin-sipe-1.13.2.orig/configure.ac 2012-03-14 21:53:10.000000000 +0000
++++ pidgin-sipe-1.13.2/configure.ac 2012-06-26 22:13:48.710870016 +0100
+@@ -300,34 +300,6 @@
+ ])
+ ])
+
+- dnl on windows
+- dnl test program needs to be in the same location as libpurple
+- dnl installation for latter to load ssl plugin referenced by
+- dnl RELATIVE path.
+- AS_IF([test "x${os_win32}" != xyes],
+- [dnl purple SSL support is mandatory
+- AC_MSG_CHECKING([for purple SSL support])
+- ac_save_LIBS=$LIBS
+- LIBS="$PURPLE_LIBS"
+- AC_RUN_IFELSE(
+- [AC_LANG_PROGRAM([[
+-#include <glib.h>
+-#include <plugin.h>
+-#include <sslconn.h>
+- ]],
+- [[
+- purple_plugins_init();
+- purple_plugins_probe(G_MODULE_SUFFIX);
+- purple_ssl_init();
+- return(purple_ssl_is_supported()?0:1);
+- ]])],
+- [AC_MSG_RESULT(ok)],
+- [AC_MSG_FAILURE([your purple hasn't been compiled with SSL support.
+-])
+- ],
+- [AC_MSG_WARN([cross compiling: not checking])])
+- ])
+-
+ dnl check whether enable voice and video support
+ AS_IF([test "x$with_vv" = xno], [], dnl disabled by user
+ [test "x$with_vv" = xcheck], dnl autodetect
diff --git a/x11-plugins/pidgin-sipe/metadata.xml b/x11-plugins/pidgin-sipe/metadata.xml
index a9088628a7d8..fc1ef104e511 100644
--- a/x11-plugins/pidgin-sipe/metadata.xml
+++ b/x11-plugins/pidgin-sipe/metadata.xml
@@ -11,5 +11,6 @@ An Open Implementation of SIP/Simple protocol for Live Communications Server 200
</longdescription>
<use>
<flag name="voice">Enable experimental voice/video support</flag>
+ <flag name="ocs2005-message-hack">disable message timeout for OCS2005 clients which causes "false" not delivered error messages</flag>
</use>
</pkgmetadata>
diff --git a/x11-plugins/pidgin-sipe/pidgin-sipe-1.13.2.ebuild b/x11-plugins/pidgin-sipe/pidgin-sipe-1.13.2.ebuild
new file mode 100644
index 000000000000..1b9fffc22b0d
--- /dev/null
+++ b/x11-plugins/pidgin-sipe/pidgin-sipe-1.13.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-sipe/pidgin-sipe-1.13.2.ebuild,v 1.1 2012/06/26 21:47:46 thev00d00 Exp $
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="Pidgin Plug-in SIPE (Sip Exchange Protocol)"
+HOMEPAGE="http://sipe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sipe/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug kerberos ocs2005-message-hack voice"
+
+RDEPEND="net-im/pidgin[gnutls]
+ >=dev-libs/gmime-2.4.16
+ dev-libs/libxml2
+ kerberos? ( app-crypt/mit-krb5 )
+ voice? (
+ >=dev-libs/glib-2.28.0
+ >=net-libs/libnice-0.1.0
+ media-libs/gstreamer
+ >=net-im/pidgin-2.8.0[gnutls]
+ )
+ !voice? (
+ >=dev-libs/glib-2.12.0
+ net-im/pidgin[gnutls]
+ )
+"
+
+DEPEND="dev-util/intltool
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-fix-sandbox.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-purple \
+ --disable-quality-check \
+ --disable-telepathy \
+ $(use_enable debug) \
+ $(use_enable ocs2005-message-hack) \
+ $(use_with kerberos krb5) \
+ $(use_with voice vv)
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog NEWS TODO README
+}