summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2009-07-19 20:12:13 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2009-07-19 20:12:13 +0000
commit1a90ea6c276fbb9e1aaaf2980a52b0c1f8bfe0e8 (patch)
treec11293ee8217d1e9bf0600d49bd9bab6b9f4fb5c /x11-plugins
parentVersion bump. Translation updates. Added a video sink to RDEPEND, bug #277480. (diff)
downloadgentoo-2-1a90ea6c276fbb9e1aaaf2980a52b0c1f8bfe0e8.tar.gz
gentoo-2-1a90ea6c276fbb9e1aaaf2980a52b0c1f8bfe0e8.tar.bz2
gentoo-2-1a90ea6c276fbb9e1aaaf2980a52b0c1f8bfe0e8.zip
Version bump, timeout issues fixed, offline messages sending support (and better receiving support), crash fixes, performance improvements and code reorganization
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/msn-pecan/ChangeLog10
-rw-r--r--x11-plugins/msn-pecan/msn-pecan-0.1.0_rc1.ebuild39
2 files changed, 48 insertions, 1 deletions
diff --git a/x11-plugins/msn-pecan/ChangeLog b/x11-plugins/msn-pecan/ChangeLog
index 16ac45d21ecb..21d68397c5ee 100644
--- a/x11-plugins/msn-pecan/ChangeLog
+++ b/x11-plugins/msn-pecan/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-plugins/msn-pecan
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/msn-pecan/ChangeLog,v 1.1 2009/07/19 19:54:21 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/msn-pecan/ChangeLog,v 1.2 2009/07/19 20:12:13 voyageur Exp $
+
+*msn-pecan-0.1.0_rc1 (19 Jul 2009)
+
+ 19 Jul 2009; Bernard Cafarelli <voyageur@gentoo.org>
+ +msn-pecan-0.1.0_rc1.ebuild:
+ Version bump, timeout issues fixed, offline messages sending support (and
+ better receiving support), crash fixes, performance improvements and code
+ reorganization
*msn-pecan-0.0.19 (19 Jul 2009)
diff --git a/x11-plugins/msn-pecan/msn-pecan-0.1.0_rc1.ebuild b/x11-plugins/msn-pecan/msn-pecan-0.1.0_rc1.ebuild
new file mode 100644
index 000000000000..79a007c5afd0
--- /dev/null
+++ b/x11-plugins/msn-pecan/msn-pecan-0.1.0_rc1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/msn-pecan/msn-pecan-0.1.0_rc1.ebuild,v 1.1 2009/07/19 20:12:13 voyageur Exp $
+
+inherit toolchain-funcs multilib
+
+DESCRIPTION="Alternative MSN protocol plugin for libpurple"
+HOMEPAGE="http://code.google.com/p/msn-pecan/"
+
+SRC_URI="http://msn-pecan.googlecode.com/files/${P/_/-}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-im/pidgin"
+DEPEND="dev-util/pkgconfig
+ ${RDEPEND}"
+
+S=${WORKDIR}/${P/_/-}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog README TODO || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "Select the 'WLM' protocol to use this plugin"
+ einfo
+ elog "For more information (how to change personal message, add"
+ elog "missing emoticons, ...), please read:"
+ elog "http://code.google.com/p/msn-pecan/wiki/FAQ"
+}