summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-10-27 20:26:12 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-10-27 20:26:12 +0000
commit125e5f160b85d615939cd54f4826c0610f740d21 (patch)
treea9b3a10f9a79db3f93a299838a0e33705dba8424 /x11-plugins
parentAdd missing dependencies, bug 519974 (diff)
downloadgentoo-2-125e5f160b85d615939cd54f4826c0610f740d21.tar.gz
gentoo-2-125e5f160b85d615939cd54f4826c0610f740d21.tar.bz2
gentoo-2-125e5f160b85d615939cd54f4826c0610f740d21.zip
version bump
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/hexchat-javascript/ChangeLog8
-rw-r--r--x11-plugins/hexchat-javascript/hexchat-javascript-0.3.2.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/x11-plugins/hexchat-javascript/ChangeLog b/x11-plugins/hexchat-javascript/ChangeLog
index 75f2abe3433a..844fc38239e4 100644
--- a/x11-plugins/hexchat-javascript/ChangeLog
+++ b/x11-plugins/hexchat-javascript/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/hexchat-javascript
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/hexchat-javascript/ChangeLog,v 1.7 2014/03/12 05:21:57 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/hexchat-javascript/ChangeLog,v 1.8 2014/10/27 20:26:12 hasufell Exp $
+
+*hexchat-javascript-0.3.2 (27 Oct 2014)
+
+ 27 Oct 2014; Julian Ospald <hasufell@gentoo.org>
+ +hexchat-javascript-0.3.2.ebuild:
+ version bump
09 Mar 2014; Pawel Hajdan jr <phajdan.jr@gentoo.org>
hexchat-javascript-0.3.1.ebuild:
diff --git a/x11-plugins/hexchat-javascript/hexchat-javascript-0.3.2.ebuild b/x11-plugins/hexchat-javascript/hexchat-javascript-0.3.2.ebuild
new file mode 100644
index 000000000000..964c67b733a3
--- /dev/null
+++ b/x11-plugins/hexchat-javascript/hexchat-javascript-0.3.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/hexchat-javascript/hexchat-javascript-0.3.2.ebuild,v 1.1 2014/10/27 20:26:12 hasufell Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Javascript interface for HexChat"
+HOMEPAGE="https://github.com/TingPing/hexchat-javascript"
+SRC_URI="https://github.com/TingPing/hexchat-javascript/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ dev-lang/spidermonkey:0
+ >=net-irc/hexchat-2.9.6[plugins]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ tc-export CXX PKG_CONFIG
+ fi
+}
+
+src_install() {
+ dodir /usr/share/appdata
+ default
+ if use examples ; then
+ dodoc -r examples
+ fi
+}