summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2008-10-27 15:29:25 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2008-10-27 15:29:25 +0000
commit0de30e52beaf9c4214e6432c5fa114f7a7e18fb9 (patch)
tree8c6a1116052d4d3eb87cddc80de35b97fb7dc0c2 /x11-plugins
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-0de30e52beaf9c4214e6432c5fa114f7a7e18fb9.tar.gz
gentoo-2-0de30e52beaf9c4214e6432c5fa114f7a7e18fb9.tar.bz2
gentoo-2-0de30e52beaf9c4214e6432c5fa114f7a7e18fb9.zip
Version bump, removes some crashes and saves some bandwidth
(Portage version: 2.2_rc12/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/pidgin-facebookchat/ChangeLog8
-rw-r--r--x11-plugins/pidgin-facebookchat/pidgin-facebookchat-1.38.ebuild38
2 files changed, 45 insertions, 1 deletions
diff --git a/x11-plugins/pidgin-facebookchat/ChangeLog b/x11-plugins/pidgin-facebookchat/ChangeLog
index 237a1541eedb..0d3f5c907f5b 100644
--- a/x11-plugins/pidgin-facebookchat/ChangeLog
+++ b/x11-plugins/pidgin-facebookchat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/pidgin-facebookchat
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-facebookchat/ChangeLog,v 1.4 2008/10/24 21:30:10 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-facebookchat/ChangeLog,v 1.5 2008/10/27 15:29:25 voyageur Exp $
+
+*pidgin-facebookchat-1.38 (27 Oct 2008)
+
+ 27 Oct 2008; Bernard Cafarelli <voyageur@gentoo.org>
+ +pidgin-facebookchat-1.38.ebuild:
+ Version bump, removes some crashes and saves some bandwidth
*pidgin-facebookchat-1.37 (05 Oct 2008)
diff --git a/x11-plugins/pidgin-facebookchat/pidgin-facebookchat-1.38.ebuild b/x11-plugins/pidgin-facebookchat/pidgin-facebookchat-1.38.ebuild
new file mode 100644
index 000000000000..080f4e5c9f4a
--- /dev/null
+++ b/x11-plugins/pidgin-facebookchat/pidgin-facebookchat-1.38.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-facebookchat/pidgin-facebookchat-1.38.ebuild,v 1.1 2008/10/27 15:29:25 voyageur Exp $
+
+inherit toolchain-funcs multilib
+
+DESCRIPTION="Facebook chat plugin for libpurple"
+HOMEPAGE="http://code.google.com/p/pidgin-facebookchat/"
+
+SRC_URI="http://pidgin-facebookchat.googlecode.com/files/${PN}-source-${PV}.tar.bz2"
+LICENSE="GPL-3"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="net-im/pidgin"
+DEPEND="dev-util/pkgconfig
+ ${RDEPEND}"
+
+S=${WORKDIR}
+
+src_compile() {
+ # Remove NO_ZLIB when it's working
+ $(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} `pkg-config --cflags purple` \
+ -DPURPLE_PLUGINS -DENABLE_NLS -DNO_ZLIB -shared -fPIC -DPIC \
+ libfacebook.c -o libfacebook.so || die "compilation failed"
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/purple-2
+ doexe libfacebook.so
+ for size in 16 22 48; do
+ insinto /usr/share/pixmaps/pidgin/protocols/${size}
+ newins facebook${size}.png facebook.png
+ done
+}