summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-07-06 12:48:40 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-07-06 12:48:40 +0000
commitf48747168d9f1576f9fe0ea01940965314937ca0 (patch)
treeb2411bc0b27109ddb92101d9df73b0648c320382 /x11-plugins/wmudmount/wmudmount-1.13.ebuild
parentPull in user.eclass for enewgroup. (diff)
downloadgentoo-2-f48747168d9f1576f9fe0ea01940965314937ca0.tar.gz
gentoo-2-f48747168d9f1576f9fe0ea01940965314937ca0.tar.bz2
gentoo-2-f48747168d9f1576f9fe0ea01940965314937ca0.zip
Version bump.
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/wmudmount/wmudmount-1.13.ebuild')
-rw-r--r--x11-plugins/wmudmount/wmudmount-1.13.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-plugins/wmudmount/wmudmount-1.13.ebuild b/x11-plugins/wmudmount/wmudmount-1.13.ebuild
new file mode 100644
index 000000000000..0c450c9e3151
--- /dev/null
+++ b/x11-plugins/wmudmount/wmudmount-1.13.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmudmount/wmudmount-1.13.ebuild,v 1.1 2012/07/06 12:48:40 ssuominen Exp $
+
+EAPI=4
+inherit eutils gnome2-utils
+
+DESCRIPTION="A filesystem mounter that uses udisks to handle notification and mounting"
+HOMEPAGE="http://sourceforge.net/projects/wmudmount/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome-keyring libnotify"
+
+COMMON_DEPEND=">=dev-libs/dbus-glib-0.98
+ >=dev-libs/glib-2.20
+ >=x11-libs/gtk+-2.18:2
+ x11-libs/libX11
+ gnome-keyring? ( gnome-base/libgnome-keyring )
+ libnotify? ( >=x11-libs/libnotify-0.7 )"
+RDEPEND="${COMMON_DEPEND}
+ sys-fs/udisks:0"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )"
+
+DOCS="ChangeLog"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-headers.patch
+}
+
+src_configure() {
+ econf \
+ $(use_with libnotify) \
+ $(use_with gnome-keyring)
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }