summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2010-08-31 14:27:34 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2010-08-31 14:27:34 +0000
commitda47f4be0629f6486dec33f921ba6ae0466be9b0 (patch)
tree963a78b1dc2248c46e3be08a97e9862befecd21e /x11-plugins/wmtimer
parentgriffon26 is retiring, reassign to maintainer-needed. (diff)
downloadgentoo-2-da47f4be0629f6486dec33f921ba6ae0466be9b0.tar.gz
gentoo-2-da47f4be0629f6486dec33f921ba6ae0466be9b0.tar.bz2
gentoo-2-da47f4be0629f6486dec33f921ba6ae0466be9b0.zip
Reworked magic SEDs to honour Gentoo LDFLAGS.
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'x11-plugins/wmtimer')
-rw-r--r--x11-plugins/wmtimer/ChangeLog8
-rw-r--r--x11-plugins/wmtimer/wmtimer-2.92-r1.ebuild9
-rw-r--r--x11-plugins/wmtimer/wmtimer-2.92.ebuild9
3 files changed, 18 insertions, 8 deletions
diff --git a/x11-plugins/wmtimer/ChangeLog b/x11-plugins/wmtimer/ChangeLog
index 0493ac7ba451..53b1aece9d85 100644
--- a/x11-plugins/wmtimer/ChangeLog
+++ b/x11-plugins/wmtimer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/wmtimer
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtimer/ChangeLog,v 1.23 2008/10/28 10:13:29 s4t4n Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtimer/ChangeLog,v 1.24 2010/08/31 14:27:34 s4t4n Exp $
+
+ 28 Oct 2008; Michele Noberasco <s4t4n@gentoo.org> wmtimer-2.9.2-r1.ebuild,
+ wmtimer-2.9.2.ebuild:
+ Reworked magic SEDs to honour Gentoo LDFLAGS.
*wmtimer-2.92-r1 (28 Oct 2008)
diff --git a/x11-plugins/wmtimer/wmtimer-2.92-r1.ebuild b/x11-plugins/wmtimer/wmtimer-2.92-r1.ebuild
index deb993bbddd8..0c2d7e19f7d9 100644
--- a/x11-plugins/wmtimer/wmtimer-2.92-r1.ebuild
+++ b/x11-plugins/wmtimer/wmtimer-2.92-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtimer/wmtimer-2.92-r1.ebuild,v 1.1 2008/10/28 10:13:29 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtimer/wmtimer-2.92-r1.ebuild,v 1.2 2010/08/31 14:27:34 s4t4n Exp $
inherit eutils multilib toolchain-funcs
@@ -25,7 +25,10 @@ S=${WORKDIR}/${P}/${PN}
src_unpack() {
unpack ${A}
cd "${S}"
- sed -e "s:-O2::" -e "s:-g:${CFLAGS}:g" -i Makefile
+ sed -e "s:\$(CFLAGS)::" -i Makefile
+ sed -e "s:-g::g" -i Makefile
+ sed -e "s:-O2:\$(CFLAGS) ${CFLAGS}:" -i Makefile
+ sed -e "s:-o wmtimer:\$(LDFLAGS) -o wmtimer:" -i Makefile
epatch "${FILESDIR}"/"${PN}"-counter-fix.patch
}
diff --git a/x11-plugins/wmtimer/wmtimer-2.92.ebuild b/x11-plugins/wmtimer/wmtimer-2.92.ebuild
index 4efb37f0515b..129fab702763 100644
--- a/x11-plugins/wmtimer/wmtimer-2.92.ebuild
+++ b/x11-plugins/wmtimer/wmtimer-2.92.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtimer/wmtimer-2.92.ebuild,v 1.2 2008/01/13 02:40:01 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtimer/wmtimer-2.92.ebuild,v 1.3 2010/08/31 14:27:34 s4t4n Exp $
inherit multilib toolchain-funcs
@@ -25,7 +25,10 @@ S=${WORKDIR}/${P}/${PN}
src_unpack() {
unpack ${A}
cd "${S}"
- sed -e "s:-O2::" -e "s:-g:${CFLAGS}:g" -i Makefile
+ sed -e "s:\$(CFLAGS)::" -i Makefile
+ sed -e "s:-g::g" -i Makefile
+ sed -e "s:-O2:\$(CFLAGS) ${CFLAGS}:" -i Makefile
+ sed -e "s:-o wmtimer:\$(LDFLAGS) -o wmtimer:" -i Makefile
}
src_compile() {