summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Nigbur <pyrania@gentoo.org>2003-11-02 12:17:43 +0000
committerMarkus Nigbur <pyrania@gentoo.org>2003-11-02 12:17:43 +0000
commit91940c96197b940386777fc35bd58d47d244fcae (patch)
treeae810f937c809bdf967492143703c12b680317ee /x11-plugins/wmpower
parentChanged net-analyzer/net-snmp to virtual/snmp (diff)
downloadgentoo-2-91940c96197b940386777fc35bd58d47d244fcae.tar.gz
gentoo-2-91940c96197b940386777fc35bd58d47d244fcae.tar.bz2
gentoo-2-91940c96197b940386777fc35bd58d47d244fcae.zip
cflags patch
Diffstat (limited to 'x11-plugins/wmpower')
-rw-r--r--x11-plugins/wmpower/ChangeLog6
-rw-r--r--x11-plugins/wmpower/files/cflags.patch71
-rw-r--r--x11-plugins/wmpower/wmpower-0.3.0.ebuild8
3 files changed, 83 insertions, 2 deletions
diff --git a/x11-plugins/wmpower/ChangeLog b/x11-plugins/wmpower/ChangeLog
index faaf590dad49..1f772a07d384 100644
--- a/x11-plugins/wmpower/ChangeLog
+++ b/x11-plugins/wmpower/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/wmpower
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmpower/ChangeLog,v 1.4 2003/10/22 21:12:04 pyrania Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmpower/ChangeLog,v 1.5 2003/11/02 12:17:43 pyrania Exp $
+
+ 01 Nov 2003; Markus Nigbur <pyrania@gentoo.org> wmpower-0.3.0.ebuild,
+ files/cflags.patch:
+ 'Fixed' cflags determination. Thanks to Brandy for the notice.
*wmpower-0.3.0 (22 Oct 2003)
diff --git a/x11-plugins/wmpower/files/cflags.patch b/x11-plugins/wmpower/files/cflags.patch
new file mode 100644
index 000000000000..10ac6c4f06ea
--- /dev/null
+++ b/x11-plugins/wmpower/files/cflags.patch
@@ -0,0 +1,71 @@
+diff -Naur wmpower-0.3.0_/configure.in wmpower-0.3.0/configure.in
+--- configure.in 2003-11-01 20:55:31.455096920 +0100
++++ /configure.in 2003-11-01 20:56:08.514463040 +0100
+@@ -8,66 +8,7 @@
+ AC_PROG_CC
+ AC_PROG_RANLIB
+
+-# Set my own flags for gcc
+-if test "x$GCC" = "xyes"; then
+- CPULAGS=""
+- CFLAGS="-O3 -fomit-frame-pointer -pipe -W -Wall"
+- GCC_TEST_MESSAGE="Checking for gcc version"
+- AC_MSG_CHECKING([$GCC_TEST_MESSAGE])
+- GCCVERSION="`$CC -dumpversion`"
+- AC_MSG_RESULT([$GCCVERSION])
+- if test "`$CC -dumpversion | grep 3.`" != ""; then
+- #Good! let see if we can see the system arch
+- PROCESSOR=`cat /proc/cpuinfo`
+- #Is our CPU a Celeron?
+- if test "`echo $PROCESSOR | grep \"Celeron\"`" != ""; then
+- CPUFLAGS="-march=pentium2"
+- fi
+- if test "`echo $PROCESSOR | grep \"Celeron (Coppermine)\"`" != ""; then
+- CPUFLAGS="-march=pentium3"
+- fi
+- #Is our CPU a Pentium?
+- if test "`echo $PROCESSOR | grep \"Pentium\"`" != ""; then
+- CPUFLAGS="-march=pentium"
+- fi
+- #Is our CPU a Pentium II?
+- if test "`echo $PROCESSOR | grep \"Pentium II\"`" != ""; then
+- CPUFLAGS="-march=pentium2"
+- fi
+- #Is our CPU a Pentium III?
+- if test "`echo $PROCESSOR | grep \"Pentium III\"`" != ""; then
+- CPUFLAGS="-march=pentium3"
+- fi
+- #Is our CPU a Pentium 4?
+- if test "`echo $PROCESSOR | grep \"Intel(R) Pentium(R) 4\"`" != ""; then
+- CPUFLAGS="-march=pentium4"
+- fi
+- #Athlon processors
+- if test "`echo $PROCESSOR | grep \"AMD Athlon(tm)\"`" != ""; then
+- CPUFLAGS="-march=athlon"
+- fi
+- if test "`echo $PROCESSOR | grep \"AMD Athlon(tm) MP\"`" != ""; then
+- CPUFLAGS="-march=athlon-mp"
+- fi
+- if test "`echo $PROCESSOR | grep \"AMD Athlon(tm) XP\"`" != ""; then
+- CPUFLAGS="-march=athlon-xp"
+- fi
+- #Is our CPU an Ultra Sparc?
+- if test "`echo $PROCESSOR | grep \"UltraSparc\"`" != ""; then
+- CPUFLAGS="-mcpu=ultrasparc"
+- fi
+- else
+- #Alas, we can set only generic arch optimizations
+- PROCESSOR=`uname -m | grep 86`
+- if test "$PROCESSOR" != ""; then
+- CPUFLAGS="-march=$PROCESSOR"
+- fi
+- fi
+- if test "$CPUFLAGS" != ""; then
+- echo "Applying architecture optimizations: "$CPUFLAGS
+- fi
+- CFLAGS="$CPUFLAGS $CFLAGS"
+-fi
++CFLAGS=${CFLAGS}
+
+ # Check for C headers
+ HEADERS="stdio.h stdlib.h stdarg.h string.h time.h unistd.h ctype.h pwd.h sys/types.h \
diff --git a/x11-plugins/wmpower/wmpower-0.3.0.ebuild b/x11-plugins/wmpower/wmpower-0.3.0.ebuild
index de35a388f0e4..ca7309da402a 100644
--- a/x11-plugins/wmpower/wmpower-0.3.0.ebuild
+++ b/x11-plugins/wmpower/wmpower-0.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmpower/wmpower-0.3.0.ebuild,v 1.1 2003/10/22 15:38:03 pyrania Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmpower/wmpower-0.3.0.ebuild,v 1.2 2003/11/02 12:17:43 pyrania Exp $
IUSE=""
@@ -14,6 +14,12 @@ KEYWORDS="x86 amd64"
DEPEND="virtual/x11"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/cflags.patch
+}
+
src_install() {
dodir /usr/bin
make prefix=${D}/usr install || die