summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2004-07-17 14:51:16 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2004-07-17 14:51:16 +0000
commit510fa726154c18661e746a611152833a0e31e3b2 (patch)
tree1bc0a9a565d3f6c93fd415097fb5fffcd2d85bd1 /x11-plugins/wmmp3/wmmp3-0.12.ebuild
parentMarked stable on x86. (Manifest recommit) (diff)
downloadgentoo-2-510fa726154c18661e746a611152833a0e31e3b2.tar.gz
gentoo-2-510fa726154c18661e746a611152833a0e31e3b2.tar.bz2
gentoo-2-510fa726154c18661e746a611152833a0e31e3b2.zip
Initial import of x11-plugins/wmmp3, version 0.12. Closes #19009
Diffstat (limited to 'x11-plugins/wmmp3/wmmp3-0.12.ebuild')
-rw-r--r--x11-plugins/wmmp3/wmmp3-0.12.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-plugins/wmmp3/wmmp3-0.12.ebuild b/x11-plugins/wmmp3/wmmp3-0.12.ebuild
new file mode 100644
index 000000000000..93b933582a10
--- /dev/null
+++ b/x11-plugins/wmmp3/wmmp3-0.12.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmp3/wmmp3-0.12.ebuild,v 1.1 2004/07/17 14:51:16 s4t4n Exp $
+
+IUSE=""
+
+DESCRIPTION="Mp3 player dock app for WindowMaker; frontend to mpg123"
+HOMEPAGE="http://www.dotfiles.com/software/wmmp3/"
+SRC_URI="http://www.dotfiles.com/software/wmmp3/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/x11
+ >=media-sound/mpg123-0.59s-r3"
+
+src_compile()
+{
+ # override wmmp3 self-calculated cflags
+ econf || die "Configuration failed"
+ emake prefix="/usr/" || die "Compilation failed"
+}
+
+src_install()
+{
+ einstall || die "Installation failed"
+ dodoc AUTHORS COPYING ChangeLog sample.wmmp3 README TODO
+}
+
+pkg_postinst()
+{
+ einfo "Please copy the sample.wmmp3 to your home directory and change it to fit your needs."
+}