summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2004-07-17 02:07:08 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2004-07-17 02:07:08 +0000
commit386ab7b1f0d35bb539369c668189b3351252a3b1 (patch)
treeb1c5f3fec0d4fc884a7e79f4fba16672b23cc01e /x11-plugins/wmjsql
parentInitial import of x11-plugins/wmload, version 0.9.2. Closes #54552 (Manifest ... (diff)
downloadgentoo-2-386ab7b1f0d35bb539369c668189b3351252a3b1.tar.gz
gentoo-2-386ab7b1f0d35bb539369c668189b3351252a3b1.tar.bz2
gentoo-2-386ab7b1f0d35bb539369c668189b3351252a3b1.zip
Initial import of x11-plugins/wmjsql, version 0.5. Closes #54558.
Diffstat (limited to 'x11-plugins/wmjsql')
-rw-r--r--x11-plugins/wmjsql/ChangeLog9
-rw-r--r--x11-plugins/wmjsql/Manifest3
-rw-r--r--x11-plugins/wmjsql/files/digest-wmjsql-0.51
-rw-r--r--x11-plugins/wmjsql/files/wmjsql.desktop9
-rw-r--r--x11-plugins/wmjsql/metadata.xml5
-rw-r--r--x11-plugins/wmjsql/wmjsql-0.5.ebuild39
6 files changed, 66 insertions, 0 deletions
diff --git a/x11-plugins/wmjsql/ChangeLog b/x11-plugins/wmjsql/ChangeLog
new file mode 100644
index 000000000000..977187cefa3c
--- /dev/null
+++ b/x11-plugins/wmjsql/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for x11-plugins/wmjsql
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmjsql/ChangeLog,v 1.1 2004/07/17 02:07:08 s4t4n Exp $
+
+*wmjsql-0.5 (17 Jul 2004)
+
+ 17 Jul 2004; Michele Noberasco <s4t4n@gentoo.org> wmjsql-0.5.ebuild:
+ Initial import. Thanks to Przemyslaw Maciag. Closes #54558.
+
diff --git a/x11-plugins/wmjsql/Manifest b/x11-plugins/wmjsql/Manifest
new file mode 100644
index 000000000000..a6ae94f9e332
--- /dev/null
+++ b/x11-plugins/wmjsql/Manifest
@@ -0,0 +1,3 @@
+MD5 2e81425daa443ab7da99fabc84e99dfc wmjsql-0.5.ebuild 686
+MD5 647835ae3e284a134ea3f0e57ab45438 files/wmjsql.desktop 165
+MD5 33c679afbad883b5bb53cb9e67430b77 files/digest-wmjsql-0.5 61
diff --git a/x11-plugins/wmjsql/files/digest-wmjsql-0.5 b/x11-plugins/wmjsql/files/digest-wmjsql-0.5
new file mode 100644
index 000000000000..ce9be8714b48
--- /dev/null
+++ b/x11-plugins/wmjsql/files/digest-wmjsql-0.5
@@ -0,0 +1 @@
+MD5 63b3df4cfb5ce3a68fba89c168980995 wmjsql-0.5.tar.gz 62739
diff --git a/x11-plugins/wmjsql/files/wmjsql.desktop b/x11-plugins/wmjsql/files/wmjsql.desktop
new file mode 100644
index 000000000000..c2257e2ea428
--- /dev/null
+++ b/x11-plugins/wmjsql/files/wmjsql.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=WmJSQL
+Comment=MySQL Monitor
+Comment[pl]=Monitor MySQLa
+Exec=wmjsql
+Type=Application
+Encoding=UTF-8
+Terminal=0
+Categories=Application;Database;
diff --git a/x11-plugins/wmjsql/metadata.xml b/x11-plugins/wmjsql/metadata.xml
new file mode 100644
index 000000000000..b1a9efc4f2f0
--- /dev/null
+++ b/x11-plugins/wmjsql/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+</pkgmetadata>
diff --git a/x11-plugins/wmjsql/wmjsql-0.5.ebuild b/x11-plugins/wmjsql/wmjsql-0.5.ebuild
new file mode 100644
index 000000000000..fbc721155cad
--- /dev/null
+++ b/x11-plugins/wmjsql/wmjsql-0.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmjsql/wmjsql-0.5.ebuild,v 1.1 2004/07/17 02:07:08 s4t4n Exp $
+
+inherit eutils
+
+IUSE=""
+
+MY_P="${PN}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="MySQL monitor dockapp"
+SRC_URI="http://www.dockapps.org/download.php/id/73/${P}.tar.gz"
+HOMEPAGE="http://www.dockapps.org/file.php/id/42"
+
+DEPEND="virtual/x11
+ >=dev-db/mysql-4.0.20"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+src_compile() {
+ cd ${S}/src
+ make clean
+ emake CFLAGS="${CFLAGS}" || die "Compilation failed"
+}
+
+src_install() {
+ cd ${S}/src
+ dobin wmjsql
+ newdoc conf sample.wmjsql
+
+ cd ${S}
+ dodoc CREDITS INSTALL README TODO
+
+ insinto /usr/share/applications
+ doins ${FILESDIR}/${PN}.desktop
+}