summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2010-02-23 11:01:32 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2010-02-23 11:01:32 +0000
commitf68c9a14c9d4fc2b55d4d3b9128fe7731c6f0822 (patch)
tree003ecedad0d5a28b71429006a82bc2e4e0e32023 /x11-plugins/wmix
parentVersion bump to final 1.0, fixes bug #306253 (diff)
downloadgentoo-2-f68c9a14c9d4fc2b55d4d3b9128fe7731c6f0822.tar.gz
gentoo-2-f68c9a14c9d4fc2b55d4d3b9128fe7731c6f0822.tar.bz2
gentoo-2-f68c9a14c9d4fc2b55d4d3b9128fe7731c6f0822.zip
Revision bump, with patch for bug #301800.
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'x11-plugins/wmix')
-rw-r--r--x11-plugins/wmix/ChangeLog9
-rw-r--r--x11-plugins/wmix/files/wmix-fix-free.patch11
-rw-r--r--x11-plugins/wmix/wmix-3.1-r2.ebuild39
3 files changed, 57 insertions, 2 deletions
diff --git a/x11-plugins/wmix/ChangeLog b/x11-plugins/wmix/ChangeLog
index d193794d2a1c..eb759ae70fd7 100644
--- a/x11-plugins/wmix/ChangeLog
+++ b/x11-plugins/wmix/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/wmix
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmix/ChangeLog,v 1.19 2009/06/04 00:19:01 tcunha Exp $
+# Copyright 2002-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmix/ChangeLog,v 1.20 2010/02/23 11:01:31 s4t4n Exp $
+
+*wmix-3.1-r1 (19 Jul 2004)
+
+ 23 Feb 2010; Michele Noberasco <s4t4n@gentoo.org> wmix-3.1-r2.ebuild:
+ Revision bump, with patch for bug #301800.
04 Jun 2009; Tiago Cunha <tcunha@gentoo.org> wmix-3.1-r1.ebuild:
stable sparc, bug 215651
diff --git a/x11-plugins/wmix/files/wmix-fix-free.patch b/x11-plugins/wmix/files/wmix-fix-free.patch
new file mode 100644
index 000000000000..340f91771fa7
--- /dev/null
+++ b/x11-plugins/wmix/files/wmix-fix-free.patch
@@ -0,0 +1,11 @@
+--- wmix.c.orig 2004-05-12 21:30:53.000000000 -0300
++++ wmix.c 2009-07-08 00:20:28.000000000 -0300
+@@ -134,7 +134,7 @@
+ }
+
+ /* handle writing PID file, silently ignore if we can't do it */
+- pid = calloc(1, strlen(home) + 10);
++ pid = calloc(1, strlen(home) + 11);
+ sprintf(pid, "%s/.wmix.pid", home);
+ fp = fopen(pid, "w");
+ if (fp) {
diff --git a/x11-plugins/wmix/wmix-3.1-r2.ebuild b/x11-plugins/wmix/wmix-3.1-r2.ebuild
new file mode 100644
index 000000000000..4227b35e31e5
--- /dev/null
+++ b/x11-plugins/wmix/wmix-3.1-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmix/wmix-3.1-r2.ebuild,v 1.1 2010/02/23 11:01:31 s4t4n Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Dockapp mixer for OSS or ALSA"
+HOMEPAGE="http://www.ne.jp/asahi/linux/timecop/"
+SRC_URI="http://www.ne.jp/asahi/linux/timecop/software/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/fix-wmix-3.1-version-number.patch
+ epatch "${FILESDIR}"/wmix-fix-free.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" || die "emake failed."
+}
+
+src_install() {
+ dobin ${PN}
+ doman "${FILESDIR}"/${PN}.1
+ dodoc AUTHORS BUGS NEWS README sample.wmixrc
+}