summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-03-04 18:33:20 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-03-04 18:33:20 +0000
commitd21f08bc3c614bb48f300c45109610559492c0a3 (patch)
treebceed8ce2df1997a2f5c754c2c6a042503828c73 /x11-plugins/wmium
parentwe do gpl2, not gpl2 or later (diff)
downloadgentoo-2-d21f08bc3c614bb48f300c45109610559492c0a3.tar.gz
gentoo-2-d21f08bc3c614bb48f300c45109610559492c0a3.tar.bz2
gentoo-2-d21f08bc3c614bb48f300c45109610559492c0a3.zip
Version bump. unmask for x86 and small documentation fix
Diffstat (limited to 'x11-plugins/wmium')
-rw-r--r--x11-plugins/wmium/ChangeLog8
-rw-r--r--x11-plugins/wmium/files/digest-wmium-1.0.81
-rw-r--r--x11-plugins/wmium/wmium-1.0.7.ebuild6
-rw-r--r--x11-plugins/wmium/wmium-1.0.8.ebuild63
4 files changed, 74 insertions, 4 deletions
diff --git a/x11-plugins/wmium/ChangeLog b/x11-plugins/wmium/ChangeLog
index e9722fe85227..ea0e57d9ffbb 100644
--- a/x11-plugins/wmium/ChangeLog
+++ b/x11-plugins/wmium/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/wmium
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmium/ChangeLog,v 1.1 2004/02/07 04:27:40 port001 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmium/ChangeLog,v 1.2 2004/03/04 18:33:20 dragonheart Exp $
+
+*wmium-1.0.8 (05 Mar 2004)
+
+ 05 Mar 2004; Daniel Black <dragonheart@gentoo.org> wmium-1.0.7.ebuild,
+ wmium-1.0.8.ebuild:
+ Version bump. unmask for x86 and small documentation fix
*wmium-1.0.7 (07 Feb 2004)
diff --git a/x11-plugins/wmium/files/digest-wmium-1.0.8 b/x11-plugins/wmium/files/digest-wmium-1.0.8
new file mode 100644
index 000000000000..ed6a6419a922
--- /dev/null
+++ b/x11-plugins/wmium/files/digest-wmium-1.0.8
@@ -0,0 +1 @@
+MD5 8244849af153a62871d2d64db2a47a3b wmium-1.0.8.tar.gz 52723
diff --git a/x11-plugins/wmium/wmium-1.0.7.ebuild b/x11-plugins/wmium/wmium-1.0.7.ebuild
index c1eb50280eed..fb4373bdcb41 100644
--- a/x11-plugins/wmium/wmium-1.0.7.ebuild
+++ b/x11-plugins/wmium/wmium-1.0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmium/wmium-1.0.7.ebuild,v 1.1 2004/02/07 04:27:40 port001 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmium/wmium-1.0.7.ebuild,v 1.2 2004/03/04 18:33:20 dragonheart Exp $
DESCRIPTION="WindowMaker DockApp/Grellm2 pluggin that fetches the DSL usage information for Australian ISP Internode"
@@ -12,7 +12,7 @@ LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="x86"
IUSE="gtk"
@@ -58,6 +58,6 @@ src_install() {
einfo "To configure look at the /usr/share/doc/${PF}/dot.wmiumrc.sample"
einfo "(if using /usr/bin/wmium with WINDOWMAKER ONLY)"
einfo ""
- einfo " or use the preferences within gkrellm"
+ einfo " or use the preferences within gkrellm2"
}
diff --git a/x11-plugins/wmium/wmium-1.0.8.ebuild b/x11-plugins/wmium/wmium-1.0.8.ebuild
new file mode 100644
index 000000000000..c5c17ff36de6
--- /dev/null
+++ b/x11-plugins/wmium/wmium-1.0.8.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmium/wmium-1.0.8.ebuild,v 1.1 2004/03/04 18:33:20 dragonheart Exp $
+
+DESCRIPTION="WindowMaker DockApp/Grellm2 pluggin that fetches the DSL usage information for Australian ISP Internode"
+
+HOMEPAGE="http://www.earthmagic.org/?software"
+
+SRC_URI="http://www.earthmagic.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="x86"
+
+IUSE="gtk"
+
+DEPEND="virtual/glibc
+ x11-base/xfree
+ media-libs/xpm
+ dev-libs/openssl
+ gtk? ( >=x11-libs/gtk+-2* )
+ gtk? ( app-admin/gkrellm )
+ gtk? ( dev-util/pkgconfig )"
+
+RDEPEND="virtual/glibc
+ x11-base/xfree
+ media-libs/xpm
+ dev-libs/openssl
+ gtk? ( >=x11-libs/gtk+-2* )
+ gtk? ( app-admin/gkrellm )
+ !gtk? ( x11-wm/windowmaker )"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+
+ emake build || die "Cannot make ${P}"
+ use gtk && emake build-gk2
+}
+
+src_install() {
+
+ if [ `use gtk` ]; then
+ exeinto /usr/lib/gkrellm2/plugins
+ doexe src-gk2/wmium-gk2.so
+ fi
+
+ dobin src/wmium
+
+ dodoc BUGS INSTALL-GK2 README dot.wmiumrc.sample \
+ CHANGES INSTALL README-GK2
+
+ doman src/wmium.1
+
+ einfo ""
+ einfo "To configure look at the /usr/share/doc/${PF}/dot.wmiumrc.sample"
+ einfo "(if using /usr/bin/wmium with WINDOWMAKER ONLY)"
+ einfo ""
+ einfo " or use the preferences within gkrellm2"
+}
+