summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2006-08-04 09:33:24 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2006-08-04 09:33:24 +0000
commit860c53fbbca9fc1b92846db2e7bd2978f3db076e (patch)
tree90d98628621e358c1f5628b58642185a3a1bc58d /x11-plugins/wmhdplop
parentstable amd64 (diff)
downloadgentoo-2-860c53fbbca9fc1b92846db2e7bd2978f3db076e.tar.gz
gentoo-2-860c53fbbca9fc1b92846db2e7bd2978f3db076e.tar.bz2
gentoo-2-860c53fbbca9fc1b92846db2e7bd2978f3db076e.zip
Revision bump, with patch to fix bug #139945. The patch itself is so trivial that I'm committing it straight into stable. Wiped out older revision.
(Portage version: 2.1-r1)
Diffstat (limited to 'x11-plugins/wmhdplop')
-rw-r--r--x11-plugins/wmhdplop/ChangeLog10
-rw-r--r--x11-plugins/wmhdplop/files/digest-wmhdplop-0.9.7-r13
-rw-r--r--x11-plugins/wmhdplop/files/wmhdplop-fontpath.patch10
-rw-r--r--x11-plugins/wmhdplop/wmhdplop-0.9.7-r1.ebuild70
4 files changed, 92 insertions, 1 deletions
diff --git a/x11-plugins/wmhdplop/ChangeLog b/x11-plugins/wmhdplop/ChangeLog
index 3fe9fb6c744e..c800299fa032 100644
--- a/x11-plugins/wmhdplop/ChangeLog
+++ b/x11-plugins/wmhdplop/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-plugins/wmhdplop
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmhdplop/ChangeLog,v 1.9 2006/01/31 19:25:21 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmhdplop/ChangeLog,v 1.10 2006/08/04 09:33:24 s4t4n Exp $
+
+*wmhdplop-0.9.7-r1 (04 Aug 2005)
+
+ 04 Aug 2005; Michele Noberasco <s4t4n@gentoo.org> wmhdplop-0.9.7-r1.ebuild:
+ Revision bump, with patch to fix bug #139945. The patch is so trivial that
+ I'm committing it directly to stable.
+ wmhdplop-0.9.7.ebuild:
+ Wiped out older revision.
31 Jan 2006; Krzysiek Pawlik <nelchael@gentoo.org> wmhdplop-0.9.7.ebuild:
Fixed DEPEND for modular X.
diff --git a/x11-plugins/wmhdplop/files/digest-wmhdplop-0.9.7-r1 b/x11-plugins/wmhdplop/files/digest-wmhdplop-0.9.7-r1
new file mode 100644
index 000000000000..0493d52ba20d
--- /dev/null
+++ b/x11-plugins/wmhdplop/files/digest-wmhdplop-0.9.7-r1
@@ -0,0 +1,3 @@
+MD5 64984c0862319cce247f4aaedd1180c3 wmhdplop-0.9.7.tar.gz 221552
+RMD160 7d192f79b8f78dbb83c8dc334b9e9bbf7ed450cc wmhdplop-0.9.7.tar.gz 221552
+SHA256 47b625590a34bddabff5fa64e16f6075cfd98aab35dd7c185d6693bcc1f48eb4 wmhdplop-0.9.7.tar.gz 221552
diff --git a/x11-plugins/wmhdplop/files/wmhdplop-fontpath.patch b/x11-plugins/wmhdplop/files/wmhdplop-fontpath.patch
new file mode 100644
index 000000000000..5f0e204f9828
--- /dev/null
+++ b/x11-plugins/wmhdplop/files/wmhdplop-fontpath.patch
@@ -0,0 +1,10 @@
+--- dockapp_imlib2.c 2006-08-04 11:23:42.000000000 +0200
++++ dockapp_imlib2.c.new 2006-08-04 11:24:15.000000000 +0200
+@@ -246,6 +246,7 @@
+ /* some default font paths */
+ snprintf(fp, 512, "%s/.fonts", getenv("HOME"));
+ add_fontpath(fp,1);
++ add_fontpath("/usr/share/fonts/corefonts",1);
+ add_fontpath("/usr/share/fonts/truetype",1);
+ add_fontpath("/usr/share/fonts/ttf",1);
+ add_fontpath("/usr/X11R6/lib/X11/fonts/truetype",1);
diff --git a/x11-plugins/wmhdplop/wmhdplop-0.9.7-r1.ebuild b/x11-plugins/wmhdplop/wmhdplop-0.9.7-r1.ebuild
new file mode 100644
index 000000000000..2f6febe04921
--- /dev/null
+++ b/x11-plugins/wmhdplop/wmhdplop-0.9.7-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmhdplop/wmhdplop-0.9.7-r1.ebuild,v 1.1 2006/08/04 09:33:24 s4t4n Exp $
+
+inherit eutils
+
+IUSE="gkrellm"
+
+DESCRIPTION="A fancy hard drive activity monitor dockapp"
+HOMEPAGE="http://hules.free.fr/wmhdplop"
+SRC_URI="http://hules.free.fr/wmhdplop/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~amd64"
+
+RDEPEND="|| ( (
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXext )
+ virtual/x11 )
+ >=media-fonts/corefonts-1-r2"
+DEPEND="${RDEPEND}
+ || ( x11-proto/xextproto virtual/x11 )
+ >=media-libs/imlib2-1.2.0-r2
+ gkrellm? ( >=app-admin/gkrellm-2.1.28-r1 )"
+
+src_unpack()
+{
+ unpack ${A}
+ cd ${S}
+
+ # Honour Gentoo CFLAGS, but retain some the package author chose himself
+ epatch ${FILESDIR}/${PN}-cflags.patch
+
+ # Add corefonts to font path, see bug #139945
+ epatch ${FILESDIR}/${PN}-fontpath.patch
+
+ if ! built_with_use media-libs/imlib2 X; then
+ echo
+ eerror "This package depends on media-libs/imlib2, which needs"
+ eerror "to be compiled with 'X' USE flag enabled..."
+ echo
+ die
+ fi
+}
+
+src_compile()
+{
+ econf \
+ GENTOO_CFLAGS="${CFLAGS}" \
+ `use_enable gkrellm` \
+ || die "configure failed"
+
+ emake || die "parallel make failed"
+}
+
+src_install ()
+{
+ einstall || die "make install failed"
+
+ dodoc README AUTHORS ChangeLog
+
+ if use gkrellm; then
+ # I don't like hardcoded paths, but other
+ # gkrellm plugin ebuilds to it the same way...
+ exeinto /usr/lib/gkrellm2/plugins/
+ doexe gkhdplop.so
+ fi
+}