summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2010-09-03 13:47:55 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2010-09-03 13:47:55 +0000
commit1d222fa24d00e7ee50579368ac65b3ddc2a3521e (patch)
tree1ceb9e7fb6c1fbd59e321893107ee0c58e8b580e /x11-plugins/wmhdplop/wmhdplop-0.9.9-r2.ebuild
parentFix building with recent glibc wrt #335687 by Diego E. Pettenò. (diff)
downloadgentoo-2-1d222fa24d00e7ee50579368ac65b3ddc2a3521e.tar.gz
gentoo-2-1d222fa24d00e7ee50579368ac65b3ddc2a3521e.tar.bz2
gentoo-2-1d222fa24d00e7ee50579368ac65b3ddc2a3521e.zip
Revision bump, directly x86 stable, fixing bug with gkrellm
by forcefully disabling optional gkrellm support. Closes bug #275262. Wiped out older revisions. (Portage version: 2.1.8.3/cvs/Linux i686, RepoMan options: --force)
Diffstat (limited to 'x11-plugins/wmhdplop/wmhdplop-0.9.9-r2.ebuild')
-rw-r--r--x11-plugins/wmhdplop/wmhdplop-0.9.9-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-plugins/wmhdplop/wmhdplop-0.9.9-r2.ebuild b/x11-plugins/wmhdplop/wmhdplop-0.9.9-r2.ebuild
new file mode 100644
index 000000000000..947e485c5161
--- /dev/null
+++ b/x11-plugins/wmhdplop/wmhdplop-0.9.9-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmhdplop/wmhdplop-0.9.9-r2.ebuild,v 1.1 2010/09/03 13:47:55 s4t4n Exp $
+
+EAPI="2"
+
+inherit eutils multilib
+
+DESCRIPTION="a dockapp for monitoring disk activities with fancy visuals."
+HOMEPAGE="http://hules.free.fr/wmhdplop"
+SRC_URI="http://hules.free.fr/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="media-libs/imlib2[X]
+ x11-libs/libX11
+ x11-libs/libXext
+ media-fonts/corefonts
+ >=media-libs/freetype-2"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-64bit.patch
+ sed -i -e "s:-O3 -fomit-frame-pointer -ffast-math:${CFLAGS}:" "${S}"/configure
+}
+
+src_configure() {
+ econf --disable-gkrellm
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README || die
+}