summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Nigbur <pyrania@gentoo.org>2003-11-16 22:50:57 +0000
committerMarkus Nigbur <pyrania@gentoo.org>2003-11-16 22:50:57 +0000
commit7a62c2c6415fdd22d15b64b8a2c15eb33e55e116 (patch)
treea4b442638c448d24068260a31906af53b46910ae /x11-plugins/wmgtemp/wmgtemp-0.7.ebuild
parent*** empty log message *** (diff)
downloadgentoo-2-7a62c2c6415fdd22d15b64b8a2c15eb33e55e116.tar.gz
gentoo-2-7a62c2c6415fdd22d15b64b8a2c15eb33e55e116.tar.bz2
gentoo-2-7a62c2c6415fdd22d15b64b8a2c15eb33e55e116.zip
*** empty log message ***
Diffstat (limited to 'x11-plugins/wmgtemp/wmgtemp-0.7.ebuild')
-rw-r--r--x11-plugins/wmgtemp/wmgtemp-0.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-plugins/wmgtemp/wmgtemp-0.7.ebuild b/x11-plugins/wmgtemp/wmgtemp-0.7.ebuild
new file mode 100644
index 000000000000..16bd87d9bbc3
--- /dev/null
+++ b/x11-plugins/wmgtemp/wmgtemp-0.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmgtemp/wmgtemp-0.7.ebuild,v 1.1 2003/11/16 22:50:49 pyrania Exp $
+
+IUSE=""
+
+DESCRIPTION="CPU and SYS temperature dockapp"
+HOMEPAGE="http://www.fluxcode.net"
+SRC_URI="http://www.fluxcode.net/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="x86 -ppc -sparc amd64"
+
+DEPEND="sys-apps/lm-sensors"
+
+src_compile() {
+ # Set compile optimizations
+ cd ${S}/src
+ cp Makefile Makefile.orig
+ sed -e "s:-Wall -g:\$(CFLAGS):" \
+ Makefile.orig > Makefile
+
+ emake || die "parallel make failed"
+}
+
+src_install() {
+ cd ${S}
+ dodoc BUGS CREDITS INSTALL README TODO
+
+ cd ${S}/src
+ dobin wmgtemp
+}