summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-01-15 08:35:28 +0000
committerSamuli Suominen <drac@gentoo.org>2008-01-15 08:35:28 +0000
commit5f3c903951feccbd3474983c2700620b81b27e88 (patch)
tree0615eec9a97fce7e7bd8264f1c53df48fd2d0167 /x11-plugins/wmfortune
parentmark stable x86 for bug 189910 (diff)
downloadgentoo-2-5f3c903951feccbd3474983c2700620b81b27e88.tar.gz
gentoo-2-5f3c903951feccbd3474983c2700620b81b27e88.tar.bz2
gentoo-2-5f3c903951feccbd3474983c2700620b81b27e88.zip
Fixed QA warnings due to a missing include string.h.
(Portage version: 2.1.4)
Diffstat (limited to 'x11-plugins/wmfortune')
-rw-r--r--x11-plugins/wmfortune/ChangeLog8
-rw-r--r--x11-plugins/wmfortune/files/wmfortune-0.241-stringh.patch11
-rw-r--r--x11-plugins/wmfortune/wmfortune-0.241.ebuild28
3 files changed, 35 insertions, 12 deletions
diff --git a/x11-plugins/wmfortune/ChangeLog b/x11-plugins/wmfortune/ChangeLog
index 2111afe86381..2080cef98e34 100644
--- a/x11-plugins/wmfortune/ChangeLog
+++ b/x11-plugins/wmfortune/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/wmfortune
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmfortune/ChangeLog,v 1.9 2007/07/22 05:08:42 dberkholz Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmfortune/ChangeLog,v 1.10 2008/01/15 08:35:28 drac Exp $
+
+ 15 Jan 2008; Samuli Suominen <drac@gentoo.org>
+ +files/wmfortune-0.241-stringh.patch, wmfortune-0.241.ebuild:
+ Fixed QA warnings due to a missing include string.h.
22 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>;
wmfortune-0.241.ebuild:
diff --git a/x11-plugins/wmfortune/files/wmfortune-0.241-stringh.patch b/x11-plugins/wmfortune/files/wmfortune-0.241-stringh.patch
new file mode 100644
index 000000000000..a8e9f9ff6eda
--- /dev/null
+++ b/x11-plugins/wmfortune/files/wmfortune-0.241-stringh.patch
@@ -0,0 +1,11 @@
+diff -ur wmfortune-0.241.orig/wmfortune.c wmfortune-0.241/wmfortune.c
+--- wmfortune-0.241.orig/wmfortune.c 2001-09-01 03:25:39.000000000 +0300
++++ wmfortune-0.241/wmfortune.c 2008-01-15 10:21:17.000000000 +0200
+@@ -25,6 +25,7 @@
+
+ #include <unistd.h>
+ #include <stdio.h>
++#include <string.h>
+ #include "dockapp.h"
+ #include "XPM/panel.xpm"
+ #include "XPM/panel_button_pressed.xpm"
diff --git a/x11-plugins/wmfortune/wmfortune-0.241.ebuild b/x11-plugins/wmfortune/wmfortune-0.241.ebuild
index cb429768f048..cb3d9ae7f915 100644
--- a/x11-plugins/wmfortune/wmfortune-0.241.ebuild
+++ b/x11-plugins/wmfortune/wmfortune-0.241.ebuild
@@ -1,15 +1,17 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmfortune/wmfortune-0.241.ebuild,v 1.11 2007/07/22 05:08:42 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmfortune/wmfortune-0.241.ebuild,v 1.12 2008/01/15 08:35:28 drac Exp $
-IUSE=""
-DESCRIPTION="dock-app that shows fortune messages"
-HOMEPAGE="http://www.dockapps.com/file.php/id/90"
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="a dockapp showing fortune-mod messages."
+HOMEPAGE="http://dockapps.org/files/90/128"
SRC_URI="http://www.dockapps.com/download.php/id/128/${P}.tar.gz"
LICENSE="GPL-1"
SLOT="0"
-KEYWORDS="x86 amd64 ppc ~sparc"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE=""
RDEPEND="games-misc/fortune-mod
x11-libs/libX11
@@ -19,12 +21,18 @@ DEPEND="${RDEPEND}
x11-proto/xproto
x11-proto/xextproto"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-stringh.patch
+}
+
src_compile() {
- emake OPTIMIZE="${CFLAGS}" || die
+ emake CC="$(tc-getCC)" OPTIMIZE="${CFLAGS}" \
+ XLIBDIR="/usr/$(get_libdir)" || die "emake failed."
}
-src_install()
-{
- dobin wmfortune
+src_install() {
+ dobin ${PN}
dodoc CHANGES README TODO
}