summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2010-08-31 13:31:32 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2010-08-31 13:31:32 +0000
commit87f05c6e4785a3a66f6ba3261895808a9e8bd4f1 (patch)
treef6b68437422c673b4e9ba4c129fe728e33b4877a /x11-plugins/wmdrawer
parentFix exception for ebuilds with missing digests (diff)
downloadgentoo-2-87f05c6e4785a3a66f6ba3261895808a9e8bd4f1.tar.gz
gentoo-2-87f05c6e4785a3a66f6ba3261895808a9e8bd4f1.tar.bz2
gentoo-2-87f05c6e4785a3a66f6ba3261895808a9e8bd4f1.zip
Honour Gentoo LDFLAGS. Closes bug #334005.
Fixed man page installation. (Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'x11-plugins/wmdrawer')
-rw-r--r--x11-plugins/wmdrawer/ChangeLog8
-rw-r--r--x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild13
2 files changed, 16 insertions, 5 deletions
diff --git a/x11-plugins/wmdrawer/ChangeLog b/x11-plugins/wmdrawer/ChangeLog
index cb814f5d6e93..80f1b5d53734 100644
--- a/x11-plugins/wmdrawer/ChangeLog
+++ b/x11-plugins/wmdrawer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/wmdrawer
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmdrawer/ChangeLog,v 1.21 2008/12/02 10:51:54 s4t4n Exp $
+# Copyright 2000-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmdrawer/ChangeLog,v 1.22 2010/08/31 13:31:32 s4t4n Exp $
+
+ 31 Aug 2010; Michele Noberasco <s4t4n@gentoo.org> wmdrawer-0.10.5-r2.ebuild:
+ Honour Gentoo LDFLAGS. Closes bug #334005.
+ Fixed man page installation.
02 Dec 2008; Michele Noberasco <s4t4n@gentoo.org> wmdrawer-0.10.5-r2.ebuild:
Fix LDFLAGS ordering per bug #248640. Some generic QA fixes.
diff --git a/x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild b/x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild
index f611ff24d83f..8cf080c51968 100644
--- a/x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild
+++ b/x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild,v 1.7 2008/12/02 10:51:54 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmdrawer/wmdrawer-0.10.5-r2.ebuild,v 1.8 2010/08/31 13:31:32 s4t4n Exp $
inherit eutils
@@ -30,10 +30,17 @@ src_unpack () {
# Do not auto-strip binaries
sed -i 's/ strip $@//' Makefile || die
+
+ # Honour Gentoo LDFLAGS
+ sed -i 's/$(CC) -o/$(CC) $(REAL_LDFLAGS) -o/' Makefile || die
+}
+
+src_compile() {
+ emake REAL_LDFLAGS="${LDFLAGS}" || die "make failed"
}
src_install() {
dobin wmdrawer
dodoc README TODO AUTHORS ChangeLog wmdrawerrc.example
- doman wmdrawer.1
+ doman doc/wmdrawer.1x.gz
}