summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2008-02-15 07:56:14 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2008-02-15 07:56:14 +0000
commit2f79af41de95544a5162da15f258e098efe13329 (patch)
tree0cd2d925503272cf692ca52a66ba55303331eccd /x11-plugins/wmSun
parentif user has FEATURES=preserve-libs, then we will let portage handle the savin... (diff)
downloadgentoo-2-2f79af41de95544a5162da15f258e098efe13329.tar.gz
gentoo-2-2f79af41de95544a5162da15f258e098efe13329.tar.bz2
gentoo-2-2f79af41de95544a5162da15f258e098efe13329.zip
Revision bump, see bug #207898.
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-plugins/wmSun')
-rw-r--r--x11-plugins/wmSun/ChangeLog7
-rw-r--r--x11-plugins/wmSun/files/wmSun-1.03-makefile.patch45
-rw-r--r--x11-plugins/wmSun/wmSun-1.03-r1.ebuild39
3 files changed, 90 insertions, 1 deletions
diff --git a/x11-plugins/wmSun/ChangeLog b/x11-plugins/wmSun/ChangeLog
index 237692c56715..a6102790f0f6 100644
--- a/x11-plugins/wmSun/ChangeLog
+++ b/x11-plugins/wmSun/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/wmSun
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmSun/ChangeLog,v 1.8 2007/07/22 05:31:27 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmSun/ChangeLog,v 1.9 2008/02/15 07:56:13 s4t4n Exp $
+
+*wmSun-1.03-r1 (15 Feb 2008)
+
+ 15 Feb 2008; Michele Noberasco <s4t4n@gentoo.org> wmSun-1.03-r1.ebuid:
+ Revision bump, see bug #207898.
22 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>; wmSun-1.03.ebuild:
Drop virtual/x11 references.
diff --git a/x11-plugins/wmSun/files/wmSun-1.03-makefile.patch b/x11-plugins/wmSun/files/wmSun-1.03-makefile.patch
new file mode 100644
index 000000000000..1e712ede094e
--- /dev/null
+++ b/x11-plugins/wmSun/files/wmSun-1.03-makefile.patch
@@ -0,0 +1,45 @@
+--- Makefile.orig 1999-01-06 03:28:39.000000000 +0100
++++ Makefile 2008-01-28 14:58:36.000000000 +0100
+@@ -1,8 +1,9 @@
+-CC = gcc
+-CFLAGS = -O2 -Wall
+-INCDIR = -I/usr/X11R6/include/X11
+-DESTDIR= /usr/X11R6
+-LIBDIR = -L/usr/X11R6/lib
++CC ?= gcc
++CFLAGS += -Wall
++INCDIR = -I/usr/include/X11
++PREFIX = /usr
++LIBDIR ?= /usr/lib
++MANDIR = $(PREFIX)/share/man
+
+
+
+@@ -22,14 +23,14 @@
+
+
+ .c.o:
+- $(CC) $(COPTS) -D$(shell echo `uname -s`) -c $< -o $*.o $(INCDIR)
++ $(CC) $(CFLAGS) -D$(shell echo `uname -s`) -c $< -o $*.o $(INCDIR)
+
+
+ all: wmSun.o wmSun
+
+ wmSun.o: wmSun_master.xpm wmSun_mask.xbm
+ wmSun: $(OBJS)
+- $(CC) $(COPTS) $(SYSTEM) -lm -o wmSun $^ $(INCDIR) $(LIBDIR) $(LIBS)
++ $(CC) $(CFLAGS) -lm -o wmSun $^ $(INCDIR) -L$(LIBDIR) $(LDFLAGS) $(LIBS)
+
+ clean:
+ for i in $(OBJS) ; do \
+@@ -38,6 +39,8 @@
+ rm -f wmSun
+
+ install:: wmSun
+- install -s -m 0755 wmSun $(DESTDIR)/bin
+- install -m 0644 wmSun.1 $(DESTDIR)/man/man1
++ install -d $(DESTDIR)$(PREFIX)/bin
++ install -m 0755 wmSun $(DESTDIR)$(PREFIX)/bin
++ install -d $(DESTDIR)$(MANDIR)/man1
++ install -m 0644 wmSun.1 $(DESTDIR)$(MANDIR)/man1
+
diff --git a/x11-plugins/wmSun/wmSun-1.03-r1.ebuild b/x11-plugins/wmSun/wmSun-1.03-r1.ebuild
new file mode 100644
index 000000000000..7112c7e6084a
--- /dev/null
+++ b/x11-plugins/wmSun/wmSun-1.03-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmSun/wmSun-1.03-r1.ebuild,v 1.1 2008/02/15 07:56:13 s4t4n Exp $
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="dockapp which displays the rise/set time of the sun"
+HOMEPAGE="http://dockapps.org/file.php/id/16"
+SRC_URI="http://dockapps.org/download.php/id/23/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~mips ~ppc ~sparc"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto"
+
+S="${WORKDIR}/${P}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ emake clean || die "make clean failed"
+ emake CC="$(tc-getCC)" LIBDIR="/usr/$(get_libdir)" || die "parallel make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc README ../{BUGS,TODO}
+}