summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2011-12-15 18:01:35 +0000
committerIan Whyman <thev00d00@gentoo.org>2011-12-15 18:01:35 +0000
commit877b1d91a50968dea66dd964dd8da1b82024cca0 (patch)
tree475eabd4a62b69760aa67a756b63fc57fefa149d /x11-plugins/pidgin-sipe
parentEAPI=2; tidy (diff)
downloadgentoo-2-877b1d91a50968dea66dd964dd8da1b82024cca0.tar.gz
gentoo-2-877b1d91a50968dea66dd964dd8da1b82024cca0.tar.bz2
gentoo-2-877b1d91a50968dea66dd964dd8da1b82024cca0.zip
Bump pidgin-sipe, add self to maintainers
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/pidgin-sipe')
-rw-r--r--x11-plugins/pidgin-sipe/ChangeLog10
-rw-r--r--x11-plugins/pidgin-sipe/metadata.xml7
-rw-r--r--x11-plugins/pidgin-sipe/pidgin-sipe-1.12.0.ebuild46
3 files changed, 61 insertions, 2 deletions
diff --git a/x11-plugins/pidgin-sipe/ChangeLog b/x11-plugins/pidgin-sipe/ChangeLog
index 7c9b9f5171ae..cb749b6e4ab6 100644
--- a/x11-plugins/pidgin-sipe/ChangeLog
+++ b/x11-plugins/pidgin-sipe/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/pidgin-sipe
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-sipe/ChangeLog,v 1.8 2010/05/24 12:12:35 pva Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-sipe/ChangeLog,v 1.9 2011/12/15 18:01:35 thev00d00 Exp $
+
+*pidgin-sipe-1.12.0 (15 Dec 2011)
+
+ 15 Dec 2011; Ian Whyman <thev00d00@gentoo.org> +pidgin-sipe-1.12.0.ebuild,
+ metadata.xml:
+ Add myself to maintainers, bump to pidgin-sipe-1.12.0
24 May 2010; Peter Volkov <pva@gentoo.org> pidgin-sipe-1.10.0.ebuild:
Fixed -Werror build issue, bug #321275, thank Diego E. 'Flameeyes'
diff --git a/x11-plugins/pidgin-sipe/metadata.xml b/x11-plugins/pidgin-sipe/metadata.xml
index de47931ef9a7..a9088628a7d8 100644
--- a/x11-plugins/pidgin-sipe/metadata.xml
+++ b/x11-plugins/pidgin-sipe/metadata.xml
@@ -2,7 +2,14 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>net-im</herd>
+<maintainer>
+ <email>thev00d00@gentoo.org</email>
+ <name>Ian Whyman</name>
+</maintainer>
<longdescription lang="en">
An Open Implementation of SIP/Simple protocol for Live Communications Server 2003/2005/2007.
</longdescription>
+<use>
+ <flag name="voice">Enable experimental voice/video support</flag>
+</use>
</pkgmetadata>
diff --git a/x11-plugins/pidgin-sipe/pidgin-sipe-1.12.0.ebuild b/x11-plugins/pidgin-sipe/pidgin-sipe-1.12.0.ebuild
new file mode 100644
index 000000000000..88d175769457
--- /dev/null
+++ b/x11-plugins/pidgin-sipe/pidgin-sipe-1.12.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-sipe/pidgin-sipe-1.12.0.ebuild,v 1.1 2011/12/15 18:01:35 thev00d00 Exp $
+
+EAPI=4
+inherit autotools
+
+DESCRIPTION="Pidgin Plug-in SIPE (Sip Exchange Protocol)"
+HOMEPAGE="http://sipe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sipe/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug kerberos voice"
+
+DEPEND="net-im/pidgin
+ dev-util/intltool
+ >=dev-libs/gmime-2.4.16
+ dev-libs/libxml2
+ kerberos? ( app-crypt/mit-krb5 )
+ voice? (
+ >=dev-libs/glib-2.28.0
+ >=net-libs/libnice-0.1.0
+ media-libs/gstreamer )
+ !voice? ( >=dev-libs/glib-2.12.0 )"
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --enable-purple \
+ --disable-quality-check \
+ --disable-kopete \
+ --disable-telepathy \
+ $(use_with voice vv) \
+ $(use_enable debug) \
+ $(use_with kerberos krb5)
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog NEWS TODO README
+}