summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-11-07 17:22:06 +0000
committerMichael Weber <xmw@gentoo.org>2010-11-07 17:22:06 +0000
commit38c5eef14ae7f58789b454fa7a3f5fe11217cca0 (patch)
tree265bd622dc9f1ee256a3b9baec5ea0086772b85f /x11-plugins/pidgin-led-notification
parentdev-lisp/cl-cxml removal, p.masked from 17Sep2010, wrt bug #337963 (diff)
downloadgentoo-2-38c5eef14ae7f58789b454fa7a3f5fe11217cca0.tar.gz
gentoo-2-38c5eef14ae7f58789b454fa7a3f5fe11217cca0.tar.bz2
gentoo-2-38c5eef14ae7f58789b454fa7a3f5fe11217cca0.zip
Initial import
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/pidgin-led-notification')
-rw-r--r--x11-plugins/pidgin-led-notification/ChangeLog11
-rw-r--r--x11-plugins/pidgin-led-notification/files/pidgin-led-notification-0.1-hardware.patch34
-rw-r--r--x11-plugins/pidgin-led-notification/metadata.xml10
-rw-r--r--x11-plugins/pidgin-led-notification/pidgin-led-notification-0.1.ebuild43
4 files changed, 98 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-led-notification/ChangeLog b/x11-plugins/pidgin-led-notification/ChangeLog
new file mode 100644
index 000000000000..f05859696ae4
--- /dev/null
+++ b/x11-plugins/pidgin-led-notification/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-plugins/pidgin-led-notification
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-led-notification/ChangeLog,v 1.1 2010/11/07 17:22:06 xmw Exp $
+
+*pidgin-led-notification-0.1 (07 Nov 2010)
+
+ 07 Nov 2010; Michael Weber <xmw@gentoo.org>
+ +pidgin-led-notification-0.1.ebuild,
+ +files/pidgin-led-notification-0.1-hardware.patch, +metadata.xml:
+ Initial import with patch to support more led hardware
+
diff --git a/x11-plugins/pidgin-led-notification/files/pidgin-led-notification-0.1-hardware.patch b/x11-plugins/pidgin-led-notification/files/pidgin-led-notification-0.1-hardware.patch
new file mode 100644
index 000000000000..aaabada116db
--- /dev/null
+++ b/x11-plugins/pidgin-led-notification/files/pidgin-led-notification-0.1-hardware.patch
@@ -0,0 +1,34 @@
+--- led-notification-0.1/led-notification.c
++++ led-notification-0.1/led-notification.c
+@@ -54,9 +54,9 @@
+ }
+
+ if(state) {
+- fputs("1", file);
++ fputs(purple_prefs_get_string("/plugins/gtk/gtk-simom-lednot/led_on"), file);
+ } else {
+- fputs("0", file);
++ fputs(purple_prefs_get_string("/plugins/gtk/gtk-simom-lednot/led_off"), file);
+ }
+
+ fclose(file);
+@@ -155,6 +155,10 @@
+
+ ent=pidgin_prefs_labeled_entry(vbox2,"File to control led:",
+ "/plugins/gtk/gtk-simom-lednot/filename",sg);
++ ent=pidgin_prefs_labeled_entry(vbox2,"String to turn led on:",
++ "/plugins/gtk/gtk-simom-lednot/led_on",sg);
++ ent=pidgin_prefs_labeled_entry(vbox2,"String to turn led off:",
++ "/plugins/gtk/gtk-simom-lednot/led_off",sg);
+
+ gtk_widget_show_all(frame);
+ return frame;
+@@ -166,6 +170,8 @@
+ purple_prefs_add_string("/plugins/gtk/gtk-simom-lednot/chat", "nick");
+ purple_prefs_add_string("/plugins/gtk/gtk-simom-lednot/filename",
+ "/proc/acpi/asus/mled");
++ purple_prefs_add_string("/plugins/gtk/gtk-simom-lednot/led_on", "1");
++ purple_prefs_add_string("/plugins/gtk/gtk-simom-lednot/led_off", "0");
+ }
+
+ static gboolean plugin_load(PurplePlugin *plugin) {
diff --git a/x11-plugins/pidgin-led-notification/metadata.xml b/x11-plugins/pidgin-led-notification/metadata.xml
new file mode 100644
index 000000000000..02b909e46b7e
--- /dev/null
+++ b/x11-plugins/pidgin-led-notification/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>
+
diff --git a/x11-plugins/pidgin-led-notification/pidgin-led-notification-0.1.ebuild b/x11-plugins/pidgin-led-notification/pidgin-led-notification-0.1.ebuild
new file mode 100644
index 000000000000..fc14238f4947
--- /dev/null
+++ b/x11-plugins/pidgin-led-notification/pidgin-led-notification-0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-led-notification/pidgin-led-notification-0.1.ebuild,v 1.1 2010/11/07 17:22:06 xmw Exp $
+
+EAPI=3
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Pidgin plugin to notify by writining '1's and '0's to (led) control files"
+HOMEPAGE="http://sites.google.com/site/simohmattila/led-notification"
+MY_PN=${PN/pidgin-/}
+MY_P=${MY_PN}-${PV}
+SRC_URI="http://sites.google.com/site/simohmattila/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-im/pidgin
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-hardware.patch
+}
+
+src_compile() {
+ $(tc-getCC) \
+ ${CFLAGS} -fpic $(pkg-config --cflags gtk+-2.0 pidgin) \
+ -shared ${MY_PN}.c -o ${MY_PN}.so \
+ ${LDFLAGS} $(pkg-config --libs gtk+-2.0 pidgin) || die
+}
+
+src_install() {
+ insinto ${EPREFIX}/usr/$(get_libdir)/pidgin
+ insopts -m755
+ doins ${MY_PN}.so || die
+ dodoc README || die
+}