summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-04-15 13:24:07 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-04-15 13:24:07 +0000
commite67441870123a43a225073e22a25eaf1cbf2b807 (patch)
tree057a3b8c0a15e6c191dba6b8e015aa09eaff04ab /x11-plugins/noscript
parentVersion bump, bug #217781 (diff)
downloadgentoo-2-e67441870123a43a225073e22a25eaf1cbf2b807.tar.gz
gentoo-2-e67441870123a43a225073e22a25eaf1cbf2b807.tar.bz2
gentoo-2-e67441870123a43a225073e22a25eaf1cbf2b807.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-plugins/noscript')
-rw-r--r--x11-plugins/noscript/ChangeLog7
-rw-r--r--x11-plugins/noscript/noscript-1.6.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/x11-plugins/noscript/ChangeLog b/x11-plugins/noscript/ChangeLog
index ab8abed86e6b..e948be1e0ea0 100644
--- a/x11-plugins/noscript/ChangeLog
+++ b/x11-plugins/noscript/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/noscript
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/noscript/ChangeLog,v 1.101 2008/04/10 19:08:25 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/noscript/ChangeLog,v 1.102 2008/04/15 13:24:07 armin76 Exp $
+
+*noscript-1.6 (15 Apr 2008)
+
+ 15 Apr 2008; Raúl Porcel <armin76@gentoo.org> +noscript-1.6.ebuild:
+ Version bump
10 Apr 2008; Raúl Porcel <armin76@gentoo.org> +noscript-1.5.8.ebuild:
Version bump
diff --git a/x11-plugins/noscript/noscript-1.6.ebuild b/x11-plugins/noscript/noscript-1.6.ebuild
new file mode 100644
index 000000000000..7f94f902eb41
--- /dev/null
+++ b/x11-plugins/noscript/noscript-1.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/noscript/noscript-1.6.ebuild,v 1.1 2008/04/15 13:24:07 armin76 Exp $
+
+inherit mozextension multilib
+
+DESCRIPTION="Firefox plugin to disable javascript"
+HOMEPAGE="http://noscript.net/"
+SRC_URI="http://software.informaction.com/data/releases/${P}.xpi"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="|| (
+ >=www-client/mozilla-firefox-bin-1.5.0.7
+ >=www-client/mozilla-firefox-1.5.0.7
+)"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}
+
+src_unpack() {
+ xpi_unpack "${P}".xpi
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME
+ if has_version '>=www-client/mozilla-firefox-1.5.0.7'; then
+ MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-firefox"
+ xpi_install "${S}"/"${P}"
+ fi
+ if has_version '>=www-client/mozilla-firefox-bin-1.5.0.7'; then
+ MOZILLA_FIVE_HOME="/opt/firefox"
+ xpi_install "${S}"/"${P}"
+ fi
+}