summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2010-08-28 22:27:59 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2010-08-28 22:27:59 +0000
commitda86b9fcd171d45bd85d8cec30f56cb7973ec8a4 (patch)
treeaf24f062df919b7cb7aed8373afdac2e8d18690f /x11-plugins/msn-pecan
parentwhitespace (diff)
downloadgentoo-2-da86b9fcd171d45bd85d8cec30f56cb7973ec8a4.tar.gz
gentoo-2-da86b9fcd171d45bd85d8cec30f56cb7973ec8a4.tar.bz2
gentoo-2-da86b9fcd171d45bd85d8cec30f56cb7973ec8a4.zip
Version bump, bugfixes
(Portage version: 2.2_rc70/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/msn-pecan')
-rw-r--r--x11-plugins/msn-pecan/ChangeLog8
-rw-r--r--x11-plugins/msn-pecan/msn-pecan-0.1.1.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/x11-plugins/msn-pecan/ChangeLog b/x11-plugins/msn-pecan/ChangeLog
index 1177034328d7..a6ff53bc8c0c 100644
--- a/x11-plugins/msn-pecan/ChangeLog
+++ b/x11-plugins/msn-pecan/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/msn-pecan
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/msn-pecan/ChangeLog,v 1.8 2010/03/07 21:47:14 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/msn-pecan/ChangeLog,v 1.9 2010/08/28 22:27:59 voyageur Exp $
+
+*msn-pecan-0.1.1 (28 Aug 2010)
+
+ 28 Aug 2010; Bernard Cafarelli <voyageur@gentoo.org>
+ +msn-pecan-0.1.1.ebuild:
+ Version bump, bugfixes
*msn-pecan-0.1.0 (07 Mar 2010)
diff --git a/x11-plugins/msn-pecan/msn-pecan-0.1.1.ebuild b/x11-plugins/msn-pecan/msn-pecan-0.1.1.ebuild
new file mode 100644
index 000000000000..f3329cf75439
--- /dev/null
+++ b/x11-plugins/msn-pecan/msn-pecan-0.1.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/msn-pecan/msn-pecan-0.1.1.ebuild,v 1.1 2010/08/28 22:27:59 voyageur Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="Alternative MSN protocol plugin for libpurple"
+HOMEPAGE="http://code.google.com/p/msn-pecan/"
+
+SRC_URI="http://msn-pecan.googlecode.com/files/${P/_/-}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-im/pidgin"
+DEPEND="dev-util/pkgconfig
+ ${RDEPEND}"
+
+S=${WORKDIR}/${P/_/-}
+
+src_prepare() {
+ sed -e "/^LDFLAGS/{s/$/ ${LDFLAGS}/;}" \
+ -e "/^CFLAGS/{s/$/ ${CFLAGS}/;}" -i Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog README TODO || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "Select the 'WLM' protocol to use this plugin"
+ einfo
+ elog "For more information (how to change personal message, add"
+ elog "missing emoticons, ...), please read:"
+ elog "http://code.google.com/p/msn-pecan/wiki/FAQ"
+}