summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2007-03-20 20:15:41 +0000
committerJim Ramsay <lack@gentoo.org>2007-03-20 20:15:41 +0000
commitcd84a67154268543a304b857ae598a9a7951047d (patch)
tree58adb8e74adbad9e81fd15ccb408e70dad4fc1e5 /x11-plugins/gkrelltop
parentTake maintainership. (diff)
downloadgentoo-2-cd84a67154268543a304b857ae598a9a7951047d.tar.gz
gentoo-2-cd84a67154268543a304b857ae598a9a7951047d.tar.bz2
gentoo-2-cd84a67154268543a304b857ae598a9a7951047d.zip
Fixed headless (USE="-X") build issue
(Portage version: 2.1.2-r10)
Diffstat (limited to 'x11-plugins/gkrelltop')
-rw-r--r--x11-plugins/gkrelltop/ChangeLog5
-rw-r--r--x11-plugins/gkrelltop/gkrelltop-2.2.6-r1.ebuild11
2 files changed, 12 insertions, 4 deletions
diff --git a/x11-plugins/gkrelltop/ChangeLog b/x11-plugins/gkrelltop/ChangeLog
index 32b10e454a26..3949fc0518db 100644
--- a/x11-plugins/gkrelltop/ChangeLog
+++ b/x11-plugins/gkrelltop/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-plugins/gkrelltop
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrelltop/ChangeLog,v 1.18 2007/03/12 17:40:26 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrelltop/ChangeLog,v 1.19 2007/03/20 20:15:41 lack Exp $
+
+ 20 Mar 2007; Jim Ramsay <lack@gentoo.org> gkrelltop-2.2.6-r1.ebuild:
+ Fixed headless (USE="-X") build issue
12 Mar 2007; Jim Ramsay <lack@gentoo.org> -gkrelltop-2.2.ebuild,
-gkrelltop-2.2.2.ebuild, -gkrelltop-2.2.3.ebuild, gkrelltop-2.2.4.ebuild,
diff --git a/x11-plugins/gkrelltop/gkrelltop-2.2.6-r1.ebuild b/x11-plugins/gkrelltop/gkrelltop-2.2.6-r1.ebuild
index 3ad82b9fce79..7338ff8b4ad5 100644
--- a/x11-plugins/gkrelltop/gkrelltop-2.2.6-r1.ebuild
+++ b/x11-plugins/gkrelltop/gkrelltop-2.2.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrelltop/gkrelltop-2.2.6-r1.ebuild,v 1.2 2007/03/12 17:40:26 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrelltop/gkrelltop-2.2.6-r1.ebuild,v 1.3 2007/03/20 20:15:41 lack Exp $
inherit gkrellm-plugin
@@ -20,8 +20,13 @@ PLUGIN_SO=gkrelltop2.so
src_compile() {
# Unfortunately, the supplied Makefile won't work properly on
# non-x86, so we have to do this the hard way.
- CONFIG="-DLINUX -DGKRELLM2 -fPIC `pkg-config gtk+-2.0 --cflags`"
- LIBS="`pkg-config gtk+-2.0 --libs` -shared"
+ if built_with_use app-admin/gkrellm X; then
+ PKGCFG_ITEM="gtk+-2.0"
+ else
+ PKGCFG_ITEM="glib-2.0"
+ fi
+ CONFIG="-DLINUX -DGKRELLM2 -fPIC `pkg-config ${PKGCFG_ITEM} --cflags`"
+ LIBS="`pkg-config ${PKGCFG_ITEM} --libs` -shared"
OBJS="top_three2.o"
XOBJS="${OBJS} gkrelltop2.o"
DOBJS="${OBJS} gkrelltopd.o"