summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-11-10 04:52:25 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-11-10 04:52:25 +0000
commita3222452fa92cac5d1921b9f97f74b9d7f4783a8 (patch)
tree4ca964b89ff4a9fcf2ff06d130884c876bda3453 /x11-plugins/gkrellsun
parentFixing access violations (diff)
downloadgentoo-2-a3222452fa92cac5d1921b9f97f74b9d7f4783a8.tar.gz
gentoo-2-a3222452fa92cac5d1921b9f97f74b9d7f4783a8.tar.bz2
gentoo-2-a3222452fa92cac5d1921b9f97f74b9d7f4783a8.zip
version bump
Diffstat (limited to 'x11-plugins/gkrellsun')
-rw-r--r--x11-plugins/gkrellsun/ChangeLog9
-rw-r--r--x11-plugins/gkrellsun/files/digest-gkrellsun-0.91
-rw-r--r--x11-plugins/gkrellsun/gkrellsun-0.9.ebuild50
3 files changed, 59 insertions, 1 deletions
diff --git a/x11-plugins/gkrellsun/ChangeLog b/x11-plugins/gkrellsun/ChangeLog
index bf2b5ce21988..b3c766407199 100644
--- a/x11-plugins/gkrellsun/ChangeLog
+++ b/x11-plugins/gkrellsun/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-plugins/gkrellsun
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellsun/ChangeLog,v 1.2 2002/09/12 05:19:36 owen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellsun/ChangeLog,v 1.3 2002/11/10 04:52:25 seemant Exp $
+
+*gkrellsun-0.9 (09 Nov 2002)
+
+ 09 Nov 2002; Seemant Kulleen <seemant@gentoo.org> gkrellsun-0.9.ebuild
+ files/digest-gkrellsun-0.9 :
+
+ Version bump -- works with both versions of gkrellm.
*gkrellsun-0.2 (19 Feb 2002)
diff --git a/x11-plugins/gkrellsun/files/digest-gkrellsun-0.9 b/x11-plugins/gkrellsun/files/digest-gkrellsun-0.9
new file mode 100644
index 000000000000..3f0c2b314041
--- /dev/null
+++ b/x11-plugins/gkrellsun/files/digest-gkrellsun-0.9
@@ -0,0 +1 @@
+MD5 6a22bf1d25f091628d05481fc5907711 gkrellsun-0.9.tar.gz 67415
diff --git a/x11-plugins/gkrellsun/gkrellsun-0.9.ebuild b/x11-plugins/gkrellsun/gkrellsun-0.9.ebuild
new file mode 100644
index 000000000000..b80224a10dbd
--- /dev/null
+++ b/x11-plugins/gkrellsun/gkrellsun-0.9.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellsun/gkrellsun-0.9.ebuild,v 1.1 2002/11/10 04:52:25 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A GKrellM plugin that shows sunrise and sunset times."
+SRC_URI="mirror://sourceforge/gkrellsun/${P}.tar.gz"
+HOMEPAGE="http://gkrellsun.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc sparc64"
+
+DEPEND="app-admin/gkrellm
+ >=media-libs/imlib-1.9.10-r1"
+
+src_compile() {
+
+ if [ -f /usr/bin/gkrellm ]
+ then
+ cd ${S}/src
+ emake || die
+ fi
+
+ if [ -f /usr/bin/gkrellm2 ]
+ then
+ cd ${S}/src20
+ emake || die
+ fi
+
+}
+
+src_install () {
+
+ dodoc README AUTHORS COPYING
+
+ if [ -f /usr/bin/gkrellm ]
+ then
+ cd ${S}/src
+ insinto /usr/lib/gkrellm/plugins
+ doins gkrellsun.so
+ fi
+
+ if [ -f /usr/bin/gkrellm2 ]
+ then
+ cd ${S}/src20
+ insinto /usr/lib/gkrellm2/plugins
+ doins gkrellsun.so
+ fi
+}