summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSantiago M. Mola <coldwind@gentoo.org>2008-01-11 22:39:27 +0000
committerSantiago M. Mola <coldwind@gentoo.org>2008-01-11 22:39:27 +0000
commitdd0ea6ef9a843f1660986d523059551791b77183 (patch)
tree26801043561cf5ef728f0085efab62cde8e4d884 /x11-plugins/gkrellm-hddtemp
parentAdd pkgconfig to DEPEND, #205016 (diff)
downloadgentoo-2-dd0ea6ef9a843f1660986d523059551791b77183.tar.gz
gentoo-2-dd0ea6ef9a843f1660986d523059551791b77183.tar.bz2
gentoo-2-dd0ea6ef9a843f1660986d523059551791b77183.zip
Add missing deps (#204574), check if gkrellm is built with USE=X, migrate to elog, misc QA fixes.
(Portage version: 2.1.3.19)
Diffstat (limited to 'x11-plugins/gkrellm-hddtemp')
-rw-r--r--x11-plugins/gkrellm-hddtemp/ChangeLog9
-rw-r--r--x11-plugins/gkrellm-hddtemp/gkrellm-hddtemp-0.2_beta-r1.ebuild36
2 files changed, 31 insertions, 14 deletions
diff --git a/x11-plugins/gkrellm-hddtemp/ChangeLog b/x11-plugins/gkrellm-hddtemp/ChangeLog
index 58510f6a020c..ac45390758c6 100644
--- a/x11-plugins/gkrellm-hddtemp/ChangeLog
+++ b/x11-plugins/gkrellm-hddtemp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/gkrellm-hddtemp
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-hddtemp/ChangeLog,v 1.20 2007/02/21 20:04:30 lack Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-hddtemp/ChangeLog,v 1.21 2008/01/11 22:39:27 coldwind Exp $
+
+ 11 Jan 2008; Santiago M. Mola <coldwind@gentoo.org>
+ gkrellm-hddtemp-0.2_beta-r1.ebuild:
+ Add missing deps (#204574), check if gkrellm is built with USE=X, migrate to
+ elog, misc QA fixes.
*gkrellm-hddtemp-0.2_beta-r1 (21 Feb 2007)
diff --git a/x11-plugins/gkrellm-hddtemp/gkrellm-hddtemp-0.2_beta-r1.ebuild b/x11-plugins/gkrellm-hddtemp/gkrellm-hddtemp-0.2_beta-r1.ebuild
index cae676731a15..b779fd3fc401 100644
--- a/x11-plugins/gkrellm-hddtemp/gkrellm-hddtemp-0.2_beta-r1.ebuild
+++ b/x11-plugins/gkrellm-hddtemp/gkrellm-hddtemp-0.2_beta-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-hddtemp/gkrellm-hddtemp-0.2_beta-r1.ebuild,v 1.1 2007/02/21 20:04:30 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-hddtemp/gkrellm-hddtemp-0.2_beta-r1.ebuild,v 1.2 2008/01/11 22:39:27 coldwind Exp $
-inherit multilib
+inherit eutils multilib
IUSE=""
MY_P=${P/_beta/-beta}
@@ -15,14 +15,26 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="amd64 ppc sparc x86"
-DEPEND="=app-admin/gkrellm-2*"
-RDEPEND="${DEPEND}
+CDEPEMD="=app-admin/gkrellm-2*
+ >=x11-libs/gtk+-2"
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${CDEPEND}
>=app-admin/hddtemp-0.3_beta6"
+pkg_setup() {
+ if ! built_with_use app-admin/gkrellm X ; then
+ eerror "In order to install ${PN} you need to"
+ eerror "reinstall app-admin/gkrell with USE='X'."
+ die "app-admin/gkrellm built without USE='X'"
+ fi
+}
+
src_unpack() {
- unpack ${A} ; cd ${S}
+ unpack ${A}
+ cd "${S}"
# patch Makefile
- sed -i "s:^CFLAGS.*:CFLAGS=${CFLAGS} -fPIC:" Makefile
+ sed -i "s:^CFLAGS.*:CFLAGS=${CFLAGS} -fPIC:" Makefile || die
}
src_compile() {
@@ -30,15 +42,15 @@ src_compile() {
}
src_install() {
- dodoc README COPYING
+ dodoc README
insinto /usr/$(get_libdir)/gkrellm2/plugins
doins gkrellm-hddtemp.so
}
pkg_postinst() {
- einfo "hddtemp has to be suid root to allow regular users to run this plugin."
- einfo "To make it suid root, run"
- einfo
- einfo "\tchmod u+s /usr/sbin/hddtemp"
+ elog "hddtemp has to be suid root to allow regular users to run this plugin."
+ elog "To make it suid root, run"
+ elog
+ elog "\tchmod u+s /usr/sbin/hddtemp"
}